summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2014-04-10 19:06:38 +0200
committerJustus Winter <4winter@informatik.uni-hamburg.de>2014-04-10 19:06:38 +0200
commitb3f03a48cab64cdc8a4cdf25d82ad1882913ae6d (patch)
tree24a663926b44f96198dea062d8a73b2fd69ffbde /debian
parent81cbf8ae79a37de4e9c5363aea60cec7ed2e457e (diff)
add boot_remove_ourdevice_hack.patch
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/boot_remove_ourdevice_hack.patch37
-rw-r--r--debian/patches/series1
2 files changed, 38 insertions, 0 deletions
diff --git a/debian/patches/boot_remove_ourdevice_hack.patch b/debian/patches/boot_remove_ourdevice_hack.patch
new file mode 100644
index 00000000..b5c6f82e
--- /dev/null
+++ b/debian/patches/boot_remove_ourdevice_hack.patch
@@ -0,0 +1,37 @@
+diff --git a/boot/Makefile b/boot/Makefile
+index 0d883b0..2d52f3f 100644
+--- a/boot/Makefile
++++ b/boot/Makefile
+@@ -20,7 +20,7 @@ makemode := utility
+
+ SRCS = mach-crt0.c boot.c ux.c sigvec.S syscall.S \
+ boot_script.c userland-boot.c
+-COMMON-OBJS = notifyServer.o ourdeviceServer.o \
++COMMON-OBJS = notifyServer.o deviceServer.o \
+ ioServer.o io_replyUser.o device_replyUser.o \
+ termServer.o bootstrapServer.o boot_script.o userland-boot.o
+ OBJS = boot.o $(COMMON-OBJS)
+@@ -39,10 +39,6 @@ include ../Makeconf
+
+ all: boot # uxboot
+
+-ourdevice.defs: device.defs
+- $(CPP) $(CPPFLAGS) -x c $< | sed -e '/out[ ]*device[ ]*:[ ]*device_t/s/device_t/mach_port_send_t/' > $@
+-
+-
+ uxboot.o: boot.c
+ $(COMPILE.c) -DUX $< -o $@
+
+diff --git a/boot/boot.c b/boot/boot.c
+index 0dbe1c2..ed29014 100644
+--- a/boot/boot.c
++++ b/boot/boot.c
+@@ -42,7 +42,7 @@ the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
+ #include <version.h>
+
+ #include "notify_S.h"
+-#include "ourdevice_S.h"
++#include "device_S.h"
+ #include "io_S.h"
+ #include "device_reply_U.h"
+ #include "io_reply_U.h"
diff --git a/debian/patches/series b/debian/patches/series
index 65769bfb..4650ee92 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -42,3 +42,4 @@ xkb-compat.patch
xxx-fix-build.patch
mach-defpager-protected-payload.patch
#ext2fs-skip-unallocated-blocks.patch
+boot_remove_ourdevice_hack.patch