summaryrefslogtreecommitdiff
path: root/debian/patches/boot_remove_ourdevice_hack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/boot_remove_ourdevice_hack.patch')
-rw-r--r--debian/patches/boot_remove_ourdevice_hack.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/patches/boot_remove_ourdevice_hack.patch b/debian/patches/boot_remove_ourdevice_hack.patch
new file mode 100644
index 00000000..b5c6f82e
--- /dev/null
+++ b/debian/patches/boot_remove_ourdevice_hack.patch
@@ -0,0 +1,37 @@
+diff --git a/boot/Makefile b/boot/Makefile
+index 0d883b0..2d52f3f 100644
+--- a/boot/Makefile
++++ b/boot/Makefile
+@@ -20,7 +20,7 @@ makemode := utility
+
+ SRCS = mach-crt0.c boot.c ux.c sigvec.S syscall.S \
+ boot_script.c userland-boot.c
+-COMMON-OBJS = notifyServer.o ourdeviceServer.o \
++COMMON-OBJS = notifyServer.o deviceServer.o \
+ ioServer.o io_replyUser.o device_replyUser.o \
+ termServer.o bootstrapServer.o boot_script.o userland-boot.o
+ OBJS = boot.o $(COMMON-OBJS)
+@@ -39,10 +39,6 @@ include ../Makeconf
+
+ all: boot # uxboot
+
+-ourdevice.defs: device.defs
+- $(CPP) $(CPPFLAGS) -x c $< | sed -e '/out[ ]*device[ ]*:[ ]*device_t/s/device_t/mach_port_send_t/' > $@
+-
+-
+ uxboot.o: boot.c
+ $(COMPILE.c) -DUX $< -o $@
+
+diff --git a/boot/boot.c b/boot/boot.c
+index 0dbe1c2..ed29014 100644
+--- a/boot/boot.c
++++ b/boot/boot.c
+@@ -42,7 +42,7 @@ the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
+ #include <version.h>
+
+ #include "notify_S.h"
+-#include "ourdevice_S.h"
++#include "device_S.h"
+ #include "io_S.h"
+ #include "device_reply_U.h"
+ #include "io_reply_U.h"