summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/pfinet_local_port_range.patch27
-rw-r--r--debian/patches/series1
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a9921b4b..28ed6337 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,8 @@ hurd (20121127-1~0) UNRELEASED; urgency=low
support to pthread.
* control: Add missing libx11-dev, x11proto-core-dev, pkg-config, xkb-data,
flex, and bison build-dependencies.
+ * New upstream patch patches/pfinet_local_port_range.patch to increase
+ number of available local ports.
-- Samuel Thibault <sthibault@debian.org> Sun, 15 Jul 2012 12:53:39 +0200
diff --git a/debian/patches/pfinet_local_port_range.patch b/debian/patches/pfinet_local_port_range.patch
new file mode 100644
index 00000000..3103b8ae
--- /dev/null
+++ b/debian/patches/pfinet_local_port_range.patch
@@ -0,0 +1,27 @@
+commit 23c9bbee12b08bcbc82188dabe3bf8135756c183
+Author: Richard Braun <rbraun@sceen.net>
+Date: Thu Dec 6 23:16:54 2012 +0000
+
+ pfinet: increase local port range
+
+ * pfinet/linux-src/net/ipv4/tcp_ipv4.c (sysctl_local_port_range): Set port
+ range to 32768-61000.
+
+merged upstream
+
+diff --git a/pfinet/linux-src/net/ipv4/tcp_ipv4.c b/pfinet/linux-src/net/ipv4/tcp_ipv4.c
+index 9919423..60d2bdb 100644
+--- a/pfinet/linux-src/net/ipv4/tcp_ipv4.c
++++ b/pfinet/linux-src/net/ipv4/tcp_ipv4.c
+@@ -113,7 +113,11 @@ struct sock *tcp_regs[TCP_NUM_REGS];
+ * For high-usage systems, use sysctl to change this to
+ * 32768-61000
+ */
++#if 0
+ int sysctl_local_port_range[2] = { 1024, 4999 };
++#else
++int sysctl_local_port_range[2] = { 32768, 61000 };
++#endif
+ int tcp_port_rover = (1024 - 1);
+
+ static __inline__ int tcp_hashfn(__u32 laddr, __u16 lport,
diff --git a/debian/patches/series b/debian/patches/series
index 299b9452..44e45af1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -41,3 +41,4 @@ libmachdev.patch
exec_filename_exec.patch
exec_filename_fs.patch
exec_filename_use.patch
+pfinet_local_port_range.patch