summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index a77987f7..c403e841 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,7 +9,11 @@ hurd (20040508-4) UNRELEASED; urgency=low
succeeds. (Closes: #273508)
[ Guillem Jover ]
- * debian/hurd.postinst: Move /bin/login suid root chmod to debian/rules.
+ * debian/hurd.postinst:
+ - Move /bin/login suid root chmod to debian/rules.
+ - Set suid bit to other binaries (/bin/ps, /bin/ids, /bin/w).
+ (Closes: #273507)
+ Thanks Ognyan Kulev <ogi@fmi.uni-sofia.bg>.
-- Michael Banck <mbanck@debian.org> Tue, 21 Sep 2004 19:23:51 +0200
diff --git a/debian/rules b/debian/rules
index 51ccf189..a6c28fdf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,6 +33,8 @@ install/hurd::
# runsystem is managed by update-alternatives
mv debian/tmp/libexec/runsystem debian/tmp/libexec/runsystem.gnu
+SUID_PROGRAMS = /bin/ids /bin/login /bin/ps /bin/w
+
binary-predeb/hurd::
- chmod u+s $(CURDIR)/debian/$(cdbs_curpkg)/bin/login
+ chmod u+s $(patsubst %, $(CURDIR)/debian/$(cdbs_curpkg)%, $(SUID_PROGRAMS))