summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/ext2fs_large_stores.patch21
2 files changed, 15 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 2fe66f6a..af029247 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,9 @@ hurd (20050513-6+SVN) unreleased; urgency=low
when generating the standard devices.
* debian/hurd.postinst: Create /dev/shm directory if not present
already.
+ * debian/patches/ext2fs_large_stores.patch: Include <hurd/pager.h>
+ rather than "../libpager/pager.h" and add pager.h to libdiskfs'
+ HURDLIBS.
-- Michael Banck <mbanck@debian.org> Tue, 17 Jan 2006 22:16:33 +0100
diff --git a/debian/patches/ext2fs_large_stores.patch b/debian/patches/ext2fs_large_stores.patch
index 75c951a3..d872a1fd 100644
--- a/debian/patches/ext2fs_large_stores.patch
+++ b/debian/patches/ext2fs_large_stores.patch
@@ -1968,15 +1968,6 @@ diff -urpN --exclude='*~' --exclude=build ../cvs/hurd/libdiskfs/diskfs-pager.h h
Written by Roland McGrath.
This program is free software; you can redistribute it and/or
-@@ -19,7 +19,7 @@
- #ifndef _HURD_DISKFS_PAGER_H
- #define _HURD_DISKFS_PAGER_H 1
-
--#include <hurd/pager.h>
-+#include "../libpager/pager.h"
- #include <hurd/ports.h>
- #include <setjmp.h>
- #include <cthreads.h>
@@ -33,7 +33,8 @@
mapped is returned in IMAGE. INFO, PAGER_BUCKET, & MAY_CACHE are passed
to `pager_create'. */
@@ -2403,3 +2394,15 @@ diff -urpN --exclude='*~' --exclude=build ../cvs/hurd/ufs/pager.c hurd/ufs/pager
if (upi->p == 0)
{
diskfs_nrele_light (np);
+--- hurd/libdiskfs/Makefile 2006-04-14 16:29:02.000000000 +0200
++++ hurd/libdiskfs/Makefileorig 2006-04-14 16:27:55.000000000 +0200
+@@ -61,7 +61,7 @@
+ startup_notifyServer.o
+ OBJS = $(sort $(SRCS:.c=.o) $(MIGSTUBS))
+
+-HURDLIBS = fshelp iohelp store threads ports shouldbeinlibc
++HURDLIBS = fshelp iohelp store threads ports shouldbeinlibc pager
+
+ fsys-MIGSFLAGS = -imacros $(srcdir)/fsmutations.h -DREPLY_PORTS
+ fs-MIGSFLAGS = -imacros $(srcdir)/fsmutations.h
+