summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/feature-proc-set-task-name-to-pid.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/debian/patches/feature-proc-set-task-name-to-pid.patch b/debian/patches/feature-proc-set-task-name-to-pid.patch
index abe40ff0..73506883 100644
--- a/debian/patches/feature-proc-set-task-name-to-pid.patch
+++ b/debian/patches/feature-proc-set-task-name-to-pid.patch
@@ -1,42 +1,3 @@
-diff --git a/exec/main.c b/exec/main.c
-index c1f347c..27f33b1 100644
---- a/exec/main.c
-+++ b/exec/main.c
-@@ -200,7 +200,7 @@ kern_return_t
- S_exec_init (struct trivfs_protid *protid,
- auth_t auth, process_t proc)
- {
-- mach_port_t host_priv, startup;
-+ mach_port_t host_priv, device_master, startup;
- error_t err;
-
- if (! protid || ! protid->isroot)
-@@ -232,9 +232,22 @@ S_exec_init (struct trivfs_protid *protid,
- mach_port_deallocate (mach_task_self (), right);
- }
-
-- err = get_privileged_ports (&host_priv, NULL);
-+ err = get_privileged_ports (&host_priv, &device_master);
- assert_perror (err);
-
-+ {
-+ /* Get our stderr set up to print on the console, in case we have
-+ to panic or something. */
-+ mach_port_t cons;
-+ error_t err;
-+ err = device_open (device_master, D_READ|D_WRITE, "console", &cons);
-+ assert_perror (err);
-+ mach_port_deallocate (mach_task_self (), device_master);
-+ stdin = mach_open_devstream (cons, "r");
-+ stdout = stderr = mach_open_devstream (cons, "w");
-+ mach_port_deallocate (mach_task_self (), cons);
-+ }
-+
- proc_register_version (procserver, host_priv, "exec", "", HURD_VERSION);
-
- err = proc_getmsgport (procserver, HURD_PID_STARTUP, &startup);
-diff --git a/proc/Makefile b/proc/Makefile
-index 2eed13c..7f1296a 100644
--- a/proc/Makefile
+++ b/proc/Makefile
@@ -29,7 +29,7 @@ MIGSFLAGS="-DPROCESS_INTRAN=pstruct_t reqport_find (process_t)" \