summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/mount-loop.patch20
-rw-r--r--debian/patches/series1
3 files changed, 22 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c516e854..0cd38792 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ hurd (20130620-1.1) UNRELEASED; urgency=low
* patches/mount-{f,n,remount}.patch: New patches from Justus Winter to make
mount more compatible with Linux'.
+ * patches/mount-loop.patch: New patch to ignore loop option.
-- Samuel Thibault <sthibault@debian.org> Wed, 19 Jun 2013 23:32:07 +0000
diff --git a/debian/patches/mount-loop.patch b/debian/patches/mount-loop.patch
new file mode 100644
index 00000000..07f572be
--- /dev/null
+++ b/debian/patches/mount-loop.patch
@@ -0,0 +1,20 @@
+mount: Ignore `loop' option
+
+* utils/mount.c (do_mount): Ignore `loop' option.
+---
+ mount.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+diff --git a/utils/mount.c b/utils/mount.c
+index 8b059c2..8af055e 100644
+--- a/utils/mount.c
++++ b/utils/mount.c
+@@ -248,7 +248,8 @@ do_mount (struct fs *fs, int remount)
+ {
+ ARGZ (add (&fsopts, &fsopts_len, o));
+ }
+- else if (strcmp (o, "defaults") != 0)
++ else if (strcmp (o, "defaults") != 0 &&
++ strcmp (o, "loop") != 0)
+ {
+ /* Prepend `--' to the option to make a long option switch,
+ e.g. `--ro' or `--rsize=1024'. */
diff --git a/debian/patches/series b/debian/patches/series
index e8f140a3..d902bd8e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -44,3 +44,4 @@ exec_filename_use.patch
mount-n.patch
mount-f.patch
mount-remount.patch
+mount-loop.patch