summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/libpthread_pthreadtypes_h.patch2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 20573a16..4dd1958e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,8 @@ hurd (20080607-4) UNRELEASED; urgency=low
* debian/patches/libpthread_spin-lock-inline.patch: New patch to split off
inlines from spin-lock.h into spin-lock-inline.h to avoid including too
many headers from pthreadtypes.h (fixes glibc 2.7-13 compilation).
+ * debian/patches/libpthread_pthreadtypes_h.patch: Remove comma at end of
+ enumeration.
-- Michael Banck <mbanck@debian.org> Sat, 12 Jul 2008 16:45:36 +0200
diff --git a/debian/patches/libpthread_pthreadtypes_h.patch b/debian/patches/libpthread_pthreadtypes_h.patch
index e1e92c78..3f26b5ee 100644
--- a/debian/patches/libpthread_pthreadtypes_h.patch
+++ b/debian/patches/libpthread_pthreadtypes_h.patch
@@ -328,7 +328,7 @@ diff -N include/pthread/pthreadtypes.h
+enum __pthread_contentionscope
+ {
+ __PTHREAD_SCOPE_SYSTEM = 0,
-+ __PTHREAD_SCOPE_PROCESS,
++ __PTHREAD_SCOPE_PROCESS
+ };
+
+/* Possible values for the `detachstate' attribute. */