summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/external-splitinit.patch55
-rw-r--r--debian/patches/series5
2 files changed, 59 insertions, 1 deletions
diff --git a/debian/patches/external-splitinit.patch b/debian/patches/external-splitinit.patch
new file mode 100644
index 00000000..a2ba6c82
--- /dev/null
+++ b/debian/patches/external-splitinit.patch
@@ -0,0 +1,55 @@
+Include procfs, random, and DDE in the build
+
+diff --git a/Makefile b/Makefile
+index 0b9eff2..12b56f0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,8 @@ include ./Makeconf
+ # Hurd libraries
+ lib-subdirs = libshouldbeinlibc libihash libiohelp libports libthreads \
+ libpager libfshelp libdiskfs libtrivfs libps \
+- libnetfs libpipe libstore libhurdbugaddr libftpconn libcons
++ libnetfs libpipe libstore libhurdbugaddr libftpconn libcons \
++ libmachdev libbpf libddekit libhurd-slab eth-filter eth-multiplexer
+
+ # Hurd programs
+ prog-subdirs = auth proc exec term \
+@@ -40,8 +41,9 @@ prog-subdirs = auth proc exec init term \
+ benchmarks fstests \
+ random \
+ procfs \
+ startup \
+ init \
++ devnode \
+
+ ifeq ($(HAVE_SUN_RPC),yes)
+ prog-subdirs += nfs nfsd
+--- hurd-debian.orig/Makeconf
++++ hurd-debian/Makeconf
+@@ -548,6 +548,6 @@ vpath %.defs $(top_srcdir)/hurd
+ # These we want to find in the libc include directory...
+ mach_defs_names = bootstrap exc mach mach4 \
+ mach_host mach_port mach_timer_reply memory_object \
+- memory_object_default notify
++ memory_object_default notify experimental
+ mach_debug_defs_names = mach_debug
+ device_defs_names = dev_forward device device_reply device_request
+
+ mach_defs = $(addsuffix .defs,$(mach_defs_names))
+diff --git a/configure.ac b/configure.ac
+index 05b959b..68ec159 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -227,6 +227,12 @@ AC_SUBST(boot_store_types)dnl
+ AC_MSG_CHECKING(boot store types)
+ AC_MSG_RESULT($boot_store_types)
+
++AC_CHECK_LIB(pciaccess, pci_system_init, LIBPCIACCESS=-lpciaccess, LIBPCIACCESS=no)
++AC_SUBST(LIBPCIACCESS)
++if test "$LIBPCIACCESS" = "no"; then
++ AC_MSG_ERROR([libpciaccess must be install in order to use libddekit])
++fi
++
+ # Check for ncursesw, which is needed for the console-curses client.
+ hurd_LIB_NCURSESW
+
diff --git a/debian/patches/series b/debian/patches/series
index 0e06799b..0afa2a67 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -23,7 +23,10 @@ tmp_exec_startup.patch
uptime_w_path_fix.patch
stat_round.patch
proxy-defpager.diff
-external.patch
+
+#external.patch
+external-splitinit.patch
+
console_ignore_bdf_err.patch
posix-sigcodes.patch
random-default-fast.patch