summaryrefslogtreecommitdiff
path: root/debian/patches/external.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/external.patch')
-rw-r--r--debian/patches/external.patch61
1 files changed, 38 insertions, 23 deletions
diff --git a/debian/patches/external.patch b/debian/patches/external.patch
index a283b69a..e4c25d4b 100644
--- a/debian/patches/external.patch
+++ b/debian/patches/external.patch
@@ -1,34 +1,35 @@
Include DDE in the build
-TODO: We should turn AC_MSG_WARN into disabling targets
-
-Index: hurd-debian/Makefile
-===================================================================
---- hurd-debian.orig/Makefile
-+++ hurd-debian/Makefile
-@@ -28,8 +28,8 @@ include ./Makeconf
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,16 @@ include ./Makeconf
# Hurd libraries
lib-subdirs = libshouldbeinlibc libihash libiohelp libports libthreads \
libpager libfshelp libdiskfs libtrivfs libps \
- libnetfs libpipe libstore libhurdbugaddr libftpconn libcons \
-- libhurd-slab
-+ libhurd-slab libmachdev libbpf libddekit libhurd-slab
+- libnetfs libpipe libstore libhurdbugaddr libftpconn libcons
++ libnetfs libpipe libstore libhurdbugaddr libftpconn libcons \
++ libbpf libhurd-slab eth-multiplexer
++
++ifneq ($(LIBPCIACCESS),no)
++lib-subdirs += libmachdev libddekit
++endif
++
++ifeq ($(HAVE_PCAP),yes)
++lib-subdirs += eth-filter
++endif
# Hurd programs
prog-subdirs = auth proc exec term \
-@@ -37,6 +38,8 @@ prog-subdirs = auth proc exec init term
+@@ -42,6 +51,7 @@ prog-subdirs = auth proc exec term \
procfs \
startup \
init \
-+ eth-filter \
-+ eth-multiplexer \
++ devnode
ifeq ($(HAVE_SUN_RPC),yes)
prog-subdirs += nfs nfsd
-Index: hurd-debian/Makeconf
-===================================================================
---- hurd-debian.orig/Makeconf
-+++ hurd-debian/Makeconf
+--- a/Makeconf
++++ b/Makeconf
@@ -576,7 +576,7 @@ vpath %.defs $(top_srcdir)/hurd
# These we want to find in the libc include directory...
mach_defs_names = bootstrap exc mach mach4 \
@@ -38,20 +39,34 @@ Index: hurd-debian/Makeconf
gnumach \
task_notify \
-Index: hurd-debian/configure.ac
-===================================================================
---- hurd-debian.orig/configure.ac
-+++ hurd-debian/configure.ac
-@@ -241,6 +241,12 @@ AC_SUBST(boot_store_types)dnl
+--- a/configure.ac
++++ b/configure.ac
+@@ -245,6 +245,13 @@ AC_SUBST(boot_store_types)dnl
AC_MSG_CHECKING(boot store types)
AC_MSG_RESULT($boot_store_types)
+AC_CHECK_LIB(pciaccess, pci_system_init, LIBPCIACCESS=-lpciaccess, LIBPCIACCESS=no)
+AC_SUBST(LIBPCIACCESS)
+if test "$LIBPCIACCESS" = "no"; then
-+ AC_MSG_WARN([libpciaccess must be install in order to use libddekit])
++ AC_MSG_WARN([libpciaccess must be installed in order to use libddekit])
+fi
++AC_CHECK_HEADER([pcap.h], [HAVE_PCAP=yes], [HAVE_PCAP=no])
+
# Check for ncursesw, which is needed for the console-curses client.
hurd_LIB_NCURSESW
+--- a/config.make.in
++++ b/config.make.in
+@@ -98,6 +98,12 @@ libblkid_LIBS = @libblkid_LIBS@
+ # Whether Sun RPC support is available.
+ HAVE_SUN_RPC = @HAVE_SUN_RPC@
+
++# Whether pcap support is available.
++HAVE_PCAP = @HAVE_PCAP@
++
++# Whether libpciaccess is available.
++LIBPCIACCESS = @LIBPCIACCESS@
++
+ # Installation tools.
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@