summaryrefslogtreecommitdiff
path: root/debian/patches/0010-potfu_bootshell_fixbuild.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0010-potfu_bootshell_fixbuild.patch')
-rw-r--r--debian/patches/0010-potfu_bootshell_fixbuild.patch75
1 files changed, 0 insertions, 75 deletions
diff --git a/debian/patches/0010-potfu_bootshell_fixbuild.patch b/debian/patches/0010-potfu_bootshell_fixbuild.patch
deleted file mode 100644
index 7f475cad..00000000
--- a/debian/patches/0010-potfu_bootshell_fixbuild.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From 8905e266cc72b915cae5be6630907ba08789cd06 Mon Sep 17 00:00:00 2001
-From: Justus Winter <4winter@informatik.uni-hamburg.de>
-Date: Wed, 14 Jan 2015 02:13:46 +0100
-Subject: [PATCH hurd 10/11] potfu_bootshell_fixbuild
-
----
- bootshell/Makefile | 4 +++-
- bootshell/ffi.h | 11 ++++++-----
- bootshell/main.c | 6 +++---
- 3 files changed, 12 insertions(+), 9 deletions(-)
-
-diff --git a/bootshell/Makefile b/bootshell/Makefile
-index 97e30f7..2b22696 100644
---- a/bootshell/Makefile
-+++ b/bootshell/Makefile
-@@ -52,7 +52,9 @@ LDFLAGS += -static
- MIGSFLAGS := -imacros mig-mutate.h
-
- %.o: %.scm
-- $(LD) -r --format=binary $< -o $@
-+ cat <$< >.$@
-+ $(LD) -r --format=binary .$@ -o $@
-+ rm .$@
-
- NOWARN := conversion sign-conversion switch unused-function
- CFLAGS := $(filter-out $(foreach flag,$NOWARN,-W$(flag)),$(CFLAGS))
-diff --git a/bootshell/ffi.h b/bootshell/ffi.h
-index b1b3f97..60ab50d 100644
---- a/bootshell/ffi.h
-+++ b/bootshell/ffi.h
-@@ -94,8 +94,9 @@
- void scheme_load_mem (scheme *, const char *, const char *);
-
- #define declare_embedded_script(X) \
-- extern char X##_start[] asm("_binary_"#X"_start"); \
-- extern char X##_end[] asm("_binary_"#X"_end")
-+ extern char X##_size[] asm("_binary__"#X"_o_size"); \
-+ extern char X##_start[] asm("_binary__"#X"_o_start"); \
-+ extern char X##_end[] asm("_binary__"#X"_o_end")
-
- #define load_embedded_script(S, X) \
- ({ \
-@@ -104,9 +105,9 @@ void scheme_load_mem (scheme *, const char *, const char *);
- fprintf (stderr, "Errors encountered evaluating %s\n", #X); \
- })
-
--declare_embedded_script (init_scm);
--declare_embedded_script (boot_scm);
--declare_embedded_script (runsystem_scm);
-+declare_embedded_script (init);
-+declare_embedded_script (boot);
-+declare_embedded_script (runsystem);
-
- void ffi_update (scheme *sc);
- void ffi_init (scheme *sc);
-diff --git a/bootshell/main.c b/bootshell/main.c
-index f5f3ab5..823a143 100644
---- a/bootshell/main.c
-+++ b/bootshell/main.c
-@@ -232,9 +232,9 @@ main (int argc, char **argv)
-
- ffi_init (&scm);
-
-- load_embedded_script (&scm, init_scm);
-- load_embedded_script (&scm, boot_scm);
-- load_embedded_script (&scm, runsystem_scm);
-+ load_embedded_script (&scm, init);
-+ load_embedded_script (&scm, boot);
-+ load_embedded_script (&scm, runsystem);
-
- define_variable (&scm, bootscript_task);
- define_variable (&scm, rootfs_server_task);
---
-2.1.4
-