summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@debian.org>2010-02-06 18:40:39 +0000
committerSamuel Thibault <sthibault@debian.org>2010-02-06 18:40:39 +0000
commitfebb8908b7a18298f1bf428fb46c316996f0278a (patch)
tree8a4f12b61fcb530c4c4a5c9a6307e1f024a613af /debian
parent6b8ef33c92abdd35c73870efc7c321b02545e8ef (diff)
debian/patches/ext2fs_large_stores.patch: Apply Alioth fix #312328 from Fredrik Hammar to fix random startup crash.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/ext2fs_large_stores.patch2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b010f5c7..f2afa003 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -28,6 +28,8 @@ hurd (20090404-3) UNRELEASED; urgency=low
* debian/patches/MAKEDEV.patch: Make MAKEDEV bash-free.
* debian/patches/tmpfs.patch: New patch to fix tmpfs crash.
* debian/patches/proxy-defpager.diff: New patch to fix proxying defpager.
+ * debian/patches/ext2fs_large_stores.patch: Apply Alioth fix #312328 from
+ Fredrik Hammar to fix random startup crash.
[ Guillem Jover ]
* Update make-new-tarball.sh to exclude git instead of CVS paths.
diff --git a/debian/patches/ext2fs_large_stores.patch b/debian/patches/ext2fs_large_stores.patch
index 53b9e381..7a78c4b7 100644
--- a/debian/patches/ext2fs_large_stores.patch
+++ b/debian/patches/ext2fs_large_stores.patch
@@ -613,7 +613,7 @@ Support for >2GB volumes
-
- sblock = (struct ext2_super_block *) boffs_ptr (SBLOCK_OFFS);
+ error_t err;
-+ size_t read;
++ size_t read = 0;
+ assert (! sblock);
+ err = store_read (store, SBLOCK_OFFS >> store->log2_block_size,