summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@debian.org>2009-10-13 18:19:03 +0000
committerSamuel Thibault <sthibault@debian.org>2009-10-13 18:19:03 +0000
commitf87130e12553f285c7ccd7f2ae2954738bc4268c (patch)
treeef1aa0ac0963fb0fa89acc1478567e0aee2e8353 /debian
parentafd6444a72593fba4e61a562eebdb7005e6cacf2 (diff)
debian/patches/libpthread_cancel_init.patch: New patch to fix portability
of pthread.h
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/libpthread_cancel_init.patch27
-rw-r--r--debian/patches/series1
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 51b6fa2d..63184022 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
hurd (20090404-3) unreleased; urgency=low
* debian/rules: Really put debugging symbols into the hurd-dbg package.
+ * debian/patches/libpthread_cancel_init.patch: New patch to fix portability
+ of pthread.h
-- Samuel Thibault <sthibault@debian.org> Tue, 13 Oct 2009 01:20:44 +0200
diff --git a/debian/patches/libpthread_cancel_init.patch b/debian/patches/libpthread_cancel_init.patch
new file mode 100644
index 00000000..7ca6d330
--- /dev/null
+++ b/debian/patches/libpthread_cancel_init.patch
@@ -0,0 +1,27 @@
+commit d69e38ee77536912308212945cfb0b6abe93cef0
+Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
+Date: Tue Oct 13 20:15:08 2009 +0200
+
+ Fix pthread_cleanup_push old-gcc-style initializer
+
+ sysdeps/generic/bits/cancelation.h (__pthread_cleanup_push): For better
+ portability to various compilation flags, use standard initializer for
+ struct __pthread_cancelation_handler __handler instead of old-gcc-style.
+
+diff --git a/sysdeps/generic/bits/cancelation.h b/sysdeps/generic/bits/cancelation.h
+index f446d59..db9169a 100644
+--- a/sysdeps/generic/bits/cancelation.h
++++ b/sysdeps/generic/bits/cancelation.h
+@@ -38,9 +38,9 @@ struct __pthread_cancelation_handler **__pthread_get_cleanup_stack (void);
+ = __pthread_get_cleanup_stack (); \
+ struct __pthread_cancelation_handler __handler = \
+ { \
+- handler: (rt), \
+- arg: (rtarg), \
+- next: *__handlers \
++ (rt), \
++ (rtarg), \
++ *__handlers \
+ }; \
+ *__handlers = &__handler;
+
diff --git a/debian/patches/series b/debian/patches/series
index 14070207..6d59d6ff 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -29,3 +29,4 @@ libpthread_recursive_mutex_initializer.patch -p0
pfinet-gcc-4.3-fix.patch -p1
MAKEDEV.patch -p1
libdiskfs-rename.patch -p1
+libpthread_cancel_init.patch -p1