summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Banck <mbanck@debian.org>2006-08-04 13:40:41 +0000
committerMichael Banck <mbanck@debian.org>2006-08-04 13:40:41 +0000
commitf026495234d59fdb18dd08bed20f6dd17c111113 (patch)
tree8ac68ef5d349021a3844abf811b63a278499eaa5 /debian
parent80243d08656eaad4b0ba29a2fa00b912255eb1ae (diff)
* debian/patches/sysvshm.patch: Removed as it was causing deadlocks.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/sysvshm.patch78
2 files changed, 1 insertions, 78 deletions
diff --git a/debian/changelog b/debian/changelog
index 560d7a65..430f8483 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ hurd (20050513-7+SVN) unreleased; urgency=low
gathering incoming packets, taken from CVS.
* debian/hurd.install: Install hurd.msgids into /usr/share/msgids.
* debian/hurd.dirs: Added /usr/share/msgids.
+ * debian/patches/sysvshm.patch: Removed as it was causing deadlocks.
-- Michael Banck <mbanck@debian.org> Thu, 27 Apr 2006 12:17:47 +0200
diff --git a/debian/patches/sysvshm.patch b/debian/patches/sysvshm.patch
deleted file mode 100644
index a64b1da6..00000000
--- a/debian/patches/sysvshm.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-2005-03-09 Marcus Brinkmann <marcus@flubber>
-
- * pager.c: Include <sys/stat.h>.
- (pager_clear_user_data): Set the S_IMMAP0 flag in the node's stat
- mode.
- (diskfs_get_filemap): Clear the S_IMMAP0 flag in the node's stat
- mode after creating the pager.
- * inode.c (read_node): Set the S_IMMAP0 flag in the node's stat
- mode.
-
---- ext2fs/inode.c 2005-08-30 17:08:51.000000000 +0200
-+++ ext2fs/inode.c.new 2005-08-30 17:09:16.000000000 +0200
-@@ -309,7 +309,7 @@
- if (S_ISREG (st->st_mode) || S_ISDIR (st->st_mode)
- || (S_ISLNK (st->st_mode) && st->st_blocks))
- np->allocsize = round_block (np->dn_stat.st_size);
-- else
-+ else {
- /* Allocsize should be zero for anything except directories, files, and
- long symlinks. These are the only things allowed to have any blocks
- allocated as well, although st_size may be zero for any type (cases
-@@ -317,6 +317,11 @@
- linux, some devices). */
- np->allocsize = 0;
-
-+#ifdef S_IMMAP0
-+ /* We start out with no map users. */
-+ st->st_mode |= S_IMMAP0;
-+#endif
-+ }
- return 0;
- }
-
---- ext2fs/pager.c 2005-08-30 17:08:51.000000000 +0200
-+++ ext2fs/pager.c.new 2005-08-30 17:09:17.000000000 +0200
-@@ -21,6 +21,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <errno.h>
-+#include <sys/stat.h>
- #include <hurd/store.h>
- #include "ext2fs.h"
-
-@@ -799,6 +800,9 @@
- if (upi->type == FILE_DATA)
- {
- struct pager *pager;
-+#ifdef S_IMMAP0
-+ struct node *np;
-+#endif
-
- spin_lock (&node_to_page_lock);
- pager = upi->node->dn->pager;
-@@ -806,6 +810,13 @@
- upi->node->dn->pager = 0;
- spin_unlock (&node_to_page_lock);
-
-+#ifdef S_IMMAP0
-+ np = upi->node;
-+ mutex_lock (&np->lock);
-+ np->dn_stat.st_mode |= S_IMMAP0;
-+ mutex_unlock (&np->lock);
-+#endif
-+
- diskfs_nrele_light (upi->node);
- }
-
-@@ -1251,6 +1262,10 @@
- return MACH_PORT_NULL;
- }
-
-+#ifdef S_IMMAP0
-+ node->dn_stat.st_mode &= ~S_IMMAP0;
-+#endif
-+
- right = pager_get_port (node->dn->pager);
- ports_port_deref (node->dn->pager);
- }