summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Banck <mbanck@debian.org>2005-07-29 10:46:43 +0000
committerMichael Banck <mbanck@debian.org>2005-07-29 10:46:43 +0000
commitc74f5dd571c9cea7caf31b27acb1eee3bc3e6b04 (patch)
tree2b0dd8d2bb5ca69e680fa875ccac796d39b0a8f2 /debian
parent8126449e17af95f564c347fe10d5d17791ed2e41 (diff)
* debian/patches/ftpfs_fix.patch: New patch by Anders Juel Jensen.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/ftpfs_fix.patch17
2 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5201d4d4..830c9838 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ hurd (20050513-3+SVN) unreleased; urgency=low
on bootup.
* debian/patches/magic_port_leak.patch: New patch by Marcus
Brinkmann, taken from CVS.
+ * debian/patches/ftpfs_fix.patch: New patch by Anders Juel Jensen.
-- Michael Banck <mbanck@debian.org> Sun, 12 Jun 2005 23:53:59 +0200
diff --git a/debian/patches/ftpfs_fix.patch b/debian/patches/ftpfs_fix.patch
new file mode 100644
index 00000000..08d99a6d
--- /dev/null
+++ b/debian/patches/ftpfs_fix.patch
@@ -0,0 +1,17 @@
+2005-07-28 Anders Juel Jensen <macavity@aracer.com>
+
+ * node.c (netfs_node_norefs) <hurd_ihash_locp_remove>:
+ Missing dereference of an argument.
+
+--- ftpfs/node.c 1 Mar 2004 09:58:44 -0000 1.2
++++ ftpfs/node.c 28 Jul 2005 18:14:47 -0000
+@@ -92,7 +92,7 @@
+
+ /* Remove this entry from the set of known inodes. */
+ spin_lock (&nn->fs->inode_mappings_lock);
+- hurd_ihash_locp_remove (&nn->fs->inode_mappings, nn->dir_entry-
+>inode_locp);
++ hurd_ihash_locp_remove (&nn->fs->inode_mappings, &nn->dir_entry-
+>inode_locp); spin_unlock (&nn->fs->inode_mappings_lock);
+
+ if (nn->contents)