summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2013-11-15 10:29:41 +0100
committerJustus Winter <4winter@informatik.uni-hamburg.de>2013-12-04 14:25:08 +0100
commitc53f7559f09a773d4818ff5442ee0eef7f674f38 (patch)
treec56fc45d99b0733072adddf27ca9162761a283ed /debian
parent058fc330a8a8b3791aa93163c7cbfb0b5d5e99a0 (diff)
remove udeb stuff
Diffstat (limited to 'debian')
-rw-r--r--debian/control20
-rwxr-xr-xdebian/rules16
2 files changed, 1 insertions, 35 deletions
diff --git a/debian/control b/debian/control
index 0aec1b13..4a964a6a 100644
--- a/debian/control
+++ b/debian/control
@@ -65,23 +65,3 @@ Depends: ${misc:Depends}
Suggests: www-browser
Description: GNU Hurd manual
This package includes the manual in info and HTML format.
-
-Package: hurd-libs0.3-udeb
-Section: debian-installer
-Package-Type: udeb
-Priority: optional
-Architecture: hurd-any
-Depends: ${misc:Depends}, ${shlibs:Depends}
-Description: GNU Hurd (libraries) - udeb
- This package contains the libraries used by GNU Hurd udeb.
-
-Package: hurd-udeb
-Package-Type: udeb
-Priority: optional
-Section: debian-installer
-Architecture: hurd-any
-Depends: ${misc:Depends}, ${shlibs:Depends}, hurd-libs0.3-udeb (= ${binary:Version}), xkb-data-udeb
-Provides: hurd, ext2-modules, fat-modules, ipv6-modules, isofs-modules, loop-modules, mouse-modules, nfs-modules, socket-modules
-Description: GNU Hurd - udeb
- This is the GNU Hurd udeb package. It contains essential system software and
- libraries.
diff --git a/debian/rules b/debian/rules
index a4714298..a58d2df8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,11 +18,9 @@
# 02111-1307 USA.
DEB_DESTDIR = $(CURDIR)/debian/tmp
-DEB_DESTDIR_UDEB = $(CURDIR)/debian/tmp-udeb
CONFIGURE_ARGS = --disable-profile --enable-static-progs='ext2fs,iso9660fs'
CONFIGURE_ARGS_deb =
-CONFIGURE_ARGS_udeb = --without-libdaemon
SUID_PROGRAMS = /bin/ids /bin/login /bin/ps-hurd /usr/bin/w-hurd
DEB_HOST_MULTIARCH := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -35,17 +33,14 @@ INSTALL_generated := $(patsubst %.in,%,$(INSTALL_in))
override_dh_auto_configure:
dh_auto_configure -Bbuild-deb -- $(CONFIGURE_ARGS) $(CONFIGURE_ARGS_deb) $(shell dpkg-buildflags --export=configure)
- dh_auto_configure -Bbuild-udeb -- $(CONFIGURE_ARGS) $(CONFIGURE_ARGS_udeb) $(shell dpkg-buildflags --export=configure)
override_dh_auto_build:
dh_auto_build -Bbuild-deb
- dh_auto_build -Bbuild-udeb
cd build-deb/doc && make && makeinfo --html --split=chapter ../../doc/hurd.texi
$(MAKE) -C libdde-linux26 BUILDDIR=$(CURDIR)/build-deb
override_dh_auto_clean:
dh_auto_clean -Bbuild-deb
- dh_auto_clean -Bbuild-udeb
$(MAKE) -C libdde-linux26 cleanall
rm -f $$(find libdde-linux26 -name \*.d)
rm -fr libdde-linux26/build
@@ -54,7 +49,6 @@ override_dh_auto_clean:
override_dh_auto_install:
dh_auto_install -Bbuild-deb --destdir= -- prefix=$(DEB_DESTDIR) libdir=$(DEB_DESTDIR)/lib/$(DEB_HOST_MULTIARCH) sysconfdir=$(DEB_DESTDIR)/etc localstatedir=$(DEB_DESTDIR)/var XKB_BASE=$(DEB_DESTDIR)/usr/share/X11/xkb
- dh_auto_install -Bbuild-udeb --destdir= -- prefix=$(DEB_DESTDIR_UDEB) libdir=$(DEB_DESTDIR_UDEB)/lib sysconfdir=$(DEB_DESTDIR_UDEB)/etc localstatedir=$(DEB_DESTDIR_UDEB)/var XKB_BASE=$(DEB_DESTDIR_UDEB)/usr/share/X11/xkb
$(MAKE) -C libdde-linux26 INSTALLDIR=$(CURDIR)/debian/tmp/usr/share/libdde_linux26/build/include install
# runsystem is managed by update-alternatives
@@ -68,11 +62,6 @@ override_dh_auto_install:
mv debian/tmp/bin/uptime debian/tmp/usr/bin/uptime-hurd
mv debian/tmp/bin/vmstat debian/tmp/usr/bin/vmstat-hurd
mv debian/tmp/bin/w debian/tmp/usr/bin/w-hurd
- mkdir -p debian/tmp-udeb/usr/bin
- mv debian/tmp-udeb/bin/ps debian/tmp-udeb/bin/ps-hurd
- mv debian/tmp-udeb/bin/uptime debian/tmp-udeb/usr/bin/uptime-hurd
- mv debian/tmp-udeb/bin/vmstat debian/tmp-udeb/usr/bin/vmstat-hurd
- mv debian/tmp-udeb/bin/w debian/tmp-udeb/usr/bin/w-hurd
# move away halt and reboot to not conflict with sysvinit
# (they will be handled as alternatives)
@@ -81,10 +70,8 @@ override_dh_auto_install:
# remove PIC static libraries
rm -f debian/tmp/lib/$(DEB_HOST_MULTIARCH)/*_pic.a
- rm -f debian/tmp-udeb/lib/*_pic.a
override_dh_install: $(INSTALL_generated)
- dh_install $(addprefix -p,$(filter %-udeb,$(shell dh_listpackages))) --sourcedir=debian/tmp-udeb
dh_install --remaining-packages --list-missing --sourcedir=debian/tmp
override_dh_installinit:
@@ -103,12 +90,11 @@ override_dh_fixperms:
chmod u+s $(patsubst %,$(CURDIR)/debian/hurd%,$(SUID_PROGRAMS))
override_dh_makeshlibs:
- dh_makeshlibs -phurd-libs0.3 --add-udeb=hurd-libs0.3-udeb
+ dh_makeshlibs -phurd-libs0.3
dh_makeshlibs --remaining-packages -Xusr/lib/hurd/
override_dh_clean:
dh_clean
- rm -rf debian/tmp-udeb
debian/%.install: debian/%.install.in
cat $^ | sed -e 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' > $@