summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@debian.org>2009-04-04 22:50:20 +0000
committerSamuel Thibault <sthibault@debian.org>2009-04-04 22:50:20 +0000
commitac998e8ce3f3d20037da9016944b6554db866212 (patch)
tree220cf5065def5a70379dc52a46080bb865eaced0 /debian
parent34c50839ff6f4d7515271f88cbca68ea48a91b04 (diff)
* debian/patches/stat_round.patch: New temporary patch, fixes symlink issues
with tar.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/stat_round.patch57
3 files changed, 60 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 98fdc0f7..abba4087 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -42,6 +42,8 @@ hurd (20080921-1) UNRELEASED; urgency=low
* debian/patches/in6_addr.patch: New patch to fix compilation under libc
2.9.
* debian/control (Build-Depends): Bump libc0.3-dev to (>= 2.9).
+ * debian/patches/stat_round.patch: New temporary patch, fixes symlink issues
+ with tar.
-- Michael Banck <mbanck@debian.org> Sat, 13 Sep 2008 23:43:27 +0200
diff --git a/debian/patches/series b/debian/patches/series
index a6add4cb..cb7902a7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -22,3 +22,4 @@ ttys.patch -p1
uptime_w_path_fix.patch -p1
stat-fix.patch -p0
in6_addr.patch -p1
+stat_round.patch -p0
diff --git a/debian/patches/stat_round.patch b/debian/patches/stat_round.patch
new file mode 100644
index 00000000..083f317f
--- /dev/null
+++ b/debian/patches/stat_round.patch
@@ -0,0 +1,57 @@
+Index: libdiskfs/file-utimes.c
+===================================================================
+RCS file: /cvsroot/hurd/hurd/libdiskfs/file-utimes.c,v
+retrieving revision 1.9
+diff -u -r1.9 file-utimes.c
+--- libdiskfs/file-utimes.c 2 Feb 2009 03:04:46 -0000 1.9
++++ libdiskfs/file-utimes.c 4 Apr 2009 22:47:50 -0000
+@@ -33,7 +33,7 @@
+ else
+ {
+ np->dn_stat.st_atim.tv_sec = atime.seconds;
+- np->dn_stat.st_atim.tv_nsec = atime.microseconds * 1000;
++ np->dn_stat.st_atim.tv_nsec = 0;
+ np->dn_set_atime = 0;
+ }
+
+@@ -42,7 +42,7 @@
+ else
+ {
+ np->dn_stat.st_mtim.tv_sec = mtime.seconds;
+- np->dn_stat.st_mtim.tv_nsec = mtime.microseconds * 1000;
++ np->dn_stat.st_mtim.tv_nsec = 0;
+ np->dn_set_mtime = 0;
+ }
+
+Index: libdiskfs/node-times.c
+===================================================================
+RCS file: /cvsroot/hurd/hurd/libdiskfs/node-times.c,v
+retrieving revision 1.15
+diff -u -r1.15 node-times.c
+--- libdiskfs/node-times.c 16 Feb 2009 16:06:00 -0000 1.15
++++ libdiskfs/node-times.c 4 Apr 2009 22:47:51 -0000
+@@ -53,21 +53,21 @@
+ if (np->dn_set_mtime)
+ {
+ np->dn_stat.st_mtim.tv_sec = t.tv_sec;
+- np->dn_stat.st_mtim.tv_nsec = t.tv_usec * 1000;
++ np->dn_stat.st_mtim.tv_nsec = 0;
+ np->dn_stat_dirty = 1;
+ np->dn_set_mtime = 0;
+ }
+ if (np->dn_set_atime)
+ {
+ np->dn_stat.st_atim.tv_sec = t.tv_sec;
+- np->dn_stat.st_atim.tv_nsec = t.tv_usec * 1000;
++ np->dn_stat.st_atim.tv_nsec = 0;
+ np->dn_stat_dirty = 1;
+ np->dn_set_atime = 0;
+ }
+ if (np->dn_set_ctime)
+ {
+ np->dn_stat.st_ctim.tv_sec = t.tv_sec;
+- np->dn_stat.st_ctim.tv_nsec = t.tv_usec * 1000;
++ np->dn_stat.st_ctim.tv_nsec = 0;
+ np->dn_stat_dirty = 1;
+ np->dn_set_ctime = 0;
+ }