summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2010-08-01 18:32:28 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2010-08-01 18:32:28 +0200
commit88ac10891b3163be0bd748a3abbd66252d45ecc1 (patch)
tree6bf8ce575bb0898dec6218392191e1f5e5ced42a /debian
parentbf8b133e9ed35e5bec866bf308e609d8fb000502 (diff)
Ignore erroneous number of glyphs in bdf files
* debian/patches/console_ignore_bdf_err.patch: New patch to ignore erroneous number of glyphs in bdf files.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/console_ignore_bdf_err.patch17
-rw-r--r--debian/patches/series1
3 files changed, 21 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 0450f34c..60cf200a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -46,7 +46,9 @@ hurd (20100701-1) UNRELEASED; urgency=low
when installed.
* debian/source/options: Set compression to bzip2.
* debian/control: Update Vcs fields to point to the new git repositories.
-
+ * debian/patches/console_ignore_bdf_err.patch: New patch to ignore erroneous
+ number of glyphs in bdf files.
+
[ Guillem Jover ]
* Update make-new-tarball.sh to exclude git instead of CVS paths.
* Refresh patches with -pab to allow migration to source format 3.0 (quilt).
diff --git a/debian/patches/console_ignore_bdf_err.patch b/debian/patches/console_ignore_bdf_err.patch
new file mode 100644
index 00000000..c3ea30cb
--- /dev/null
+++ b/debian/patches/console_ignore_bdf_err.patch
@@ -0,0 +1,17 @@
+reduce-font overestimates the number of characters in the font.
+
+diff --git a/console-client/bdf.c b/console-client/bdf.c
+index 30501f4..ee8aa30 100644
+--- a/console-client/bdf.c
++++ b/console-client/bdf.c
+@@ -415,8 +415,10 @@ bdf_read (FILE *filep, bdf_font_t *font, int *linecount)
+ glyphs. */
+ if (!strcmp (line, "ENDFONT"))
+ {
++ /*
+ if (parser.glyphs != bdf->glyphs_count)
+ err = BDF_COUNT_MISMATCH;
++ */
+ done = 1;
+ }
+ else
diff --git a/debian/patches/series b/debian/patches/series
index aaa67b3b..9d9109f1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -24,3 +24,4 @@ proxy-defpager.diff
libpthread_procfs.patch
makedev_keep_options.patch
makedev_parted_store.patch
+console_ignore_bdf_err.patch