summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2013-06-19 15:52:39 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2013-06-19 15:52:39 +0200
commit8825b9799e0348283c16f4ba30c0be48a33a3d24 (patch)
treed1b32207600f27f1fe389e86188085db36df6203 /debian
parent4f04a44f72bf552c8d477650a593406b130c79f5 (diff)
Fix documentation build, add io_select_timeout
* Add doc-fix.patch to fix documentation build. * Add io_select_timeout patch to introduce the RPC definition for libc to build the RPC stubs.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/doc-fix.patch56
-rw-r--r--debian/patches/io_select_timeout104
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
5 files changed, 168 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 997e3701..2eb5fc50 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-hurd (20130226-3) UNRELEASED; urgency=low
+hurd (20130226-3) unstable; urgency=low
[ Pino Toscano ]
* Stop installing the upstream ChangeLog, since it is just a pointer to the
@@ -9,8 +9,11 @@ hurd (20130226-3) UNRELEASED; urgency=low
[ Samuel Thibault ]
* Do not create lpr3, it does not exist in standard PC hardware.
+ * Add doc-fix.patch to fix documentation build.
+ * Add io_select_timeout patch to introduce the RPC definition for libc to
+ build the RPC stubs.
- -- GNU Hurd Maintainers <debian-hurd@lists.debian.org> Sun, 24 Mar 2013 22:47:50 +0100
+ -- Samuel Thibault <sthibault@debian.org> Wed, 19 Jun 2013 10:56:03 +0000
hurd (20130226-2) unstable; urgency=low
diff --git a/debian/patches/doc-fix.patch b/debian/patches/doc-fix.patch
new file mode 100644
index 00000000..0b59812a
--- /dev/null
+++ b/debian/patches/doc-fix.patch
@@ -0,0 +1,56 @@
+commit 45193362a810024ab4810470fcd00e16123d5aaf
+Author: Richard Braun <rbraun@sceen.net>
+Date: Wed May 22 21:00:08 2013 +0200
+
+ Fix some errors in the texinfo documentation
+
+ * doc/gpl.texinfo: Replace @unnumbered with @node and @section commands.
+ * doc/hurd.texi: Fix call to @setchapternewpage, remove the @node and
+ @section commands that are now in gpl.texinfo, and remove an erroneous
+ occurrence of 'attributes' before a command.
+
+diff --git a/doc/gpl.texinfo b/doc/gpl.texinfo
+index a2f8db9..d29870c 100644
+--- a/doc/gpl.texinfo
++++ b/doc/gpl.texinfo
+@@ -1,6 +1,5 @@
+-@setfilename gpl.info
+-
+-@unnumbered GNU GENERAL PUBLIC LICENSE
++@node Copying
++@section GNU GENERAL PUBLIC LICENSE
+ @center Version 2, June 1991
+
+ @display
+diff --git a/doc/hurd.texi b/doc/hurd.texi
+index ea73a4c..070daed 100644
+--- a/doc/hurd.texi
++++ b/doc/hurd.texi
+@@ -127,7 +127,7 @@ into another language, under the above conditions for modified versions.
+ @end quotation
+ @end copying
+
+-@setchapternewpage none
++@setchapternewpage off
+ @settitle Hurd Reference Manual
+
+ @titlepage
+@@ -513,9 +513,6 @@ mentions that the FSF started developing the Hurd in 1990. As of
+ kernel.
+
+
+-@node Copying
+-@section GNU General Public License
+-
+ @include gpl.texinfo
+
+
+@@ -1461,7 +1458,7 @@ dropped by the kernel. If the page is currently in core, the kernel
+ might ignore this call.
+ @end deftypefun
+
+-attributes@deftypefun void pager_change_attributes (@w{struct pager *@var{pager}}, @w{boolean_t @var{may_cache}}, @w{memory_object_copy_strategy_t @var{copy_strategy}}, @w{int @var{wait}})
++@deftypefun void pager_change_attributes (@w{struct pager *@var{pager}}, @w{boolean_t @var{may_cache}}, @w{memory_object_copy_strategy_t @var{copy_strategy}}, @w{int @var{wait}})
+ Change the attributes of the memory object underlying pager @var{pager}.
+ The @var{may_cache} and @var{copy_strategy} arguments are as for
+ @code{memory_object_change_}. Wait for the kernel to report
diff --git a/debian/patches/io_select_timeout b/debian/patches/io_select_timeout
new file mode 100644
index 00000000..6ff81e68
--- /dev/null
+++ b/debian/patches/io_select_timeout
@@ -0,0 +1,104 @@
+commit cc36b5a5e2e8df6e633bb767df84ac1e61c56bc3
+Author: Richard Braun <rbraun@sceen.net>
+Date: Tue Feb 26 22:24:42 2013 +0100
+
+ Add the timespec_t Hurd type
+
+ This type matches the standard struct timespec, and allows passing time
+ values with nanosecond precision in RPCs.
+
+ * hurd/hurd_types.defs (timespec_t): New MIG type.
+ * hurd/hurd_types.h: Include <time.h>.
+ (timespec_t): New C type, aliasing struct timespec.
+
+diff --git a/hurd/hurd_types.defs b/hurd/hurd_types.defs
+index 5ad5e93..4b32504 100644
+--- a/hurd/hurd_types.defs
++++ b/hurd/hurd_types.defs
+@@ -230,6 +230,8 @@ type rusage_t = struct[18] of int; /* XXX */
+
+ type flock_t = struct[5] of int;
+
++type timespec_t = struct[2] of int;
++
+ #define _SYS_UTSNAME_H /* Inhibit warning from <bits/utsname.h>. */
+ #include <bits/utsname.h>
+ type utsname_t = struct[5 * _UTSNAME_LENGTH] of char;
+diff --git a/hurd/hurd_types.h b/hurd/hurd_types.h
+index e1a644f..7d1bb73 100644
+--- a/hurd/hurd_types.h
++++ b/hurd/hurd_types.h
+@@ -20,6 +20,7 @@ the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
+ #ifndef _HURD_TYPES_H
+ #define _HURD_TYPES_H
+
++#include <time.h> /* For struct timespec. */
+ #include <mach/std_types.h> /* For mach_port_t et al. */
+ #include <mach/message.h> /* For mach_msg_id_t et al. */
+ #include <sys/types.h> /* For pid_t and uid_t. */
+@@ -69,6 +70,7 @@ typedef struct statfs fsys_statfsbuf_t;
+ typedef struct stat64 io_statbuf_t;
+ typedef struct statfs64 fsys_statfsbuf_t;
+ #endif
++typedef struct timespec timespec_t;
+
+
+ /* Parameters and flags in RPC calls */
+
+
+commit 8cd75c4d6b229bb4e3de9264466731e3a32e0133
+Author: Richard Braun <rbraun@sceen.net>
+Date: Tue Feb 26 22:24:47 2013 +0100
+
+ Add io_select_timeout to the io interface
+
+ * hurd/io.defs (io_select_timeout): New MIG routine.
+ * hurd/io_reply.defs (io_select_timeout_reply): New MIG simpleroutine.
+ * hurd/io_request.defs (io_select_timeout_request): Likewise.
+
+diff --git a/hurd/io.defs b/hurd/io.defs
+index 9119b05..ba0b807 100644
+--- a/hurd/io.defs
++++ b/hurd/io.defs
+@@ -320,3 +320,14 @@ routine io_identity (
+ on the specified object. */
+ routine io_revoke (
+ io_object: io_t RPTLAST);
++
++/* INTR */
++routine io_select_timeout (
++ io_object: io_t;
++#if defined (REPLY_PORTS) || defined (IO_SELECT_REPLY_PORT)
++ replyport reply: sreply_port_t;
++#else
++ ureplyport reply: mach_port_make_send_t;
++#endif
++ timeout: timespec_t;
++ inout select_type: int);
+diff --git a/hurd/io_reply.defs b/hurd/io_reply.defs
+index ffc4e75..eee6824 100644
+--- a/hurd/io_reply.defs
++++ b/hurd/io_reply.defs
+@@ -175,3 +175,8 @@ simpleroutine io_identity_reply (
+ simpleroutine io_revoke_reply (
+ reply: reply_port_t;
+ RETURN_CODE_ARG);
++
++simpleroutine io_select_timeout_reply (
++ reply: reply_port_t;
++ RETURN_CODE_ARG;
++ select_result: int);
+diff --git a/hurd/io_request.defs b/hurd/io_request.defs
+index a3e775a..0d5e36d 100644
+--- a/hurd/io_request.defs
++++ b/hurd/io_request.defs
+@@ -172,3 +172,9 @@ simpleroutine io_identity_request (
+ simpleroutine io_revoke_request (
+ io_object: io_t;
+ reply: reply_port_t);
++
++simpleroutine io_select_timeout_request (
++ io_object: io_t;
++ ureplyport reply: mach_port_make_send_t;
++ timeout: timespec_t;
++ select_type: int);
diff --git a/debian/patches/series b/debian/patches/series
index 299b9452..2e094756 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -41,3 +41,4 @@ libmachdev.patch
exec_filename_exec.patch
exec_filename_fs.patch
exec_filename_use.patch
+doc-fix.patch
diff --git a/debian/rules b/debian/rules
index 342ea4d1..9bc24a43 100755
--- a/debian/rules
+++ b/debian/rules
@@ -72,6 +72,8 @@ override_dh_auto_install:
# remove PIC static libraries
rm -f debian/tmp/lib/$(DEB_HOST_MULTIARCH)/*_pic.a
+ patch -p1 -d debian/tmp/include < debian/patches/io_select_timeout
+
override_dh_install: $(INSTALL_generated)
dh_install --list-missing