summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Banck <mbanck@debian.org>2006-01-12 20:36:27 +0000
committerMichael Banck <mbanck@debian.org>2006-01-12 20:36:27 +0000
commit87b7847a2f233bc725825f34ce4bb30ad30542aa (patch)
tree276ded853cdd095b790883a4a90e9ddf98e1c927 /debian
parenta74b8dcd66eee549ec11113d80ff565fea75a78e (diff)
* debian/patches/beta_make.patch: New patch, support newer make.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/beta_make.patch27
2 files changed, 28 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5b250674..8e5f1383 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ hurd (20050513-5+SVN) unreleased; urgency=low
* debian/patches/console_ioperms.patch: New patch by Samuel Thibault.
* debian/control: Add Depends/Conflicts on gnumach version 20050801-3.
+ * debian/patches/beta_make.patch: New patch, support newer make.
-- Michael Banck <mbanck@debian.org> Fri, 23 Dec 2005 12:28:46 +0100
diff --git a/debian/patches/beta_make.patch b/debian/patches/beta_make.patch
new file mode 100644
index 00000000..ed7915b9
--- /dev/null
+++ b/debian/patches/beta_make.patch
@@ -0,0 +1,27 @@
+--- hurd/Makeconf.orig 2006-01-12 15:02:57.000000000 +0100
++++ hurd/Makeconf 2006-01-12 15:31:25.000000000 +0100
+@@ -576,16 +576,18 @@
+ # Here is how to build those dependency files
+
+ # Dependencies for fooServer.c files.
++migs_d_SCRIPT = 'set -e; $(CPP) $(CPPFLAGS) $(MIGSFLAGS) $($*-MIGSFLAGS) \
++ -DSERVERPREFIX=S_ -M -MG $< | \
++ sed -e \'s/\.defs\.o:/Server\.c $@:/\' > $@)'
+ %.migs_d: %.defs
+- (set -e; $(CPP) $(CPPFLAGS) $(MIGSFLAGS) $($*-MIGSFLAGS) \
+- -DSERVERPREFIX=S_ -M -MG $< | \
+- sed -e 's/\.defs\.o:/Server\.c $@:/' > $@)
++ $(migs_d_SCRIPT)
+
+ # Dependencies for fooUser.c files.
+-%.migu_d: %.defs
+- (set -e; $(CPP) $(CPPFLAGS) $(MIGUFLAGS) $($*-MIGUFLAGS) \
++migu_d_SCRIPT = 'set -e; $(CPP) $(CPPFLAGS) $(MIGUFLAGS) $($*-MIGUFLAGS) \
+ -M -MG $< | \
+- sed -e 's/\.defs\.o:/User\.c $@:/' > $@)
++ sed -e \'s/\.defs\.o:/User\.c $@:/\' > $@)'
++%.migu_d: %.defs
++ $(migu_d_SCRIPT)
+
+ # The associated .h files are build by the same CCP, so a simple massaging
+ # of the previous two will work.