summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Banck <mbanck@debian.org>2008-09-21 12:22:50 +0000
committerMichael Banck <mbanck@debian.org>2008-09-21 12:22:50 +0000
commit6ab06fa26d1fad942adf3df94d3468e9208e60c3 (patch)
tree489bc8e17124ff44e38578bdf3f173b5dedc891f /debian
parent108cb0e2a640a1fffe221087ec558f0b8c528059 (diff)
+ debian/patches/lock-memory-clobber.patch: Likewise.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/lock-memory-clobber.patch40
2 files changed, 1 insertions, 40 deletions
diff --git a/debian/changelog b/debian/changelog
index ee296f44..d0ea59a7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ hurd (20080921-1) UNRELEASED; urgency=low
+ debian/patches/libpthread_mutex-no-include.patch: Likewise.
+ debian/patches/libpthread_pthreadtypes_h.patch: Likewise.
+ debian/patches/libpthread_spin-lock-inline.patch: Likewise.
+ + debian/patches/lock-memory-clobber.patch: Likewise.
* debian/hurd.postinst: Install w and ps alternatives links in /bin, not
/usr/bin.
diff --git a/debian/patches/lock-memory-clobber.patch b/debian/patches/lock-memory-clobber.patch
deleted file mode 100644
index 3d16074e..00000000
--- a/debian/patches/lock-memory-clobber.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Index: libpthread/sysdeps/i386/bits/memory.h
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libpthread/sysdeps/i386/bits/memory.h,v
-retrieving revision 1.3
-diff -u -p -r1.3 memory.h
---- libpthread/sysdeps/i386/bits/memory.h 1 Jul 2008 11:43:17 -0000 1.3
-+++ libpthread/sysdeps/i386/bits/memory.h 2 Aug 2008 20:38:31 -0000
-@@ -28,7 +28,7 @@ __memory_barrier (void)
-
- /* Any lock'ed instruction will do. We just do a simple
- increment. */
-- __asm__ __volatile ("lock; incl %0" : "=m" (i) : "m" (i));
-+ __asm__ __volatile ("lock; incl %0" : "=m" (i) : "m" (i) : "memory");
- }
-
- /* Prevent read reordering across this function. */
-Index: libthreads/i386/cthreads.h
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libthreads/i386/cthreads.h,v
-retrieving revision 1.3
-diff -u -p -r1.3 cthreads.h
---- libthreads/i386/cthreads.h 3 Mar 2007 23:57:37 -0000 1.3
-+++ libthreads/i386/cthreads.h 2 Aug 2008 20:38:32 -0000
-@@ -98,14 +98,14 @@ typedef volatile int spin_lock_t;
- ({ register int _u__ ; \
- __asm__ volatile("xorl %0, %0; \n\
- xchgl %0, %1" \
-- : "=&r" (_u__), "=m" (*(p)) ); \
-+ : "=&r" (_u__), "=m" (*(p)) :: "memory" ); \
- 0; })
-
- #define spin_try_lock(p)\
- (!({ boolean_t _r__; \
- __asm__ volatile("movl $1, %0; \n\
- xchgl %0, %1" \
-- : "=&r" (_r__), "=m" (*(p)) ); \
-+ : "=&r" (_r__), "=m" (*(p)) :: "memory" ); \
- _r__; }))
-
- #define cthread_sp() \