summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@debian.org>2010-01-11 02:37:41 +0000
committerSamuel Thibault <sthibault@debian.org>2010-01-11 02:37:41 +0000
commit6694fa2e834cf110697fa1aa19efcb5b922d3ef1 (patch)
tree1dfda68c9d69b6395b3a32f6a7162f0a3a984796 /debian
parent2dcfe47d3b2b136d50222901a4d08514942c77df (diff)
* debian/patches/tmpfs.patch: New patch to fix tmpfs crash.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/tmpfs.patch21
3 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index baac0aa7..f843118a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -27,6 +27,7 @@ hurd (20090404-3) UNRELEASED; urgency=low
* debian/rules: Do not ship libthread_*.pic.a, as mklibs doesn't manage to
keep version information.
* debian/patches/MAKEDEV.patch: Make MAKEDEV bash-free.
+ * debian/patches/tmpfs.patch: New patch to fix tmpfs crash.
[ Guillem Jover ]
* Update make-new-tarball.sh to exclude git instead of CVS paths.
diff --git a/debian/patches/series b/debian/patches/series
index b1ddf87a..055633fa 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -32,3 +32,4 @@ libdiskfs-rename.patch
libpthread_cancel_init.patch
libpthread_kill_0.patch
console_current_vcs.patch
+tmpfs.patch
diff --git a/debian/patches/tmpfs.patch b/debian/patches/tmpfs.patch
new file mode 100644
index 00000000..63e4de37
--- /dev/null
+++ b/debian/patches/tmpfs.patch
@@ -0,0 +1,21 @@
+commit 97c5690abeaa88767acf2ffbb55552e8278052c8
+Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
+Date: Mon Jan 11 03:34:50 2010 +0100
+
+ Fix tmpfs assertion
+
+ * tmpfs/tmpfs.h (tmpfs_dirent): Add padding field to push the
+ name field after its position in struct dirent.
+
+diff --git a/tmpfs/tmpfs.h b/tmpfs/tmpfs.h
+index 3032ce3..a0e1f7a 100644
+--- a/tmpfs/tmpfs.h
++++ b/tmpfs/tmpfs.h
+@@ -64,6 +64,7 @@ struct tmpfs_dirent
+ {
+ struct tmpfs_dirent *next;
+ struct disknode *dn;
++ uint32_t pad;
+ uint8_t namelen;
+ char name[0];
+ };