summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJeremie Koenig <jk@jk.fr.eu.org>2010-08-01 13:35:57 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2010-08-01 13:35:57 +0200
commit16c741ccaea1356d29e6d9d0ca93bd3a98c2d934 (patch)
tree195cf0476c502a69f7afca3b46b21f0a6e40cc8a /debian
parent50861e36b4126aebba2ece7ab0bc3b61ff26add8 (diff)
Sort out how device and server nodes are created
- debian/patches/makedev_keep_options.patch: Introduces the -k and -K options to MAKEDEV, respectively to keep active translators running or leave existing files alone completely. - debian/patches/makedev_parted_store.patch: MAKEDEV -p will use parted instead of device stores for disk partitions. - debian/local/setup-translators: New script installed in /usr/lib/hurd, uses MAKEDEV's new options to create all the necessary device and server nodes. - debian/local/runsystem (hurd-udeb): Uses setup-translators in "minimal mode" to prepare the initrd when the installer is started. Parted stores are used to avoid problems when reloading the partition table. - debian/hurd.postinst: Uses setup-translators to create missing nodes on upgrades (on initial installs, debootstrap will use the setup-translators script from the installed hurd package to setup the devices and servers itself).
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog36
-rw-r--r--debian/hurd-udeb.install1
-rw-r--r--debian/hurd.install1
-rw-r--r--debian/hurd.postinst25
-rwxr-xr-xdebian/local/runsystem54
-rw-r--r--debian/local/setup-translators148
-rw-r--r--debian/patches/makedev_keep_options.patch56
-rw-r--r--debian/patches/makedev_parted_store.patch70
-rw-r--r--debian/patches/series2
9 files changed, 312 insertions, 81 deletions
diff --git a/debian/changelog b/debian/changelog
index 7e227e07..bdd8ba6b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -42,16 +42,6 @@ hurd (20100701-1) UNRELEASED; urgency=low
* debian/local/runsystem.gnu: Integrate jkoenig d-i changes, rename to
debian/local/runsystem.
- [ Jeremie Koenig ]
- * debian/control: Build-Depend on libparted-dev.
- * debian/rules: Enable parted stores, in a hackish way for now.
- * debian/local/partman/commit.d/40hurd_reload-partitions: New file for
- hurd-udeb, make partman restart the partition translators after the
- partition table has been changed.
- * debian/hurd-udeb.install: Install file above.
- * debian/local/runsystem (hurd-udeb): Start mach-defpager.
- * debian/hurd-udeb.dirs: Include /servers.
-
[ Guillem Jover ]
* Update make-new-tarball.sh to exclude git instead of CVS paths.
* Refresh patches with -pab to allow migration to source format 3.0 (quilt).
@@ -62,6 +52,32 @@ hurd (20100701-1) UNRELEASED; urgency=low
[ Michael Banck ]
* debian/control (Uploaders): Removed Marcus Brinkmann. (Closes: #503564)
+ [ Jeremie Koenig ]
+ * debian/control: Build-Depend on libparted-dev.
+ * debian/rules: Enable parted stores, in a hackish way for now.
+ * debian/local/partman/commit.d/40hurd_reload-partitions: New file for
+ hurd-udeb, make partman restart the partition translators after the
+ partition table has been changed.
+ * debian/hurd-udeb.install: Install file above.
+ * debian/local/runsystem (hurd-udeb): Start mach-defpager.
+ * debian/hurd-udeb.dirs: Include /servers.
+ * Sort out the way device and server nodes are created:
+ - debian/patches/makedev_keep_options.patch: Introduces the -k and -K
+ options to MAKEDEV, respectively to keep active translators running or
+ leave existing files alone completely.
+ - debian/patches/makedev_parted_store.patch: MAKEDEV -p will use parted
+ instead of device stores for disk partitions.
+ - debian/local/setup-translators: New script installed in /usr/lib/hurd,
+ uses MAKEDEV's new options to create all the necessary device and
+ server nodes.
+ - debian/local/runsystem (hurd-udeb): Uses setup-translators in "minimal
+ mode" to prepare the initrd when the installer is started. Parted
+ stores are used to avoid problems when reloading the partition table.
+ - debian/hurd.postinst: Uses setup-translators to create missing nodes on
+ upgrades (on initial installs, debootstrap will use the
+ setup-translators script from the installed hurd package to setup the
+ devices and servers itself).
+
-- Samuel Thibault <sthibault@debian.org> Tue, 13 Oct 2009 01:20:44 +0200
hurd (20090404-2) unstable; urgency=low
diff --git a/debian/hurd-udeb.install b/debian/hurd-udeb.install
index 8e27ab3d..f80c96c9 100644
--- a/debian/hurd-udeb.install
+++ b/debian/hurd-udeb.install
@@ -1,4 +1,5 @@
debian/local/runsystem libexec
+debian/local/setup-translators usr/lib/hurd
debian/local/partman lib
debian/tmp/lib/*.so.*
debian/tmp/lib/hurd/console/*.so.* usr/lib/hurd/console
diff --git a/debian/hurd.install b/debian/hurd.install
index bd27df90..63e8d02e 100644
--- a/debian/hurd.install
+++ b/debian/hurd.install
@@ -1,3 +1,4 @@
+debian/local/setup-translators usr/lib/hurd
debian/tmp/lib/*.so.*
debian/tmp/lib/hurd/console/*.so.* usr/lib/hurd/console
debian/tmp/hurd/*
diff --git a/debian/hurd.postinst b/debian/hurd.postinst
index 3713c7e6..807366b7 100644
--- a/debian/hurd.postinst
+++ b/debian/hurd.postinst
@@ -22,27 +22,8 @@ update-alternatives \
#DEBHELPER#
-for i in vcs tty1 tty2 tty3 tty4 tty5 tty6; do
- if ! [ -e /dev/$i ]; then
- cd /dev
- /sbin/MAKEDEV $i || true
- fi
-done
-
-if [ ! -h /dev/mouse ]; then
- ln -s /dev/cons/mouse /dev/mouse
+if [ "$1" = configure ] && [ "$2" ]; then
+ # Upgrade: create the missing device and server nodes
+ /usr/lib/hurd/setup-translators -K
fi
-if [ ! -h /dev/kbd ]; then
- ln -s /dev/cons/kbd /dev/kbd
-fi
-
-if [ ! -e /dev/shm ]; then
- mkdir /dev/shm
- chmod 1777 /dev/shm
-fi
-
-if [ ! -e /proc ]; then
- mkdir /proc
- settrans -c /proc /hurd/procfs
-fi
diff --git a/debian/local/runsystem b/debian/local/runsystem
index 986fcabe..eb7d8586 100755
--- a/debian/local/runsystem
+++ b/debian/local/runsystem
@@ -3,64 +3,20 @@
PATH=/bin:/sbin:/usr/bin:/usr/sbin
export PATH
-# Usage: foldsubst <pat> xxxx yyyy zzzz ...
-# <pat> is substituted for every character of xxxx with sed, the character in
-# question being accessible as a '\0' in <pat>, and the result is used as the
-# new pattern to handle the remaining arguments.
-foldsubst () {
- [ "$2" ] || { echo $1; return; }
- expanded=$(echo "$2" | sed "s/./ $1/g"); shift 2
- foldsubst "$expanded" $@;
-}
+# Create a minimal subset of device and server nodes
+/usr/lib/hurd/setup-translators -m -k -p
-# Verbosely attach a translator.
-st () {
- echo -n " $1"
- settrans -ck /servers/$1 /hurd/$2
-}
-
-# Verbosely create device nodes,
-# after the aguments are filtered through foldsubst.
-md () {
- pattern=$1; shift
- sedrepl=$(echo $pattern | sed -e 's/X/\\0/' -e 's/Y/\\\\0/')
- devs=$(foldsubst "$sedrepl" $@)
- (cd /dev; ./MAKEDEV $devs)
- echo -n " $pattern"
-}
-
-
-echo -n "Setting up translators:"
-mkdir -p /servers/socket
-ln -s 1 /servers/socket/local
-ln -s 2 /servers/socket/inet
-st socket/1 pflocal
-st socket/2 pfinet
-st exec exec
-st default-pager proxy-defpager
/hurd/mach-defpager
-echo .
-
-echo -n "Creating device nodes:"
-md 'fd std vcs'
-md ttyX 1234
-md ptypX 0123
-md loopX 0123
-md hdX 0123
-md hdXsY 0123 12345678
-echo .
-
-echo -n "Starting procfs"
-settrans -g /proc /hurd/procfs
-echo .
-echo -n "Starting the Hurd console..."
# Touch the first tty so that the Hurd console is certain to pick it
# and not some random other tty.
sleep 1
touch /dev/tty1
+
+echo -n "Starting the Hurd console..."
console -d vga -d pc_kbd -c /dev/vcs &
sleep 1
+
# Switch over
exec < /dev/tty1 > /dev/tty1 2>&1
echo "Console started."
diff --git a/debian/local/setup-translators b/debian/local/setup-translators
new file mode 100644
index 00000000..a865f3ea
--- /dev/null
+++ b/debian/local/setup-translators
@@ -0,0 +1,148 @@
+#!/bin/sh
+# Set up device nodes and /servers translators.
+#
+# Use cases:
+# - from d-i's /libexec/runsystem, to create a minimal set of device nodes
+# and translators for the installer environment;
+# - from debootstrap on initial installation, to create device and server
+# nodes before /dev and /servers are firmlinked to the host system.
+# - from hurd.postinst, on upgrade, where only non-existant nodes should be
+# created, and the other ones should be left alone.
+
+
+PATH=/bin:/sbin:/usr/bin:/usr/sbin
+export PATH
+
+usage () {
+cat >&2 <<EOU
+Usage: $0 [OPTIONS]
+Set up device nodes and /servers translators.
+
+ -k, --keep-active Keep active translators running
+ -K, --keep-all Don't even set passive translators on existing files
+ -m, --minimal Create a minimal subset of nodes only
+ -p, --parted Prefer parted stores for partition devices
+
+At least one of -k or -K must be given.
+EOU
+}
+
+# Parse command-line arguments
+REPLACE=
+MDFLAGS=
+MINIMAL=
+while [ $# -gt 0 ]; do
+ case "$1" in
+ -k|--keep-active)
+ MDFLAGS="$MDFLAGS -k"
+ REPLACE=y
+ shift;;
+ -K|--keep-all)
+ MDFLAGS="$MDFLAGS -K"
+ REPLACE=n
+ shift;;
+ -m|--minimal)
+ MINIMAL=y
+ shift;;
+ -p|--parted)
+ MDFLAGS="$MDFLAGS -p"
+ shift;;
+ *)
+ usage
+ exit 1;;
+ esac
+done
+
+if [ -z "$REPLACE" ]; then
+ usage
+ exit 1
+fi
+
+# Usage: foldsubst <pat> xxxx yyyy zzzz ...
+# <pat> is substituted for every character of xxxx with sed, the character in
+# question being accessible as a '\0' in <pat>, and the result is used as the
+# new pattern to handle the remaining arguments.
+foldsubst () {
+ [ "$2" ] || { echo $1; return; }
+ expanded=$(echo "$2" | sed "s/./ $1/g"); shift 2
+ foldsubst "$expanded" $@;
+}
+
+# Verbosely attach a translator.
+st () {
+ node=$1
+ cmdl=$2
+ name=${3:-$cmdl}
+
+ echo -n " $name"
+ if [ "$REPLACE" = y ] || [ ! -e $1 ]; then
+ # Work around a bug in ext2fs, which crashes if a non-empty
+ # file is turned into a symlink through settrans, by clearing
+ # the passive translator first.
+ settrans -ck $node
+ settrans -ck $node /hurd/$cmdl
+ fi
+}
+
+# Verbosely create device nodes, with some help from foldsubst.
+md () {
+ pattern=$1; shift
+ sedrepl=$(echo $pattern | sed -e 's/X/\\0/' -e 's/Y/\\\\0/')
+ devs=$(foldsubst "$sedrepl" $@)
+
+ echo -n " $pattern"
+ /sbin/MAKEDEV $MDFLAGS $devs
+}
+
+
+echo -n "Setting up translators:"
+cd /servers
+mkdir -p socket
+
+st exec exec
+st default-pager proxy-defpager
+st socket/1 pflocal
+st socket/local 'symlink 1' '(+link)'
+st socket/2 pfinet
+st socket/inet 'symlink 2' '(+link)'
+st /proc procfs
+
+if [ -z "$MINIMAL" ]; then
+ st password password
+ st crash-kill 'crash --kill' crash-kill
+ st crash-suspend 'crash --suspend' crash-suspend
+ st crash-dump-core 'crash --dump-core' crash-dump-core
+ st crash 'symlink crash-kill' crash
+fi
+
+echo .
+
+
+echo -n "Creating device nodes:"
+cd /dev
+
+md fd
+md std
+md vcs
+md hdX 0123
+md hdXsY 0123 12345678
+md sdX 0123
+md sdXsY 0123 12345678
+
+if [ "$MINIMAL" ]; then
+ md loopX 0123
+ md ttyX 1234
+ md ptypX 0123
+else
+ md loopX 01234567
+ md ttyX 123456
+ md ptyp
+ md ptyq
+ md comX 0123
+ md lprX 0123
+ st kbd 'symlink cons/kbd' kbd
+ st mouse 'symlink cons/mouse' mouse
+fi
+
+echo .
+
diff --git a/debian/patches/makedev_keep_options.patch b/debian/patches/makedev_keep_options.patch
new file mode 100644
index 00000000..90a6c6e9
--- /dev/null
+++ b/debian/patches/makedev_keep_options.patch
@@ -0,0 +1,56 @@
+Add options -k and -K to MAKEDEV.sh to chose not to overwrite existing entries.
+
+Index: hurd/sutils/MAKEDEV.sh
+===================================================================
+--- hurd.orig/sutils/MAKEDEV.sh 2010-07-01 18:14:22.000000000 +0200
++++ hurd/sutils/MAKEDEV.sh 2010-07-01 18:17:37.000000000 +0200
+@@ -8,6 +8,8 @@
+ ECHO=: # Change to "echo" to echo commands.
+ EXEC="" # Change to ":" to suppress command execution.
+ DEVDIR=`pwd` # Reset below by -D/--devdir command line option.
++STFLAGS="-g" # Set to -k if active translators are to be kept.
++KEEP= # Set to something if existing files are to be left alone.
+
+ while :; do
+ case "$1" in
+@@ -18,6 +20,8 @@
+
+ -D, --devdir=DIR Use DIR when a device node name must be
+ embedded in a translator; default is the cwd
++ -k, --keep-active Leave any existing active translator running
++ -K, --keep-all Don't overwrite existing files
+ -n, --dry-run Don't actually execute any commands
+ -v, --verbose Show what commands are executed to make the devices
+ -?, --help Give this help list
+@@ -28,11 +32,14 @@
+ --devdir=*) DEVDIR="`echo "$1" | sed 's/^--devdir=//'`"; shift 1;;
+ -D) DEVDIR="$2"; shift 2;;
+ -D*) DEVDIR="`echo "$1" | sed 's/^-D//'`"; shift 1;;
++ --keep-active|-k) STFLAGS="-k"; shift;;
++ --keep-all|-K) KEEP=1; shift;;
+ --verbose|-v) ECHO=echo; shift;;
+ --dry-run|-n) EXEC=:; shift;;
+ -nv|-vn) ECHO=echo; EXEC=:; shift;;
+ --usage)
+- echo "Usage: $0 [-V?] [-D DIR] [--help] [--usage] [--version] [--devdir=DIR] DEVNAME..."
++ echo "Usage: $0 [-V?] [-D DIR] [--help] [--usage] [--version]"
++ echo " [--devdir=DIR] [--keep-active] [--keep-all] DEVNAME..."
+ exit 0;;
+ --version|-V)
+ echo "STANDARD_HURD_VERSION_MAKEDEV_"; exit 0;;
+@@ -61,10 +68,13 @@
+ local OWNER="$2"
+ local PERM="$3"
+ shift 3
+- if cmd settrans -cg "$NODE"; then
++ if [ "$KEEP" ] && [ -e "$NODE" ]; then
++ return;
++ fi
++ if cmd settrans $STFLAGS -c "$NODE"; then
+ cmd chown "$OWNER" "$NODE"
+ cmd chmod "$PERM" "$NODE"
+- cmd settrans "$NODE" "$@"
++ cmd settrans $STFLAGS "$NODE" "$@"
+ fi
+ }
+
diff --git a/debian/patches/makedev_parted_store.patch b/debian/patches/makedev_parted_store.patch
new file mode 100644
index 00000000..ea10edff
--- /dev/null
+++ b/debian/patches/makedev_parted_store.patch
@@ -0,0 +1,70 @@
+Add option -p to MAKEDEV to use user-space parted stores for partition devices.
+
+Index: hurd/sutils/MAKEDEV.sh
+===================================================================
+--- hurd.orig/sutils/MAKEDEV.sh 2010-07-08 00:48:13.000000000 +0000
++++ hurd/sutils/MAKEDEV.sh 2010-07-08 01:18:26.000000000 +0000
+@@ -10,6 +10,7 @@
+ DEVDIR=`pwd` # Reset below by -D/--devdir command line option.
+ STFLAGS="-g" # Set to -k if active translators are to be kept.
+ KEEP= # Set to something if existing files are to be left alone.
++USE_PARTSTORE= # Whether to use the newer part: stores
+
+ while :; do
+ case "$1" in
+@@ -22,6 +23,8 @@
+ embedded in a translator; default is the cwd
+ -k, --keep-active Leave any existing active translator running
+ -K, --keep-all Don't overwrite existing files
++ -p, --parted Prefer user-space parted stores to kernel devices
++ for partition devices
+ -n, --dry-run Don't actually execute any commands
+ -v, --verbose Show what commands are executed to make the devices
+ -?, --help Give this help list
+@@ -34,11 +37,12 @@
+ -D*) DEVDIR="`echo "$1" | sed 's/^-D//'`"; shift 1;;
+ --keep-active|-k) STFLAGS="-k"; shift;;
+ --keep-all|-K) KEEP=1; shift;;
++ --parted|-p) USE_PARTSTORE=1; shift;;
+ --verbose|-v) ECHO=echo; shift;;
+ --dry-run|-n) EXEC=:; shift;;
+ -nv|-vn) ECHO=echo; EXEC=:; shift;;
+ --usage)
+- echo "Usage: $0 [-V?] [-D DIR] [--help] [--usage] [--version]"
++ echo "Usage: $0 [-V?] [-D DIR] [--help] [--usage] [--version] [--parted]"
+ echo " [--devdir=DIR] [--keep-active] [--keep-all] DEVNAME..."
+ exit 0;;
+ --version|-V)
+@@ -150,6 +154,7 @@
+ ;;
+
+ [hrsc]d*)
++ local sliceno=
+ local n="${I#?d}"
+ local major="${n%%[!0-9]*}"
+ if [ -z "$major" ]; then
+@@ -170,7 +175,9 @@
+ ;;
+ esac
+ case "$rest" in
+- '') ;; # Whole slice
++ '') # Whole slice, can use parted stores
++ sliceno=$slice
++ ;;
+ [a-z]) ;; # BSD partition after slice
+ *)
+ lose "$I: Invalid partition \`$rest'"
+@@ -183,7 +190,12 @@
+ esac
+
+ # The device name passed all syntax checks, so finally use it!
+- st $I root 640 /hurd/storeio $I
++ if [ "$USE_PARTSTORE" ] && [ -z "$rest" ] && [ "$sliceno" ]; then
++ local dev=${I%s[0-9]*}
++ st $I root 640 /hurd/storeio -T typed part:$sliceno:device:$dev
++ else
++ st $I root 640 /hurd/storeio $I
++ fi
+ ;;
+
+ # /dev/shm is used by the POSIX.1 shm_open call in libc.
diff --git a/debian/patches/series b/debian/patches/series
index bdc0719d..aaa67b3b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -22,3 +22,5 @@ libpthread_fix.patch
extern_inline_fix.patch
proxy-defpager.diff
libpthread_procfs.patch
+makedev_keep_options.patch
+makedev_parted_store.patch