summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorMichael Banck <mbanck@debian.org>2005-06-19 14:18:43 +0000
committerMichael Banck <mbanck@debian.org>2005-06-19 14:18:43 +0000
commite5a94733cfa5e5110146f3639710e81b58db6316 (patch)
treeeea2ef4b162fd9981bc09b78d36ec3cfe5ebf2da /debian/patches
parent6e8c617dd37e802363936f8837c6fc94e8a9b771 (diff)
* debian/patches/hurd_console_startup.patch: New patch, adding
support for starting the Hurd console on bootup. * debian/hurd-console.default: New file. * debian/rules (install/hurd::) Install it into debian/tmp/etc/default. * debian/rules/hurd.install: Ship debian/tmp/etc/default/hurd-console.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/hurd_console_startup.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/patches/hurd_console_startup.patch b/debian/patches/hurd_console_startup.patch
new file mode 100644
index 00000000..4344dc68
--- /dev/null
+++ b/debian/patches/hurd_console_startup.patch
@@ -0,0 +1,27 @@
+--- daemons/runsystem.sh.orig 2001-12-20 18:29:33.000000000 +0100
++++ daemons/runsystem.sh 2005-06-18 01:05:30.398035896 +0200
+@@ -127,10 +127,24 @@
+ trap "kill -$sig \${runttys_pid}" $sig
+ done
+
++ # Touch the first tty so that the Hurd console is certain to pick it
++ # and not some random other tty.
++ touch /dev/tty1
++
+ # This program reads /etc/ttys and starts the programs it says to.
+ ${RUNTTYS} &
+ runttys_pid=$!
+
++ # Startup the Hurd console if configured.
++ if [ -e /etc/default/hurd-console ]; then
++ unset DISPLAY KBD KBD_REPEAT MOUSE MOUSE_REPEAT SPEAKER
++ . /etc/default/hurd-console
++ fi
++ if [ "$ENABLE" = "true" ]; then
++ console ${DISPLAY} ${KBD} ${KBD_REPEAT} \
++ ${SPEAKER} ${MOUSE} ${MOUSE_REPEAT} -c /dev/vcs
++ fi
++
+ # Wait for runttys to die, meanwhile handling trapped signals.
+ wait
+