summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2014-02-10 14:48:26 +0100
committerJustus Winter <4winter@informatik.uni-hamburg.de>2014-02-10 14:48:26 +0100
commita71241625e8f8ca510302c96df7e0ee551fb8e17 (patch)
tree13c704316823b2afa6ddd3273e07b28934ecadd3 /debian/patches
parentcfb95cedb57c0ef9adc9c93d39cb5d07cb7506a1 (diff)
add fix-build.patch
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fix-build.patch26
-rw-r--r--debian/patches/series1
2 files changed, 27 insertions, 0 deletions
diff --git a/debian/patches/fix-build.patch b/debian/patches/fix-build.patch
new file mode 100644
index 00000000..6340181b
--- /dev/null
+++ b/debian/patches/fix-build.patch
@@ -0,0 +1,26 @@
+diff --git a/fatfs/Makefile b/fatfs/Makefile
+index c673b1b..9a04fbb 100644
+--- a/fatfs/Makefile
++++ b/fatfs/Makefile
+@@ -23,7 +23,7 @@ SRCS = inode.c main.c dir.c pager.c fat.c virt-inode.c node-create.c
+
+ OBJS = $(SRCS:.c=.o)
+ HURDLIBS = diskfs iohelp fshelp store pager ports ihash shouldbeinlibc
+-OTHERLIBS = -lpthread
++OTHERLIBS = -lpthread -lbz2
+
+ include ../Makeconf
+
+diff --git a/isofs/Makefile b/isofs/Makefile
+index 053b622..a037c21 100644
+--- a/isofs/Makefile
++++ b/isofs/Makefile
+@@ -22,7 +22,7 @@ SRCS = inode.c main.c lookup.c pager.c rr.c
+
+ OBJS = $(SRCS:.c=.o)
+ HURDLIBS = diskfs iohelp fshelp store pager ports ihash shouldbeinlibc
+-OTHERLIBS = -lpthread
++OTHERLIBS = -lpthread -lbz2
+
+ include ../Makeconf
+
diff --git a/debian/patches/series b/debian/patches/series
index 333eca0d..7cd1d7e3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
+fix-build.patch
feature-proc-set-task-name-to-pid.patch
diskfs_no_inherit_dir_group.patch
init_try_runsystem.gnu.patch