summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorMichael Banck <mbanck@debian.org>2006-08-25 18:50:10 +0000
committerMichael Banck <mbanck@debian.org>2006-08-25 18:50:10 +0000
commit30dbdb680f7f95968bf1e8d463c4a7638f8cef86 (patch)
tree65ab162f7093a866365073860e828f8a1f8fa490 /debian/patches
parent389bf6b8af8622f5342e09d752fd171210dc5f0e (diff)
* New snapshot from CVS.
* debian/patches/beta_make.patch: Removed, fixed upstream. * debian/patches/ext2fs_large_stores.patch: Resynced. * debian/patches/pfinet_dhcp.patch: Likewise. * debian/patches/ftpfs_fix.patch: Removed, applied upstream. * debian/patches/gcc-4.0_fixes.patch: Likewise. * debian/patches/libpthread_need_clockid_t.patch: Likewise. * debian/patches/libstore_attribute.patch: Likewise. * debian/patches/magic_port_leak.patch: Likewise. * debian/patches/pfinet_packet_filter.diff: Likewise. * debian/patches/semaphore_restrict_fix.patch: Likewise.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/beta_make.patch27
-rw-r--r--debian/patches/ext2fs_large_stores.patch12
-rw-r--r--debian/patches/ftpfs_fix.patch59
-rw-r--r--debian/patches/gcc-4.0_fixes.patch252
-rw-r--r--debian/patches/libpthread_need_clockid_t.patch49
-rw-r--r--debian/patches/libstore_attribute.patch29
-rw-r--r--debian/patches/magic_port_leak.patch71
-rw-r--r--debian/patches/pfinet_dhcp.patch8
-rw-r--r--debian/patches/pfinet_packet_filter.diff19
-rw-r--r--debian/patches/semaphore_restrict_fix.patch28
10 files changed, 0 insertions, 554 deletions
diff --git a/debian/patches/beta_make.patch b/debian/patches/beta_make.patch
deleted file mode 100644
index ed7915b9..00000000
--- a/debian/patches/beta_make.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- hurd/Makeconf.orig 2006-01-12 15:02:57.000000000 +0100
-+++ hurd/Makeconf 2006-01-12 15:31:25.000000000 +0100
-@@ -576,16 +576,18 @@
- # Here is how to build those dependency files
-
- # Dependencies for fooServer.c files.
-+migs_d_SCRIPT = 'set -e; $(CPP) $(CPPFLAGS) $(MIGSFLAGS) $($*-MIGSFLAGS) \
-+ -DSERVERPREFIX=S_ -M -MG $< | \
-+ sed -e \'s/\.defs\.o:/Server\.c $@:/\' > $@)'
- %.migs_d: %.defs
-- (set -e; $(CPP) $(CPPFLAGS) $(MIGSFLAGS) $($*-MIGSFLAGS) \
-- -DSERVERPREFIX=S_ -M -MG $< | \
-- sed -e 's/\.defs\.o:/Server\.c $@:/' > $@)
-+ $(migs_d_SCRIPT)
-
- # Dependencies for fooUser.c files.
--%.migu_d: %.defs
-- (set -e; $(CPP) $(CPPFLAGS) $(MIGUFLAGS) $($*-MIGUFLAGS) \
-+migu_d_SCRIPT = 'set -e; $(CPP) $(CPPFLAGS) $(MIGUFLAGS) $($*-MIGUFLAGS) \
- -M -MG $< | \
-- sed -e 's/\.defs\.o:/User\.c $@:/' > $@)
-+ sed -e \'s/\.defs\.o:/User\.c $@:/\' > $@)'
-+%.migu_d: %.defs
-+ $(migu_d_SCRIPT)
-
- # The associated .h files are build by the same CCP, so a simple massaging
- # of the previous two will work.
diff --git a/debian/patches/ext2fs_large_stores.patch b/debian/patches/ext2fs_large_stores.patch
index d872a1fd..026a0478 100644
--- a/debian/patches/ext2fs_large_stores.patch
+++ b/debian/patches/ext2fs_large_stores.patch
@@ -2394,15 +2394,3 @@ diff -urpN --exclude='*~' --exclude=build ../cvs/hurd/ufs/pager.c hurd/ufs/pager
if (upi->p == 0)
{
diskfs_nrele_light (np);
---- hurd/libdiskfs/Makefile 2006-04-14 16:29:02.000000000 +0200
-+++ hurd/libdiskfs/Makefileorig 2006-04-14 16:27:55.000000000 +0200
-@@ -61,7 +61,7 @@
- startup_notifyServer.o
- OBJS = $(sort $(SRCS:.c=.o) $(MIGSTUBS))
-
--HURDLIBS = fshelp iohelp store threads ports shouldbeinlibc
-+HURDLIBS = fshelp iohelp store threads ports shouldbeinlibc pager
-
- fsys-MIGSFLAGS = -imacros $(srcdir)/fsmutations.h -DREPLY_PORTS
- fs-MIGSFLAGS = -imacros $(srcdir)/fsmutations.h
-
diff --git a/debian/patches/ftpfs_fix.patch b/debian/patches/ftpfs_fix.patch
deleted file mode 100644
index db5be65a..00000000
--- a/debian/patches/ftpfs_fix.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-2005-07-30 Samuel Thibault <samuel.thibault@ens-lyon.org>
-
- * ihash.c (add_one): Correct cast.
-
-2005-07-30 Samuel Thibault <samuel.thibault@ens-lyon.org>
-
- * node.c (ftpfs_create_node): Add check for result of
- hurd_ihash_add(), correct addition of dir entry.
-
-Index: libihash/ihash.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libihash/ihash.c,v
-retrieving revision 1.9
-diff -u -u -p -r1.9 ihash.c
---- libihash/ihash.c 2 Apr 2004 17:01:03 -0000 1.9
-+++ libihash/ihash.c 30 Jul 2005 01:38:27 -0000
-@@ -329,7 +329,7 @@ add_one (hurd_ihash_t ht, hurd_ihash_key
- ht->items[first_free].key = key;
-
- if (ht->locp_offset != HURD_IHASH_NO_LOCP)
-- *((hurd_ihash_locp_t) (((char *) value) + ht->locp_offset))
-+ *((hurd_ihash_locp_t *) (((char *) value) + ht->locp_offset))
- = &ht->items[first_free].value;
-
- return 1;
-
-Index: ftpfs/node.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/ftpfs/node.c,v
-retrieving revision 1.2
-diff -u -p -r1.2 node.c
---- ftpfs/node.c 1 Mar 2004 09:58:44 -0000 1.2
-+++ ftpfs/node.c 30 Jul 2005 01:38:07 -0000
-@@ -39,6 +39,7 @@ ftpfs_create_node (struct ftpfs_dir_entr
- {
- struct node *new;
- struct netnode *nn = malloc (sizeof (struct netnode));
-+ error_t err;
-
- if (! nn)
- return ENOMEM;
-@@ -61,9 +62,16 @@ ftpfs_create_node (struct ftpfs_dir_entr
- ftpfs_maptime);
-
- spin_lock (&nn->fs->inode_mappings_lock);
-- hurd_ihash_add (&nn->fs->inode_mappings, e->stat.st_ino, new);
-+ err = hurd_ihash_add (&nn->fs->inode_mappings, e->stat.st_ino, e);
- spin_unlock (&nn->fs->inode_mappings_lock);
-
-+ if (err)
-+ {
-+ free(nn);
-+ free(new);
-+ return err;
-+ }
-+
- e->node = new;
- *node = new;
-
diff --git a/debian/patches/gcc-4.0_fixes.patch b/debian/patches/gcc-4.0_fixes.patch
deleted file mode 100644
index 9614fa38..00000000
--- a/debian/patches/gcc-4.0_fixes.patch
+++ /dev/null
@@ -1,252 +0,0 @@
-boot/ChangeLog
-2005-09-01 Thomas Schwinge <tschwinge@gnu.org>
-
- * boot.c (boot_script_exec_cmd): Fix invalid lvalues.
-
-libdiskfs/ChangeLog
-2005-09-01 Thomas Schwinge <tschwinge@gnu.org>
-
- * priv.h: Include <argp.h>.
-
-nfsd/ChangeLog
-2005-09-01 Thomas Schwinge <tschwinge@gnu.org>
-
- * loop.c (server_loop): Fix invalid lvalues.
-
-pfinet/ChangeLog
-2005-09-01 Thomas Schwinge <tschwinge@gnu.org>
-
- * glue-include/asm/system.h (xchg): Fix invalid lvalue.
- * linux-src/net/ipv4/tcp_ipv4.c (tcp_v4_rst_req): Don't use ?: as a
- lvalue.
-
-ufs/ChangeLog
-2005-09-01 Thomas Schwinge <tschwinge@gnu.org>
-
- * dir.h (DIRECT_NAMELEN): Don't use ?: as a lvalue.
-
-ufs-utils/ChangeLog
-2005-09-01 Thomas Schwinge <tschwinge@gnu.org>
-
- * mkfs.c (parse_opt): Move UP's functionality into UP_INT in order to
- fix invalid lvalues.
-
-utils/ChangeLog
-2005-09-01 Thomas Schwinge <tschwinge@gnu.org>
-
- * ps.c (current_tty_name): Don't declare as `static'.
- * rpctrace.c (print_contents): Don't use ?: as a lvalue.
-
-serverboot/ChageLog
-2005-08-13 Alfred M. Szmidt <ams@gnu.org>
-
- * kalloc.c: #include <malloc.h>
- (init_hook, malloc_hook, free_hook): New functions.
- (__malloc_initialize_hook): New variable.
- (malloc, free): Functions removed.
-
-diff -rN -u old-hurd-0-branch.1.tmp-1/boot/boot.c new-hurd-0-branch.1.tmp-1/boot/boot.c
---- old-hurd-0-branch.1.tmp-1/boot/boot.c 2005-09-01 19:18:01.293715312 +0200
-+++ new-hurd-0-branch.1.tmp-1/boot/boot.c 2005-09-01 19:18:01.307713184 +0200
-@@ -367,11 +367,17 @@
- str_start = ((vm_address_t) arg_pos
- + (argc + 2) * sizeof (char *) + sizeof (integer_t));
- p = args + ((vm_address_t) arg_pos & (vm_page_size - 1));
-- *((int *) p)++ = argc;
-+ *(int *) p = argc;
-+ p = (char *) ((int *) p + 1);
- for (i = 0; i < argc; i++)
-- *((char **) p)++ = argv[i] - strings + (char *) str_start;
-- *((char **) p)++ = 0;
-- *((char **) p)++ = 0;
-+ {
-+ *(char **) p = argv[i] - strings + (char *) str_start;
-+ p = (char *) ((char **) p + 1);
-+ }
-+ *(char **) p = 0;
-+ p = (char *) ((char **) p + 1);
-+ *(char **) p = 0;
-+ p = (char *) ((char **) p + 1);
- memcpy (p, strings, stringlen);
- bzero (args, (vm_offset_t) arg_pos & (vm_page_size - 1));
- vm_write (task, trunc_page ((vm_offset_t) arg_pos), (vm_address_t) args,
-diff -rN -u old-hurd-0-branch.1.tmp-1/libdiskfs/priv.h new-hurd-0-branch.1.tmp-1/libdiskfs/priv.h
---- old-hurd-0-branch.1.tmp-1/libdiskfs/priv.h 2005-09-01 19:18:01.291715616 +0200
-+++ new-hurd-0-branch.1.tmp-1/libdiskfs/priv.h 2005-09-01 19:18:01.737647824 +0200
-@@ -26,6 +26,7 @@
- #include <hurd/iohelp.h>
- #include <hurd/port.h>
- #include <assert.h>
-+#include <argp.h>
-
- #include "diskfs.h"
-
-diff -rN -u old-hurd-0-branch.1.tmp-1/nfsd/loop.c new-hurd-0-branch.1.tmp-1/nfsd/loop.c
---- old-hurd-0-branch.1.tmp-1/nfsd/loop.c 2005-09-01 19:18:01.291715616 +0200
-+++ new-hurd-0-branch.1.tmp-1/nfsd/loop.c 2005-09-01 19:18:01.318711512 +0200
-@@ -77,7 +77,7 @@
- /* This transacation has already completed. */
- goto repost_reply;
-
-- r = (int *) rbuf = malloc (MAXIOSIZE);
-+ r = (int *) (rbuf = malloc (MAXIOSIZE));
-
- if (ntohl (*p) != RPC_MSG_VERSION)
- {
-@@ -173,7 +173,7 @@
- if (amt > MAXIOSIZE)
- {
- free (rbuf);
-- r = (int *) rbuf = malloc (amt);
-+ r = (int *) (rbuf = malloc (amt));
- }
- }
-
-diff -rN -u old-hurd-0-branch.1.tmp-1/pfinet/glue-include/asm/system.h new-hurd-0-branch.1.tmp-1/pfinet/glue-include/asm/system.h
---- old-hurd-0-branch.1.tmp-1/pfinet/glue-include/asm/system.h 2005-09-01 19:18:01.291715616 +0200
-+++ new-hurd-0-branch.1.tmp-1/pfinet/glue-include/asm/system.h 2005-09-01 19:18:01.495684608 +0200
-@@ -9,7 +9,7 @@
- #define xchg(ptr, x) \
- ({ \
- __typeof__ (*(ptr)) *_ptr = (ptr), _x = *_ptr; \
-- (uintptr_t) *_ptr = (x); _x; \
-+ *_ptr = (x); _x; \
- })
-
- #define mb() ((void) 0) /* memory barrier */
-diff -rN -u old-hurd-0-branch.1.tmp-1/pfinet/linux-src/net/ipv4/tcp_ipv4.c new-hurd-0-branch.1.tmp-1/pfinet/linux-src/net/ipv4/tcp_ipv4.c
---- old-hurd-0-branch.1.tmp-1/pfinet/linux-src/net/ipv4/tcp_ipv4.c 2005-09-01 19:18:01.290715768 +0200
-+++ new-hurd-0-branch.1.tmp-1/pfinet/linux-src/net/ipv4/tcp_ipv4.c 2005-09-01 19:18:01.512682024 +0200
-@@ -1584,7 +1584,10 @@
- after(TCP_SKB_CB(skb)->seq, req->rcv_isn+1))
- return;
- tcp_synq_unlink(tp, req, prev);
-- (req->sk ? sk->ack_backlog : tp->syn_backlog)--;
-+ if (req->sk)
-+ sk->ack_backlog--;
-+ else
-+ tp->syn_backlog--;
- req->class->destructor(req);
- tcp_openreq_free(req);
-
-diff -rN -u old-hurd-0-branch.1.tmp-1/ufs/dir.h new-hurd-0-branch.1.tmp-1/ufs/dir.h
---- old-hurd-0-branch.1.tmp-1/ufs/dir.h 2005-09-01 19:18:01.288716072 +0200
-+++ new-hurd-0-branch.1.tmp-1/ufs/dir.h 2005-09-01 19:18:01.301714096 +0200
-@@ -91,13 +91,13 @@
- /* Return the namlen from a struct direct, paying attention to whether
- this filesystem supports the type extension */
- #if (BYTE_ORDER == LITTLE_ENDIAN)
--#define DIRECT_NAMLEN(dp) (direct_symlink_extension || swab_disk \
-- ? (dp)->d_namlen \
-- : (dp)->d_type)
-+#define DIRECT_NAMLEN(dp) (*(direct_symlink_extension || swab_disk \
-+ ? &(dp)->d_namlen \
-+ : &(dp)->d_type))
- #else
--#define DIRECT_NAMLEN(dp) (!direct_symlink_extension && swab_disk \
-- ? (dp)->d_type \
-- : (dp)->d_namlen)
-+#define DIRECT_NAMLEN(dp) (*(!direct_symlink_extension && swab_disk \
-+ ? &(dp)->d_type \
-+ : &(dp)->d_namlen))
- #endif
-
- /*
-diff -rN -u old-hurd-0-branch.1.tmp-1/ufs-utils/mkfs.c new-hurd-0-branch.1.tmp-1/ufs-utils/mkfs.c
---- old-hurd-0-branch.1.tmp-1/ufs-utils/mkfs.c 2005-09-01 19:18:01.287716224 +0200
-+++ new-hurd-0-branch.1.tmp-1/ufs-utils/mkfs.c 2005-09-01 19:18:01.461689776 +0200
-@@ -279,10 +279,8 @@
- case 'N': Nflag = 1; break;
- case 'O': Oflag = 1; break;
-
-- /* Mark &VAR as being a uparam, and return a lvalue for VAR. */
--#define UP(var) (amarks_add (&uparams, &var), var)
-- /* Record an integer uparam into VAR. */
--#define UP_INT(var) { int _i = atoi (arg); UP (var) = _i; }
-+/* Mark &VAR as being a uparam, and set VAR. */
-+#define UP_INT(var) { amarks_add (&uparams, &var); var = atoi (arg); }
-
- case 'a': UP_INT (maxcontig); break;
- case 'b': UP_INT (bsize); break;
-diff -rN -u old-hurd-0-branch.1.tmp-1/utils/ps.c new-hurd-0-branch.1.tmp-1/utils/ps.c
---- old-hurd-0-branch.1.tmp-1/utils/ps.c 2005-09-01 19:18:01.286716376 +0200
-+++ new-hurd-0-branch.1.tmp-1/utils/ps.c 2005-09-01 19:18:01.452691144 +0200
-@@ -249,7 +249,7 @@
- }
-
- /* Returns the name of the current controlling terminal. */
-- static const char *current_tty_name()
-+ const char *current_tty_name()
- {
- error_t err;
- struct ps_tty *tty;
-diff -rN -u old-hurd-0-branch.1.tmp-1/utils/rpctrace.c new-hurd-0-branch.1.tmp-1/utils/rpctrace.c
---- old-hurd-0-branch.1.tmp-1/utils/rpctrace.c 2005-09-01 19:18:01.285716528 +0200
-+++ new-hurd-0-branch.1.tmp-1/utils/rpctrace.c 2005-09-01 19:18:01.454690840 +0200
-@@ -616,11 +616,16 @@
-
- name = MACH_MSG_TYPE_MOVE_SEND;
- }
-- (type->msgt_longform ? lt->msgtl_name : type->msgt_name) = name;
-+ if (type->msgt_longform)
-+ lt->msgtl_name = name;
-+ else
-+ type->msgt_name = name;
- }
- else if (newtypes[0] != name)
-- (type->msgt_longform ? lt->msgtl_name : type->msgt_name)
-- = newtypes[0];
-+ if (type->msgt_longform)
-+ lt->msgtl_name = newtypes[0];
-+ else
-+ type->msgt_name = newtypes[0];
- }
- else
- print_data (name, data, nelt, eltsize);
-===================================================================
-RCS file: /cvsroot/hurd/cvsroot/hurd/hurd/serverboot/kalloc.c,v
-retrieving revision 1.1
-retrieving revision 1.1.2.1
-diff -u -r1.1 -r1.1.2.1
---- hurd/serverboot/kalloc.c 1997/04/03 23:27:41 1.1
-+++ hurd/serverboot/kalloc.c 2005/09/19 20:19:56 1.1.2.1
-@@ -34,6 +34,14 @@
-
- #include <mach.h>
- #include <cthreads.h> /* for spin locks */
-+#include <malloc.h> /* for malloc_hook/free_hook */
-+
-+static void init_hook (void);
-+static void *malloc_hook (size_t size, const void *caller);
-+static void free_hook (void *ptr, const void *caller);
-+
-+void (*__malloc_initialize_hook) (void) = init_hook;
-+
-
- #define DEBUG
-
-@@ -250,12 +258,21 @@
- }
- }
-
--void *malloc(vm_size_t size)
-+static void
-+init_hook (void)
-+{
-+ __malloc_hook = malloc_hook;
-+ __free_hook = free_hook;
-+}
-+
-+static void *
-+malloc_hook (size_t size, const void *caller)
- {
-- return (void *)kalloc(size);
-+ return (void *) kalloc ((vm_size_t) size);
- }
-
--void free(void *addr)
-+static void
-+free_hook (void *ptr, const void *caller)
- {
- /* Just ignore harmless attempts at cleanliness. */
- /* panic("free not implemented"); */
diff --git a/debian/patches/libpthread_need_clockid_t.patch b/debian/patches/libpthread_need_clockid_t.patch
deleted file mode 100644
index 31c92793..00000000
--- a/debian/patches/libpthread_need_clockid_t.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-2005-05-31 Neal H. Walfield <neal@gnu.org>
-
- * include/pthread/pthread.h: If clockid_t is still not defined
- after including <time.h>, define it manually.
-
-2005-05-17 Neal H. Walfield <neal@gnu.org>
-
- * include/pthread/pthread.h: Define __need_clockid_t before
- including <time.h>.
-
-Index: include/pthread/pthread.h
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libpthread/include/pthread/pthread.h,v
-diff -u -r1.5 -r1.6
---- libpthread/include/pthread/pthread.h 12 May 2005 20:55:38 -0000 1.5
-+++ libpthread/include/pthread/pthread.h 17 May 2005 09:40:50 -0000 1.6
-@@ -26,6 +26,7 @@
- #include <features.h>
-
- #include <sched.h>
-+#define __need_clockid_t
- #include <time.h>
-
- __BEGIN_DECLS
-Index: libpthread/include/pthread/pthread.h
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libpthread/include/pthread/pthread.h,v
-retrieving revision 1.6
-retrieving revision 1.7
-diff -u -r1.6 -r1.7
---- libpthread/include/pthread/pthread.h 17 May 2005 09:40:50 -0000 1.6
-+++ libpthread/include/pthread/pthread.h 31 May 2005 17:34:36 -0000 1.7
-@@ -29,6 +29,16 @@
- #define __need_clockid_t
- #include <time.h>
-
-+/* If we are in a mode where clockid_t is not automatically defined
-+ and another header has already included <time.h> then defining
-+ __need_clockid_t was not enough. */
-+#ifndef __clockid_t_defined
-+# define __clockid_t_defined 1
-+# include <bits/types.h>
-+/* Clock ID used in clock and timer functions. */
-+typedef __clockid_t clockid_t;
-+#endif
-+
- __BEGIN_DECLS
-
- #include <bits/pthread.h>
diff --git a/debian/patches/libstore_attribute.patch b/debian/patches/libstore_attribute.patch
deleted file mode 100644
index b052514c..00000000
--- a/debian/patches/libstore_attribute.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-2005-09-24 Roland McGrath <roland@frob.com>
-
- * store.h (STORE_STD_CLASS): Use __attribute_used__ macro
- instead of `unused' attribute.
-
-===================================================================
-RCS file: /cvsroot/hurd/cvsroot/hurd/hurd/libstore/store.h,v
-retrieving revision 1.46
-retrieving revision 1.47
-diff -u -r1.46 -r1.47
---- hurd/hurd/libstore/store.h 2004/09/07 21:35:45 1.46
-+++ hurd/hurd/libstore/store.h 2005/09/25 00:38:07 1.47
-@@ -1,6 +1,6 @@
- /* Store I/O
-
-- Copyright (C) 1995,96,97,98,99,2001,02,04 Free Software Foundation, Inc.
-+ Copyright (C) 1995,96,97,98,99,2001,02,04,05 Free Software Foundation, Inc.
- Written by Miles Bader <miles@gnu.org>
- This file is part of the GNU Hurd.
-
-@@ -627,7 +627,7 @@
-
- #define STORE_STD_CLASS(name) \
- static const struct store_class *const store_std_classes_##name[] \
-- __attribute__ ((unused, section ("store_std_classes"))) \
-+ __attribute_used__ __attribute__ ((section ("store_std_classes"))) \
- = { &store_##name##_class }
-
-
diff --git a/debian/patches/magic_port_leak.patch b/debian/patches/magic_port_leak.patch
deleted file mode 100644
index 66403bc9..00000000
--- a/debian/patches/magic_port_leak.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-2005-07-12 Marcus Brinkmann <marcus@gnu.org>
-
- * magic.c (magic_getroot): Deallocate DOTDOT if processing here.
- (magic_open): Do not allocate and deallocate DOTDOT, just consume
- the reference given to us.
- (magic_peropen_destroy): New function.
- (main): If in directory mode, install magic_peropen_destroy hook.
-
-Index: trans/magic.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/trans/magic.c,v
-retrieving revision 1.17
-retrieving revision 1.18
-diff -u -r1.17 -r1.18
---- hurd/trans/magic.c 6 Mar 2003 02:24:53 -0000 1.17
-+++ hurd/trans/magic.c 12 Jul 2005 15:25:49 -0000 1.18
-@@ -150,6 +150,7 @@
- retry_type *do_retry, char *retry_name,
- mach_port_t *node, mach_msg_type_name_t *node_type)
- {
-+ error_t err;
- struct magic *const m = cntl->hook;
-
- if (m->directory)
-@@ -159,6 +160,10 @@
- *do_retry = FS_RETRY_MAGICAL;
- *node = MACH_PORT_NULL;
- *node_type = MACH_MSG_TYPE_COPY_SEND;
-+
-+ err = mach_port_deallocate (mach_task_self (), dotdot);
-+ assert_perror (err);
-+
- return 0;
- }
-
-@@ -178,18 +183,21 @@
- error_t err = trivfs_open (cntl, user, flags, realnode, cred);
- if (!err)
- {
-+ /* We consume the reference for DOTDOT. */
- (*cred)->po->hook = (void *) dotdot;
-- err = mach_port_mod_refs (mach_task_self (), dotdot,
-- MACH_PORT_RIGHT_SEND, +1);
-- assert_perror (err);
-- err = mach_port_deallocate (mach_task_self (), dotdot);
-- assert_perror (err);
- struct magic *const m = cntl->hook;
- m->nusers++;
- }
- return err;
- }
-
-+static void
-+magic_peropen_destroy (struct trivfs_peropen *po)
-+{
-+ mach_port_deallocate (mach_task_self (), (mach_port_t) po->hook);
-+}
-+
-+
- /* We have this hook only for simple tracking of the live user ports. */
- static void
- magic_protid_destroy (struct trivfs_protid *cred)
-@@ -467,6 +475,8 @@
- trivfs_getroot_hook = &magic_getroot;
- trivfs_open_hook = &magic_open;
- trivfs_protid_destroy_hook = &magic_protid_destroy;
-+ if (m->directory)
-+ trivfs_peropen_destroy_hook = &magic_peropen_destroy;
-
- /* Reply to our parent */
- err = trivfs_startup (bootstrap, 0, 0, 0, 0, 0, &fsys);
diff --git a/debian/patches/pfinet_dhcp.patch b/debian/patches/pfinet_dhcp.patch
index 3d236016..9e1a42d6 100644
--- a/debian/patches/pfinet_dhcp.patch
+++ b/debian/patches/pfinet_dhcp.patch
@@ -18,14 +18,6 @@ retrieving revision 1.11
diff -u -p -r1.11 options.c
--- pfinet/options.c 18 Jul 2001 16:56:57 -0000 1.11
+++ pfinet/options.c 6 Jan 2005 18:52:30 -0000
-@@ -1,6 +1,6 @@
- /* Pfinet option parsing
-
-- Copyright (C) 1996,97,2000,01 Free Software Foundation, Inc.
-+ Copyright (C) 1996,97,2000,01,2005 Free Software Foundation, Inc.
-
- Written by Miles Bader <miles@gnu.org>
-
@@ -60,6 +60,7 @@ static const struct argp_option options[
{"netmask", 'm', "MASK", 0, "Set the netmask"},
{"peer", 'p', "ADDRESS", 0, "Set the peer address"},
diff --git a/debian/patches/pfinet_packet_filter.diff b/debian/patches/pfinet_packet_filter.diff
deleted file mode 100644
index ec883f44..00000000
--- a/debian/patches/pfinet_packet_filter.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-===================================================================
-RCS file: /var/lib/cvs/sources/hurd/hurd/pfinet/ethernet.c,v
-retrieving revision 1.29
-retrieving revision 1.30
-diff -u -r1.29 -r1.30
---- hurd/hurd/pfinet/ethernet.c 2002/05/29 08:34:35 1.29
-+++ hurd/hurd/pfinet/ethernet.c 2006/04/27 00:10:51 1.30
-@@ -68,6 +68,11 @@
-
- static short ether_filter[] =
- {
-+#ifdef NETF_IN
-+ /* We have to tell the packet filtering code that we're interested in
-+ incoming packets. */
-+ NETF_IN, /* Header. */
-+#endif
- NETF_PUSHLIT | NETF_NOP,
- 1
- };
diff --git a/debian/patches/semaphore_restrict_fix.patch b/debian/patches/semaphore_restrict_fix.patch
deleted file mode 100644
index a33a7619..00000000
--- a/debian/patches/semaphore_restrict_fix.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: libpthread/include/semaphore.h
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libpthread/include/semaphore.h,v
-retrieving revision 1.1
-diff -u -r1.1 semaphore.h
---- libpthread/include/semaphore.h 12 May 2005 11:50:42 -0000 1.1
-+++ libpthread/include/semaphore.h 26 Jul 2005 21:33:22 -0000
-@@ -36,7 +36,7 @@
- extern int sem_destroy (sem_t *sem);
-
- /* Store the value of semaphore *SEM in *VALUE. */
--extern int sem_getvalue (sem_t *restrict sem, int *restrict value);
-+extern int sem_getvalue (sem_t *__restrict sem, int *__restrict value);
-
- /* Perform a down operation on semaphore *SEM. */
- extern int sem_wait (sem_t *sem);
-@@ -47,8 +47,8 @@
-
- /* Perform a down operation on semaphore *SEM but don't wait longer
- than TIMEOUT. */
--extern int sem_timedwait (sem_t *restrict sem,
-- const struct timespec *restrict timeout);
-+extern int sem_timedwait (sem_t *__restrict sem,
-+ const struct timespec *__restrict timeout);
-
- /* Perform an up operation on semaphore *SEM. */
- extern int sem_post (sem_t *sem);
-