summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorMichael Banck <mbanck@debian.org>2007-11-19 14:57:24 +0000
committerMichael Banck <mbanck@debian.org>2007-11-19 14:57:24 +0000
commit01801d97a7d7cfb167c1fa7f385cc16a7fa19bf2 (patch)
tree44b7255723829371e67f68fac7be9494d2c8d685 /debian/patches
parentbe365fae41bd1ea79e5594d4dbc5a98ee8a3fe10 (diff)
+ debian/patches/glibc_stat_updates.patch: Removed, applied upstream.
+ debian/patches/libpthread_no-inline.patch: Likewise. + debian/patches/pfinet_-fno-strict-aliasing.patch: Likewise. + debian/patches/servers.boot-update.patch: Likewise. + debian/patches/siocgifhwaddr.patch: Likewise. + debian/patches/pfinet_dhcp.patch: Rediffed. + debian/patches/pflocal.patch: Likewise.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/glibc_stat_updates.patch615
-rw-r--r--debian/patches/libpthread_no-inline.patch125
-rw-r--r--debian/patches/pfinet_-fno-strict-aliasing.patch17
-rw-r--r--debian/patches/pfinet_dhcp.patch58
-rw-r--r--debian/patches/pflocal.patch32
-rw-r--r--debian/patches/servers.boot-update.patch19
-rw-r--r--debian/patches/siocgifhwaddr.patch71
7 files changed, 22 insertions, 915 deletions
diff --git a/debian/patches/glibc_stat_updates.patch b/debian/patches/glibc_stat_updates.patch
deleted file mode 100644
index 419220bb..00000000
--- a/debian/patches/glibc_stat_updates.patch
+++ /dev/null
@@ -1,615 +0,0 @@
-Index: console/console.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/console/console.c,v
-retrieving revision 1.23
-diff -u -p -r1.23 console.c
---- console/console.c 23 Jan 2006 22:19:13 -0000 1.23
-+++ console/console.c 30 Mar 2007 15:52:56 -0000
-@@ -501,16 +501,24 @@ netfs_attempt_utimes (struct iouser *cre
- {
- if (mtime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_mtim = *mtime;
-+#else
- node->nn_stat.st_mtime = mtime->tv_sec;
- node->nn_stat.st_mtime_usec = mtime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_MTIME;
-
- if (atime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_atim = *atime;
-+#else
- node->nn_stat.st_atime = atime->tv_sec;
- node->nn_stat.st_atime_usec = atime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_ATIME;
-Index: console-client/trans.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/console-client/trans.c,v
-retrieving revision 1.2
-diff -u -p -r1.2 trans.c
---- console-client/trans.c 11 Jul 2005 13:59:24 -0000 1.2
-+++ console-client/trans.c 30 Mar 2007 15:52:56 -0000
-@@ -174,16 +174,24 @@ netfs_attempt_utimes (struct iouser *cre
- {
- if (mtime)
- {
-+#if __USE_MISC
-+ np->nn_stat.st_mtim = *mtime;
-+#else
- np->nn_stat.st_mtime = mtime->tv_sec;
- np->nn_stat.st_mtime_usec = mtime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_MTIME;
-
- if (atime)
- {
-+#if __USE_MISC
-+ np->nn_stat.st_atim = *atime;
-+#else
- np->nn_stat.st_atime = atime->tv_sec;
- np->nn_stat.st_atime_usec = atime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_ATIME;
-Index: fatfs/inode.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/fatfs/inode.c,v
-retrieving revision 1.6
-diff -u -p -r1.6 inode.c
---- fatfs/inode.c 30 Mar 2007 14:15:49 -0000 1.6
-+++ fatfs/inode.c 30 Mar 2007 15:52:56 -0000
-@@ -385,9 +385,13 @@ read_node (struct node *np, vm_address_t
- {
- struct timespec ts;
- fat_to_epoch (dr->write_date, dr->write_time, &ts);
-+#ifdef __USE_MISC
-+ st->st_ctim = st->st_mtim = st->st_atim = ts;
-+#else
- st->st_ctime = st->st_mtime = st->st_atime = ts.tv_sec;
- st->st_ctime_usec = st->st_mtime_usec = st->st_atime_usec
- = ts.tv_nsec / 1000;
-+#endif
- }
-
- st->st_blksize = bytes_per_sector;
-Index: ftpfs/netfs.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/ftpfs/netfs.c,v
-retrieving revision 1.8
-diff -u -p -r1.8 netfs.c
---- ftpfs/netfs.c 29 Dec 2001 22:11:50 -0000 1.8
-+++ ftpfs/netfs.c 30 Mar 2007 15:52:56 -0000
-@@ -76,16 +76,24 @@ netfs_attempt_utimes (struct iouser *cre
- {
- if (atime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_atim = *atime;
-+#else
- node->nn_stat.st_atime = atime->tv_sec;
- node->nn_stat.st_atime_usec = atime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_ATIME;
-
- if (mtime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_mtim = *mtime;
-+#else
- node->nn_stat.st_mtime = mtime->tv_sec;
- node->nn_stat.st_mtime_usec = mtime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_MTIME;
-Index: hostmux/node.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/hostmux/node.c,v
-retrieving revision 1.3
-diff -u -p -r1.3 node.c
---- hostmux/node.c 31 Jan 1999 23:48:47 -0000 1.3
-+++ hostmux/node.c 30 Mar 2007 15:52:56 -0000
-@@ -78,16 +78,24 @@ netfs_attempt_utimes (struct iouser *cre
- {
- if (mtime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_mtim = *mtime;
-+#else
- node->nn_stat.st_mtime = mtime->tv_sec;
- node->nn_stat.st_mtime_usec = mtime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_MTIME;
-
- if (atime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_atim = *atime;
-+#else
- node->nn_stat.st_atime = atime->tv_sec;
- node->nn_stat.st_atime_usec = atime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_ATIME;
-Index: isofs/inode.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/isofs/inode.c,v
-retrieving revision 1.17
-diff -u -p -r1.17 inode.c
---- isofs/inode.c 25 Mar 2007 20:29:33 -0000 1.17
-+++ isofs/inode.c 30 Mar 2007 15:53:01 -0000
-@@ -431,9 +431,13 @@ read_disknode (struct node *np, struct d
- {
- struct timespec ts;
- isodate_915 (dr->date, &ts);
-+#ifdef __USE_MISC
-+ st->st_ctim = st->st_mtim = st->st_atim = ts;
-+#else
- st->st_ctime = st->st_mtime = st->st_atime = ts.tv_sec;
- st->st_ctime_usec = st->st_mtime_usec = st->st_atime_usec
- = ts.tv_nsec / 1000;
-+#endif
- }
-
- /* Override what we have better info for */
-@@ -441,20 +445,32 @@ read_disknode (struct node *np, struct d
- {
- if (rl->tfflags & TF_CREATION)
- {
-+#ifdef __USE_MISC
-+ st->st_ctim = rl->ctime;
-+#else
- st->st_ctime = rl->ctime.tv_sec;
- st->st_ctime_usec = rl->ctime.tv_nsec / 1000;
-+#endif
- }
-
- if (rl->tfflags & TF_ACCESS)
- {
-+#ifdef __USE_MISC
-+ st->st_atim = rl->atime;
-+#else
- st->st_atime = rl->atime.tv_sec;
- st->st_atime_usec = rl->atime.tv_nsec / 1000;
-+#endif
- }
-
- if (rl->tfflags & TF_MODIFY)
- {
-+#ifdef __USE_MISC
-+ st->st_mtim = rl->mtime;
-+#else
- st->st_mtime = rl->mtime.tv_sec;
- st->st_mtime_usec = rl->mtime.tv_nsec / 1000;
-+#endif
- }
- }
-
-Index: libdiskfs/node-times.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libdiskfs/node-times.c,v
-retrieving revision 1.10
-diff -u -p -r1.10 node-times.c
---- libdiskfs/node-times.c 3 Dec 2000 04:40:31 -0000 1.10
-+++ libdiskfs/node-times.c 30 Mar 2007 15:53:01 -0000
-@@ -41,9 +41,9 @@ diskfs_set_node_times (struct node *np)
- the update will happen at the next call. */
- if (np->dn_set_mtime)
- {
--#ifdef notyet
-- np->dn_stat.st_mtimespec.ts_sec = t.tv_sec;
-- np->dn_stat.st_mtimespec.ts_nsec = t.tv_usec * 1000;
-+#ifdef __USE_MISC
-+ np->dn_stat.st_mtim.tv_sec = t.tv_sec;
-+ np->dn_stat.st_mtim.tv_nsec = t.tv_usec * 1000;
- #else
- np->dn_stat.st_mtime = t.tv_sec;
- np->dn_stat.st_mtime_usec = t.tv_usec;
-@@ -53,9 +53,9 @@ diskfs_set_node_times (struct node *np)
- }
- if (np->dn_set_atime)
- {
--#ifdef notyet
-- np->dn_stat.st_atimespec.ts_sec = t.tv_sec;
-- np->dn_stat.st_atimespec.ts_nsec = t.tv_usec * 1000;
-+#ifdef __USE_MISC
-+ np->dn_stat.st_atim.tv_sec = t.tv_sec;
-+ np->dn_stat.st_atim.tv_nsec = t.tv_usec * 1000;
- #else
- np->dn_stat.st_atime = t.tv_sec;
- np->dn_stat.st_atime_usec = t.tv_usec;
-@@ -65,9 +65,9 @@ diskfs_set_node_times (struct node *np)
- }
- if (np->dn_set_ctime)
- {
--#ifdef notyet
-- np->dn_stat.st_ctimespec.ts_sec = t.tv_sec;
-- np->dn_stat.st_ctimespec.ts_nsec = t.tv_usec * 1000;
-+#ifdef __USE_MISC
-+ np->dn_stat.st_ctim.tv_sec = t.tv_sec;
-+ np->dn_stat.st_ctim.tv_nsec = t.tv_usec * 1000;
- #else
- np->dn_stat.st_ctime = t.tv_sec;
- np->dn_stat.st_ctime_usec = t.tv_usec;
-Index: libfshelp/touch.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libfshelp/touch.c,v
-retrieving revision 1.1
-diff -u -p -r1.1 touch.c
---- libfshelp/touch.c 1 Jul 1999 21:04:27 -0000 1.1
-+++ libfshelp/touch.c 30 Mar 2007 15:53:01 -0000
-@@ -32,17 +32,32 @@ fshelp_touch (struct stat *st, unsigned
-
- if (what & TOUCH_ATIME)
- {
-+#ifdef __USE_MISC
-+ st->st_atim.tv_sec = tv.tv_sec;
-+ st->st_atim.tv_nsec = tv.tv_usec * 1000;
-+#else
- st->st_atime = tv.tv_sec;
- st->st_atime_usec = tv.tv_usec;
-+#endif
- }
- if (what & TOUCH_CTIME)
- {
-+#ifdef __USE_MISC
-+ st->st_ctim.tv_sec = tv.tv_sec;
-+ st->st_ctim.tv_nsec = tv.tv_usec * 1000;
-+#else
- st->st_ctime = tv.tv_sec;
- st->st_ctime_usec = tv.tv_usec;
-+#endif
- }
- if (what & TOUCH_MTIME)
- {
-+#ifdef __USE_MISC
-+ st->st_mtim.tv_sec = tv.tv_sec;
-+ st->st_mtim.tv_nsec = tv.tv_usec * 1000;
-+#else
- st->st_mtime = tv.tv_sec;
- st->st_mtime_usec = tv.tv_usec;
-+#endif
- }
- }
-Index: libtrivfs/times.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libtrivfs/times.c,v
-retrieving revision 1.3
-diff -u -p -r1.3 times.c
---- libtrivfs/times.c 31 Jan 1999 23:50:16 -0000 1.3
-+++ libtrivfs/times.c 30 Mar 2007 15:53:01 -0000
-@@ -25,8 +25,13 @@ trivfs_set_atime (struct trivfs_control
- time_value_t mtime;
-
- io_stat (cntl->underlying, &st);
-+#ifdef __USE_MISC
-+ mtime.seconds = st.st_mtim.tv_sec;
-+ mtime.microseconds = st.st_mtim.tv_nsec / 1000;
-+#else
- mtime.seconds = st.st_mtime;
- mtime.microseconds = st.st_mtime_usec;
-+#endif
- atime.microseconds = -1;
- file_utimes (cntl->underlying, atime, mtime);
- return 0;
-@@ -40,8 +45,13 @@ trivfs_set_mtime (struct trivfs_control
- time_value_t mtime;
-
- io_stat (cntl->underlying, &st);
-+#ifdef __USE_MISC
-+ atime.seconds = st.st_atim.tv_sec;
-+ atime.microseconds = st.st_atim.tv_nsec / 1000;
-+#else
- atime.seconds = st.st_atime;
- atime.microseconds = st.st_atime_usec;
-+#endif
- mtime.microseconds = -1;
- file_utimes (cntl->underlying, atime, mtime);
- return 0;
-Index: nfs/nfs.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/nfs/nfs.c,v
-retrieving revision 1.27
-diff -u -p -r1.27 nfs.c
---- nfs/nfs.c 29 Sep 2002 15:11:59 -0000 1.27
-+++ nfs/nfs.c 30 Mar 2007 15:53:01 -0000
-@@ -335,10 +335,17 @@ xdr_encode_sattr_stat (int *p,
- *(p++) = htonl (st->st_uid);
- *(p++) = htonl (st->st_gid);
- *(p++) = htonl (st->st_size);
-+#if __USE_MISC
-+ *(p++) = htonl (st->st_atim.tv_sec);
-+ *(p++) = htonl (st->st_atim.tv_nsec / 1000);
-+ *(p++) = htonl (st->st_mtim.tv_sec);
-+ *(p++) = htonl (st->st_mtim.tv_nsec / 1000);
-+#else
- *(p++) = htonl (st->st_atime);
- *(p++) = htonl (st->st_atime_usec);
- *(p++) = htonl (st->st_mtime);
- *(p++) = htonl (st->st_mtime_usec);
-+#endif
- }
- else
- {
-@@ -351,11 +358,21 @@ xdr_encode_sattr_stat (int *p,
- *(p++) = htonl (1); /* set size */
- p = xdr_encode_64bit (p, st->st_size);
- *(p++) = htonl (SET_TO_CLIENT_TIME); /* set atime */
-+#if __USE_MISC
-+ *(p++) = htonl (st->st_atim.tv_sec);
-+ *(p++) = htonl (st->st_atim.tv_nsec);
-+#else
- *(p++) = htonl (st->st_atime);
- *(p++) = htonl (st->st_atime_usec * 1000);
-+#endif
- *(p++) = htonl (SET_TO_CLIENT_TIME); /* set mtime */
-+#if __USE_MISC
-+ *(p++) = htonl (st->st_mtim.tv_sec);
-+ *(p++) = htonl (st->st_mtim.tv_nsec);
-+#else
- *(p++) = htonl (st->st_mtime);
- *(p++) = htonl (st->st_mtime_usec * 1000);
-+#endif
- }
- return p;
- }
-@@ -442,6 +459,27 @@ xdr_decode_fattr (int *p, struct stat *s
- p++;
- st->st_ino = ntohl (*p);
- p++;
-+#if __USE_MISC
-+ st->st_atim.tv_sec = ntohl (*p);
-+ p++;
-+ st->st_atim.tv_nsec = ntohl (*p);
-+ p++;
-+ st->st_mtim.tv_sec = ntohl (*p);
-+ p++;
-+ st->st_mtim.tv_nsec = ntohl (*p);
-+ p++;
-+ st->st_ctim.tv_sec = ntohl (*p);
-+ p++;
-+ st->st_ctim.tv_nsec = ntohl (*p);
-+ p++;
-+
-+ if (protocol_version < 3)
-+ {
-+ st->st_atim.tv_nsec *= 1000;
-+ st->st_mtim.tv_nsec *= 1000;
-+ st->st_ctim.tv_nsec *= 1000;
-+ }
-+#else /* __USE_MISC */
- st->st_atime = ntohl (*p);
- p++;
- st->st_atime_usec = ntohl (*p);
-@@ -461,6 +499,7 @@ xdr_decode_fattr (int *p, struct stat *s
- st->st_mtime_usec /= 1000;
- st->st_ctime_usec /= 1000;
- }
-+#endif /* __USE_MISC */
-
- return p;
-
-Index: nfsd/ops.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/nfsd/ops.c,v
-retrieving revision 1.8
-diff -u -p -r1.8 ops.c
---- nfsd/ops.c 29 Sep 2002 15:12:48 -0000 1.8
-+++ nfsd/ops.c 30 Mar 2007 15:53:01 -0000
-@@ -104,18 +104,41 @@ complete_setattr (mach_port_t port,
- mtime.microseconds = 0;
-
- if (atime.seconds == -1)
-+#if __USE_MISC
-+ atime.seconds = st.st_atim.tv_sec;
-+#else
- atime.seconds = st.st_atime;
-+#endif
- if (atime.microseconds == -1)
-+#if __USE_MISC
-+ atime.microseconds = st.st_atim.tv_nsec / 1000;
-+#else
- atime.microseconds = st.st_atime_usec;
-+#endif
- if (mtime.seconds == -1)
-+#if __USE_MISC
-+ mtime.seconds = st.st_mtim.tv_sec;
-+#else
- mtime.seconds = st.st_mtime;
-+#endif
- if (mtime.microseconds == -1)
-+#if __USE_MISC
-+ mtime.microseconds = st.st_mtim.tv_nsec / 1000;
-+#else
- mtime.microseconds = st.st_mtime_usec;
-+#endif
-
-+#if __USE_MISC
-+ if (atime.seconds != st.st_atim.tv_sec
-+ || atime.microseconds != st.st_atim.tv_nsec / 1000
-+ || mtime.seconds != st.st_mtim.tv_sec
-+ || mtime.microseconds != st.st_mtim.tv_nsec / 1000)
-+#else
- if (atime.seconds != st.st_atime
- || atime.microseconds != st.st_atime_usec
- || mtime.seconds != st.st_mtime
- || mtime.microseconds != st.st_mtime_usec)
-+#endif
- err = file_utimes (port, atime, mtime);
-
- return err;
-Index: nfsd/xdr.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/nfsd/xdr.c,v
-retrieving revision 1.5
-diff -u -p -r1.5 xdr.c
---- nfsd/xdr.c 29 Sep 2002 15:12:48 -0000 1.5
-+++ nfsd/xdr.c 30 Mar 2007 15:53:02 -0000
-@@ -76,12 +76,21 @@ encode_fattr (int *p, struct stat *st, i
- *(p++) = htonl (st->st_blocks);
- *(p++) = htonl (st->st_fsid);
- *(p++) = htonl (st->st_ino);
-+#if __USE_MISC
-+ *(p++) = htonl (st->st_atim.tv_sec);
-+ *(p++) = htonl (st->st_atim.tv_nsec / 1000);
-+ *(p++) = htonl (st->st_mtim.tv_sec);
-+ *(p++) = htonl (st->st_mtim.tv_nsec / 1000);
-+ *(p++) = htonl (st->st_ctim.tv_sec);
-+ *(p++) = htonl (st->st_ctim.tv_nsec / 1000);
-+#else
- *(p++) = htonl (st->st_atime);
- *(p++) = htonl (st->st_atime_usec);
- *(p++) = htonl (st->st_mtime);
- *(p++) = htonl (st->st_mtime_usec);
- *(p++) = htonl (st->st_ctime);
- *(p++) = htonl (st->st_ctime_usec);
-+#endif
- return p;
- }
-
-Index: pflocal/io.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/pflocal/io.c,v
-retrieving revision 1.41
-diff -u -p -r1.41 io.c
---- pflocal/io.c 29 Aug 2005 09:41:21 -0000 1.41
-+++ pflocal/io.c 30 Mar 2007 15:53:02 -0000
-@@ -272,11 +272,19 @@ S_io_stat (struct sock_user *user, struc
- struct sock *sock;
- struct pipe *rpipe, *wpipe;
-
-+#if __USE_MISC
-+ void copy_time (time_value_t *from, time_t *to_sec, unsigned long *to_nsec)
-+ {
-+ *to_sec = from->seconds;
-+ *to_nsec = from->microseconds * 1000;
-+ }
-+#else
- void copy_time (time_value_t *from, time_t *to_sec, unsigned long *to_usec)
- {
- *to_sec = from->seconds;
- *to_usec = from->microseconds;
- }
-+#endif
-
- if (!user)
- return EOPNOTSUPP;
-@@ -300,7 +308,11 @@ S_io_stat (struct sock_user *user, struc
- if (rpipe)
- {
- mutex_lock (&rpipe->lock);
-+#if __USE_MISC
-+ copy_time (&rpipe->read_time, &st->st_atim.tv_sec, &st->st_atim.tv_nsec);
-+#else
- copy_time (&rpipe->read_time, &st->st_atime, &st->st_atime_usec);
-+#endif
- /* This seems useful. */
- st->st_size = pipe_readable (rpipe, 1);
- mutex_unlock (&rpipe->lock);
-@@ -309,11 +321,19 @@ S_io_stat (struct sock_user *user, struc
- if (wpipe)
- {
- mutex_lock (&wpipe->lock);
-+#if __USE_MISC
-+ copy_time (&wpipe->write_time, &st->st_mtim.tv_sec, &st->st_mtim.tv_nsec);
-+#else
- copy_time (&wpipe->write_time, &st->st_mtime, &st->st_mtime_usec);
-+#endif
- mutex_unlock (&wpipe->lock);
- }
-
-+#if __USE_MISC
-+ copy_time (&sock->change_time, &st->st_ctim.tv_sec, &st->st_ctim.tv_nsec);
-+#else
- copy_time (&sock->change_time, &st->st_ctime, &st->st_ctime_usec);
-+#endif
-
- mutex_unlock (&sock->lock);
-
-Index: ufs/inode.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/ufs/inode.c,v
-retrieving revision 1.59
-diff -u -p -r1.59 inode.c
---- ufs/inode.c 11 Jun 2002 21:41:06 -0000 1.59
-+++ ufs/inode.c 30 Mar 2007 15:53:02 -0000
-@@ -231,10 +231,11 @@ read_disknode (struct node *np)
- | (di->di_trans ? S_IPTRANS : 0));
- st->st_nlink = read_disk_entry (di->di_nlink);
- st->st_size = read_disk_entry (di->di_size);
--#ifdef notyet
-- st->st_atimespec = di->di_atime;
-- st->st_mtimespec = di->di_mtime;
-- st->st_ctimespec = di->di_ctime;
-+#ifdef __USE_MISC
-+ /* Correct? No need for `read_disk_entry'? Probably. */
-+ st->st_atim = di->di_atime;
-+ st->st_mtim = di->di_mtime;
-+ st->st_ctim = di->di_ctime;
- #else
- st->st_atime = read_disk_entry (di->di_atime.tv_sec);
- st->st_atime_usec = read_disk_entry (di->di_atime.tv_nsec) / 1000;
-@@ -357,10 +358,11 @@ write_node (struct node *np)
-
- write_disk_entry (di->di_nlink, st->st_nlink);
- write_disk_entry (di->di_size, st->st_size);
--#ifdef notyet
-- di->di_atime = st->st_atimespec;
-- di->di_mtime = st->st_mtimespec;
-- di->di_ctime = st->st_ctimespec;
-+#ifdef __USE_MISC
-+ /* Correct? No need for `write_disk_entry'? Probably. */
-+ di->di_atime = st->st_atim;
-+ di->di_mtime = st->st_mtim;
-+ di->di_ctime = st->st_ctim;
- #else
- write_disk_entry (di->di_atime.tv_sec, st->st_atime);
- write_disk_entry (di->di_atime.tv_nsec, st->st_atime_usec * 1000);
-Index: usermux/node.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/usermux/node.c,v
-retrieving revision 1.3
-diff -u -p -r1.3 node.c
---- usermux/node.c 28 Feb 1999 16:35:07 -0000 1.3
-+++ usermux/node.c 30 Mar 2007 15:53:02 -0000
-@@ -80,16 +80,24 @@ netfs_attempt_utimes (struct iouser *cre
- {
- if (mtime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_mtim = *mtime;
-+#else
- node->nn_stat.st_mtime = mtime->tv_sec;
- node->nn_stat.st_mtime_usec = mtime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_MTIME;
-
- if (atime)
- {
-+#if __USE_MISC
-+ node->nn_stat.st_atim = *atime;
-+#else
- node->nn_stat.st_atime = atime->tv_sec;
- node->nn_stat.st_atime_usec = atime->tv_nsec / 1000;
-+#endif
- }
- else
- flags |= TOUCH_ATIME;
diff --git a/debian/patches/libpthread_no-inline.patch b/debian/patches/libpthread_no-inline.patch
deleted file mode 100644
index e0634e1f..00000000
--- a/debian/patches/libpthread_no-inline.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-Index: libpthread/sysdeps/generic/bits/mutex.h
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libpthread/sysdeps/generic/bits/mutex.h,v
-retrieving revision 1.4
-diff -u -p -r1.4 mutex.h
---- libpthread/sysdeps/generic/bits/mutex.h 4 Mar 2007 00:05:21 -0000 1.4
-+++ libpthread/sysdeps/generic/bits/mutex.h 2 Aug 2007 17:41:05 -0000
-@@ -62,78 +62,6 @@ struct __pthread_mutex
- #include <errno.h>
- #include <stddef.h>
-
--#ifdef __USE_EXTERN_INLINES
--
--# ifndef _EXTERN_INLINE
--# define _EXTERN_INLINE extern __inline
--# endif
--
--_EXTERN_INLINE int
--pthread_mutex_init (struct __pthread_mutex *__restrict __mutex,
-- const pthread_mutexattr_t *__restrict attr)
--{
-- struct __pthread_mutex initialized_mutex = __PTHREAD_MUTEX_INITIALIZER;
--
-- extern int _pthread_mutex_init (struct __pthread_mutex *,
-- const pthread_mutexattr_t *);
--
-- if (attr)
-- return _pthread_mutex_init (__mutex, attr);
--
-- *__mutex = initialized_mutex;
-- return 0;
--}
--
--_EXTERN_INLINE int
--pthread_mutex_destroy (struct __pthread_mutex *__mutex)
--{
-- extern int _pthread_mutex_destroy (struct __pthread_mutex *);
--
-- if (__mutex->attr || __mutex->data)
-- return _pthread_mutex_destroy (__mutex);
--
-- return 0;
--}
--
--_EXTERN_INLINE int
--__pthread_mutex_lock (struct __pthread_mutex *__mutex)
--{
-- extern int _pthread_mutex_lock (struct __pthread_mutex *);
--
-- if (__mutex->attr == NULL
-- && __mutex->data == NULL
-- && __pthread_spin_trylock (&__mutex->__held) == 0)
-- return 0;
--
-- return _pthread_mutex_lock (__mutex);
--}
--
--extern __inline int
--__pthread_mutex_trylock (struct __pthread_mutex *__mutex)
--{
-- extern int _pthread_mutex_trylock (struct __pthread_mutex *);
--
-- if (__mutex->attr == NULL
-- && __mutex->data == NULL)
-- return __pthread_spin_trylock (&__mutex->__held);
--
-- return _pthread_mutex_trylock (__mutex);
--}
--
--extern __inline int
--pthread_mutex_lock (struct __pthread_mutex *__mutex)
--{
-- return __pthread_mutex_lock (__mutex);
--}
--
--extern __inline int
--pthread_mutex_trylock (struct __pthread_mutex *__mutex)
--{
-- return __pthread_mutex_trylock (__mutex);
--}
--
--#endif /* Use extern inlines. */
--
- #endif
-
- #endif /* bits/mutex.h */
-Index: libpthread/sysdeps/generic/bits/rwlock.h
-===================================================================
-RCS file: /cvsroot/hurd/hurd/libpthread/sysdeps/generic/bits/rwlock.h,v
-retrieving revision 1.4
-diff -u -p -r1.4 rwlock.h
---- libpthread/sysdeps/generic/bits/rwlock.h 24 Jun 2007 15:11:52 -0000 1.4
-+++ libpthread/sysdeps/generic/bits/rwlock.h 2 Aug 2007 17:41:05 -0000
-@@ -43,31 +43,4 @@ struct __pthread_rwlock
- { __SPIN_LOCK_INITIALIZER, __SPIN_LOCK_INITIALIZER, 0, 0, 0, 0, 0 }
-
-
--_EXTERN_INLINE int
--pthread_rwlock_init (struct __pthread_rwlock *__restrict __rwlock,
-- const struct __pthread_rwlockattr *__restrict __attr)
--{
-- struct __pthread_rwlock initialized_rwlock = __PTHREAD_RWLOCK_INITIALIZER;
-- extern int _pthread_rwlock_init (struct __pthread_rwlock *,
-- const struct __pthread_rwlockattr *);
--
-- if (__attr)
-- return _pthread_rwlock_init (__rwlock, __attr);
--
-- *__rwlock = initialized_rwlock;
-- return 0;
--}
--
--_EXTERN_INLINE int
--pthread_rwlock_destroy (struct __pthread_rwlock *__rwlock)
--{
-- extern int _pthread_rwlock_destroy (struct __pthread_rwlock *);
--
-- if (__rwlock->__attr
-- || __rwlock->__data)
-- return _pthread_rwlock_destroy (__rwlock);
--
-- return 0;
--}
--
- #endif /* bits/rwlock.h */
diff --git a/debian/patches/pfinet_-fno-strict-aliasing.patch b/debian/patches/pfinet_-fno-strict-aliasing.patch
deleted file mode 100644
index 2a536526..00000000
--- a/debian/patches/pfinet_-fno-strict-aliasing.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-2007-07-27 Thomas Schwinge <tschwinge@gnu.org>
-
- * Makefile (CFLAGS): Add ``-fno-strict-aliasing''.
-
---- pfinet/Makefile 2002/09/17 20:42:06 1.35
-+++ pfinet/Makefile 2007/07/27 12:39:15 1.36
-@@ -95,6 +95,10 @@
- -I$(srcdir)/glue-include \
- -I$(srcdir)/linux-src/include
-
-+# Don't ask... We use Linux code. The problem was first noticed when
-+# compiling `pfinet' with GCC 4.2.
-+CFLAGS += -fno-strict-aliasing
-+
- asm/checksum.h: ../config.status
- mkdir -p $(@D)
- echo > $@.new \
diff --git a/debian/patches/pfinet_dhcp.patch b/debian/patches/pfinet_dhcp.patch
index 9e1a42d6..39f87a50 100644
--- a/debian/patches/pfinet_dhcp.patch
+++ b/debian/patches/pfinet_dhcp.patch
@@ -11,40 +11,35 @@
fail when the address is `0.0.0.0'.
-Index: pfinet/options.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/pfinet/options.c,v
-retrieving revision 1.11
-diff -u -p -r1.11 options.c
---- pfinet/options.c 18 Jul 2001 16:56:57 -0000 1.11
-+++ pfinet/options.c 6 Jan 2005 18:52:30 -0000
-@@ -60,6 +60,7 @@ static const struct argp_option options[
- {"netmask", 'm', "MASK", 0, "Set the netmask"},
- {"peer", 'p', "ADDRESS", 0, "Set the peer address"},
- {"gateway", 'g', "ADDRESS", 0, "Set the default gateway"},
-+ {"dhcp", 'd', 0 , 0, "Prepare pfinet for dhcp"},
+--- pfinet/options.c.orig 2007-11-19 15:11:07.000000000 +0100
++++ pfinet/options.c 2007-11-19 15:53:11.000000000 +0100
+@@ -76,6 +76,7 @@
+ {"address6", 'A', "ADDR/LEN",0, "Set the global IPv6 address"},
+ {"gateway6", 'G', "ADDRESS", 0, "Set the IPv6 default gateway"},
+ #endif
++ {"dhcp", 'd', 0 , 0, "Prepare pfinet for dhcp"},
{"shutdown", 's', 0, 0, "Shut it down"},
{0}
};
-@@ -76,6 +77,9 @@ struct parse_interface
-
- /* New values to apply to it. */
+@@ -93,6 +94,9 @@
+ /* New values to apply to it. (IPv4) */
uint32_t address, netmask, peer, gateway;
-+
+
+ /* Set to one if the interface is configured for DHCP. */
+ int dhcp;
- };
-
- /* Used to hold data during argument parsing. */
-@@ -108,6 +112,7 @@ parse_hook_add_interface (struct parse_h
++
+ #ifdef CONFIG_IPV6
+ /* New IPv6 configuration to apply. */
+ struct inet6_ifaddr address6;
+@@ -130,6 +134,7 @@
h->curint->netmask = INADDR_NONE;
h->curint->peer = INADDR_NONE;
h->curint->gateway = INADDR_NONE;
+ h->curint->dhcp = 0;
- return 0;
- }
-
-@@ -189,6 +194,11 @@ parse_opt (int opt, char *arg, struct ar
+
+ #ifdef CONFIG_IPV6
+ memset (&h->curint->address6, 0, sizeof (struct inet6_ifaddr));
+@@ -234,6 +239,11 @@
"%s: Illegal or undefined network address", arg);
}
break;
@@ -56,9 +51,9 @@ diff -u -p -r1.11 options.c
case 'm':
h->curint->netmask = ADDR (arg, "netmask"); break;
case 'p':
-@@ -315,6 +325,55 @@ parse_opt (int opt, char *arg, struct ar
- }
- }
+@@ -474,6 +484,55 @@
+ }
+ #endif
+ /* Setup the routing required for DHCP. */
+ for (in = h->interfaces; in < h->interfaces + h->num_interfaces; in++)
@@ -112,10 +107,6 @@ diff -u -p -r1.11 options.c
__mutex_unlock (&global_lock);
/* Fall through to free hook. */
-Index: pfinet/linux-src/net/ipv4/devinet.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/pfinet/linux-src/net/ipv4/devinet.c,v
-retrieving revision 1.8
diff -u -p -r1.8 devinet.c
--- pfinet/linux-src/net/ipv4/devinet.c 18 Jul 2001 17:37:13 -0000 1.8
+++ pfinet/linux-src/net/ipv4/devinet.c 6 Jan 2005 18:52:32 -0000
@@ -134,8 +125,3 @@ diff -u -p -r1.8 devinet.c
last_primary = &in_dev->ifa_list;
-
-_______________________________________________
-Bug-hurd mailing list
-Bug-hurd@gnu.org
-http://lists.gnu.org/mailman/listinfo/bug-hurd
diff --git a/debian/patches/pflocal.patch b/debian/patches/pflocal.patch
index 3b8d2ac5..9d3a8db7 100644
--- a/debian/patches/pflocal.patch
+++ b/debian/patches/pflocal.patch
@@ -41,14 +41,6 @@ retrieving revision 1.15
diff -u -p -r1.15 connq.c
--- pflocal/connq.c 22 Dec 2001 21:00:37 -0000 1.15
+++ pflocal/connq.c 17 May 2005 09:25:47 -0000
-@@ -1,6 +1,6 @@
- /* Listen queue functions
-
-- Copyright (C) 1995,96,2001 Free Software Foundation, Inc.
-+ Copyright (C) 1995,96,2001, 2005 Free Software Foundation, Inc.
-
- Written by Miles Bader <miles@gnu.org>
-
@@ -26,31 +26,22 @@
/* A queue for queueing incoming connections. */
struct connq
@@ -497,14 +489,6 @@ retrieving revision 1.6
diff -u -p -r1.6 connq.h
--- pflocal/connq.h 12 Feb 2001 17:24:36 -0000 1.6
+++ pflocal/connq.h 17 May 2005 09:25:47 -0000
-@@ -1,6 +1,6 @@
- /* Connection queues
-
-- Copyright (C) 1995 Free Software Foundation, Inc.
-+ Copyright (C) 1995, 2005 Free Software Foundation, Inc.
-
- Written by Miles Bader <miles@gnu.ai.mit.edu>
-
@@ -23,9 +23,8 @@
#include <errno.h>
@@ -568,14 +552,6 @@ retrieving revision 1.39
diff -u -p -r1.39 io.c
--- pflocal/io.c 11 Jun 2002 21:40:34 -0000 1.39
+++ pflocal/io.c 17 May 2005 09:25:48 -0000
-@@ -1,6 +1,6 @@
- /* Socket I/O operations
-
-- Copyright (C) 1995,96,98,99,2000,02 Free Software Foundation, Inc.
-+ Copyright (C) 1995,96,98,99,2000,02, 2005 Free Software Foundation, Inc.
- Written by Miles Bader <miles@gnu.org>
-
- This program is free software; you can redistribute it and/or
@@ -197,16 +197,16 @@ S_io_select (struct sock_user *user,
if (*select_type & SELECT_READ)
@@ -604,14 +580,6 @@ retrieving revision 1.22
diff -u -p -r1.22 socket.c
--- pflocal/socket.c 27 Jan 1996 17:37:55 -0000 1.22
+++ pflocal/socket.c 17 May 2005 09:25:48 -0000
-@@ -1,6 +1,6 @@
- /* Socket-specific operations
-
-- Copyright (C) 1995 Free Software Foundation, Inc.
-+ Copyright (C) 1995, 2005 Free Software Foundation, Inc.
-
- Written by Miles Bader <miles@gnu.ai.mit.edu>
-
@@ -110,7 +110,7 @@ S_socket_connect (struct sock_user *user
else if (sock->flags & SOCK_CONNECTED)
/* SOCK_CONNECTED is only set for connection-oriented sockets,
diff --git a/debian/patches/servers.boot-update.patch b/debian/patches/servers.boot-update.patch
deleted file mode 100644
index 0b355dac..00000000
--- a/debian/patches/servers.boot-update.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- release/servers.boot 1999-05-16 01:16:43.000000000 +0200
-+++ release/servers.boot.new 2007-07-31 15:39:02.000000000 +0200
-@@ -3,7 +3,8 @@
-
- # First, the bootstrap filesystem. It needs several ports as arguments,
- # as well as the user flags from the boot loader.
--/hurd/ufs.static --bootflags=${boot-args} --host-priv-port=${host-port} --device-master-port=${device-port} --exec-server-task=${exec-task} -Tdevice ${root-device} $(task-create) $(task-resume)
-+/hurd/ext2fs.static --multiboot-command-line=${kernel-command-line} --host-priv-port=${host-port} --device-master-port=${device-port} --exec-server-task=${exec-task} -T typed ${root} $(task-create) $(task-resume)
-+
-
- # Now the exec server; to load the dynamically-linked exec server program,
- # we have the boot loader in fact load and run ld.so, which in turn
-@@ -11,6 +12,3 @@
- # in ${exec-task} to be passed to the fs above, but it is left suspended;
- # the fs will resume the exec task once it is ready.
- /lib/ld.so.1 /hurd/exec $(exec-task=task-create)
--
--# default pager
--/dev/sd0b $(add-paging-file)
diff --git a/debian/patches/siocgifhwaddr.patch b/debian/patches/siocgifhwaddr.patch
deleted file mode 100644
index b8e9418c..00000000
--- a/debian/patches/siocgifhwaddr.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-2004-08-03 Marco Gerards <metgerards@student.han.nl>
-
- * iioctl.defs (iioctl_siocgifhwaddr): New RPC.
-
-Index: iioctl.defs
-===================================================================
-RCS file: /cvsroot/hurd/hurd/hurd/iioctl.defs,v
-retrieving revision 1.1
-diff -u -p -r1.1 iioctl.defs
---- hurd/iioctl.defs 11 Jan 2001 22:28:29 -0000 1.1
-+++ hurd/iioctl.defs 3 Aug 2004 13:12:34 -0000
-@@ -131,7 +131,14 @@ routine iioctl_siocgifnetmask (
- inout ifnam: ifname_t;
- inout netmask: sockaddr_t);
-
--skip; skip; skip; skip; /* 38, 39, 40, 41 unused */
-+skip; /* 38 SIOCGARP -- Not implemented yet */
-+
-+routine iioctl_siocgifhwaddr (
-+ reqport: io_t;
-+ inout ifnam: ifname_t;
-+ inout netmask: sockaddr_t);
-+
-+skip; skip; /* 40, 41 unused */
- skip; skip; skip; skip; /* 42, 43, 44, 45 unused */
- skip; skip; skip; skip; /* 46, 47, 48, 49 unused */
- skip; /* 50 unused */
-
-
-
-2004-08-03 Marco Gerards <metgerards@student.han.nl>
-
- * iioctl-ops.c (S_iioctl_siocgifhwaddr): New function.
-
-
-Index: iioctl-ops.c
-===================================================================
-RCS file: /cvsroot/hurd/hurd/pfinet/iioctl-ops.c,v
-retrieving revision 1.2
-diff -u -p -r1.2 iioctl-ops.c
---- pfinet/iioctl-ops.c 17 Jan 2001 01:37:51 -0000 1.2
-+++ pfinet/iioctl-ops.c 3 Aug 2004 13:11:45 -0000
-@@ -361,3 +361,28 @@ S_iioctl_siocgifname (io_t port,
-
- return err;
- }
-+
-+error_t
-+S_iioctl_siocgifhwaddr (io_t port,
-+ ifname_t ifname,
-+ sockaddr_t *addr)
-+{
-+ error_t err = 0;
-+ struct device *dev;
-+
-+ if (!port)
-+ return EOPNOTSUPP;
-+
-+ dev = get_dev (ifname);
-+ if (!dev)
-+ err = ENODEV;
-+ else
-+ {
-+ memcpy (addr->sa_data, dev->dev_addr, MAX_ADDR_LEN);
-+ addr->sa_family = dev->type;
-+
-+ }
-+
-+ __mutex_unlock (&global_lock);
-+ return err;
-+}