summaryrefslogtreecommitdiff
path: root/debian/patches/translators-list0003-libihash-add-general-purpose-hash-functions.patch
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2015-11-24 01:34:02 +0100
committerJustus Winter <4winter@informatik.uni-hamburg.de>2015-11-24 01:34:02 +0100
commitc5c8157b7def596bdf786d3c4de6537c62e30a97 (patch)
tree8d1b1f2041753f5afc9689b3666226caa6448a12 /debian/patches/translators-list0003-libihash-add-general-purpose-hash-functions.patch
parenteae82693bf1ed63dd63e5c2d78522bab37ab4ac5 (diff)
add patch series
Diffstat (limited to 'debian/patches/translators-list0003-libihash-add-general-purpose-hash-functions.patch')
-rw-r--r--debian/patches/translators-list0003-libihash-add-general-purpose-hash-functions.patch144
1 files changed, 144 insertions, 0 deletions
diff --git a/debian/patches/translators-list0003-libihash-add-general-purpose-hash-functions.patch b/debian/patches/translators-list0003-libihash-add-general-purpose-hash-functions.patch
new file mode 100644
index 00000000..2d095777
--- /dev/null
+++ b/debian/patches/translators-list0003-libihash-add-general-purpose-hash-functions.patch
@@ -0,0 +1,144 @@
+From 217f0c33da62cb96e12873a8f80a673caefac4c3 Mon Sep 17 00:00:00 2001
+From: Justus Winter <4winter@informatik.uni-hamburg.de>
+Date: Tue, 24 Nov 2015 01:07:32 +0100
+Subject: [PATCH hurd 3/5] libihash: add general purpose hash functions
+
+* libihash/Makefile (SRCS): Add new file.
+* libihash/fasthash.c: New file.
+* libihash/ihash.h (hurd_ihash_fasthash{32,64}): New prototypes.
+---
+ libihash/Makefile | 2 +-
+ libihash/fasthash.c | 76 +++++++++++++++++++++++++++++++++++++++++++++++++++++
+ libihash/ihash.h | 14 ++++++++++
+ 3 files changed, 91 insertions(+), 1 deletion(-)
+ create mode 100644 libihash/fasthash.c
+
+diff --git a/libihash/Makefile b/libihash/Makefile
+index 09bb136..eb5d87e 100644
+--- a/libihash/Makefile
++++ b/libihash/Makefile
+@@ -20,7 +20,7 @@ dir := libihash
+ makemode := library
+
+ libname := libihash
+-SRCS = ihash.c
++SRCS = ihash.c fasthash.c
+ installhdrs = ihash.h
+
+ OBJS = $(SRCS:.c=.o)
+diff --git a/libihash/fasthash.c b/libihash/fasthash.c
+new file mode 100644
+index 0000000..9295cf1
+--- /dev/null
++++ b/libihash/fasthash.c
+@@ -0,0 +1,76 @@
++/* The MIT License
++
++ Copyright (C) 2012 Zilong Tan (eric.zltan@gmail.com)
++
++ Permission is hereby granted, free of charge, to any person
++ obtaining a copy of this software and associated documentation
++ files (the "Software"), to deal in the Software without
++ restriction, including without limitation the rights to use, copy,
++ modify, merge, publish, distribute, sublicense, and/or sell copies
++ of the Software, and to permit persons to whom the Software is
++ furnished to do so, subject to the following conditions:
++
++ The above copyright notice and this permission notice shall be
++ included in all copies or substantial portions of the Software.
++
++ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
++ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
++ BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
++ ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
++ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
++ SOFTWARE.
++*/
++
++#include <stdint.h>
++#include <stdio.h>
++
++// Compression function for Merkle-Damgard construction.
++// This function is generated using the framework provided.
++#define mix(h) ({ \
++ (h) ^= (h) >> 23; \
++ (h) *= 0x2127599bf4325c37ULL; \
++ (h) ^= (h) >> 47; })
++
++uint64_t hurd_ihash_fasthash64(const void *buf, size_t len, uint64_t seed)
++{
++ const uint64_t m = 0x880355f21e6d1965ULL;
++ const uint64_t *pos = (const uint64_t *)buf;
++ const uint64_t *end = pos + (len / 8);
++ const unsigned char *pos2;
++ uint64_t h = seed ^ (len * m);
++ uint64_t v;
++
++ while (pos != end) {
++ v = *pos++;
++ h ^= mix(v);
++ h *= m;
++ }
++
++ pos2 = (const unsigned char*)pos;
++ v = 0;
++
++ switch (len & 7) {
++ case 7: v ^= (uint64_t)pos2[6] << 48;
++ case 6: v ^= (uint64_t)pos2[5] << 40;
++ case 5: v ^= (uint64_t)pos2[4] << 32;
++ case 4: v ^= (uint64_t)pos2[3] << 24;
++ case 3: v ^= (uint64_t)pos2[2] << 16;
++ case 2: v ^= (uint64_t)pos2[1] << 8;
++ case 1: v ^= (uint64_t)pos2[0];
++ h ^= mix(v);
++ h *= m;
++ }
++
++ return mix(h);
++}
++
++uint32_t hurd_ihash_fasthash32(const void *buf, size_t len, uint32_t seed)
++{
++ // the following trick converts the 64-bit hashcode to Fermat
++ // residue, which shall retain information from both the higher
++ // and lower parts of hashcode.
++ uint64_t h = hurd_ihash_fasthash64(buf, len, seed);
++ return h - (h >> 32);
++}
+diff --git a/libihash/ihash.h b/libihash/ihash.h
+index 986291b..50676a6 100644
+--- a/libihash/ihash.h
++++ b/libihash/ihash.h
+@@ -136,6 +136,13 @@ typedef struct hurd_ihash *hurd_ihash_t;
+ .max_load = HURD_IHASH_MAX_LOAD_DEFAULT, \
+ .locp_offset = (locp_offs)}
+
++#define HURD_IHASH_INITIALIZER_GKI(locp_offs, cleanup, hash, compare) \
++ { .nr_items = 0, .size = 0, .cleanup = (cleanup), \
++ .max_load = HURD_IHASH_MAX_LOAD_DEFAULT, \
++ .locp_offset = (locp_offs), \
++ .fct_hash = (hash), \
++ .fct_cmp = (compare)} \
++
+ /* Initialize the hash table at address HT. If LOCP_OFFSET is not
+ HURD_IHASH_NO_LOCP, then this is an offset (in bytes) from the
+ address of a hash value where a location pointer can be found. The
+@@ -339,5 +346,12 @@ int hurd_ihash_remove (hurd_ihash_t ht, hurd_ihash_key_t key);
+ was provided to hurd_ihash_add(). This call is faster than
+ hurd_ihash_remove(). */
+ void hurd_ihash_locp_remove (hurd_ihash_t ht, hurd_ihash_locp_t locp);
++
++/* General purpose hash functions. */
++
++/* Zilong Tans fast-hash. Based on 'Marsaglia, George. "Xorshift
++ rngs." Journal of Statistical Software 8.14 (2003): 1-6.' */
++uint32_t hurd_ihash_fasthash32 (const void *buf, size_t len, uint32_t seed);
++uint64_t hurd_ihash_fasthash64 (const void *buf, size_t len, uint64_t seed);
+
+ #endif /* _HURD_IHASH_H */
+--
+2.1.4
+