summaryrefslogtreecommitdiff
path: root/debian/patches/startup0003-startup-use-the-generated-default-server-implementat.patch
diff options
context:
space:
mode:
authorJustus Winter <justus@gnupg.org>2016-04-26 19:15:41 +0200
committerJustus Winter <justus@gnupg.org>2016-04-26 19:15:41 +0200
commitef35a7912013767b01ac9b9aa75c54774fc73b5a (patch)
tree59737f411f167567f0ccb352b4dcc5d796befb55 /debian/patches/startup0003-startup-use-the-generated-default-server-implementat.patch
parent754232cb582df208508c124aeb24b0f5f1e31b2d (diff)
drop old patch series
Diffstat (limited to 'debian/patches/startup0003-startup-use-the-generated-default-server-implementat.patch')
-rw-r--r--debian/patches/startup0003-startup-use-the-generated-default-server-implementat.patch153
1 files changed, 0 insertions, 153 deletions
diff --git a/debian/patches/startup0003-startup-use-the-generated-default-server-implementat.patch b/debian/patches/startup0003-startup-use-the-generated-default-server-implementat.patch
deleted file mode 100644
index 45cfbbee..00000000
--- a/debian/patches/startup0003-startup-use-the-generated-default-server-implementat.patch
+++ /dev/null
@@ -1,153 +0,0 @@
-From 5f6d67e9df94930a4ecf37daabb5f3c8d92423b4 Mon Sep 17 00:00:00 2001
-From: Justus Winter <justus@gnupg.org>
-Date: Tue, 26 Apr 2016 19:12:17 +0200
-Subject: [PATCH hurd 3/3] startup: use the generated default server
- implementations
-
-* startup/Makefile: Set appropriate flags.
-* startup/startup.c: Drop most stub functions.
----
- startup/Makefile | 3 ++
- startup/startup.c | 102 +-----------------------------------------------------
- 2 files changed, 4 insertions(+), 101 deletions(-)
-
-diff --git a/startup/Makefile b/startup/Makefile
-index db062ad..bda3ffb 100644
---- a/startup/Makefile
-+++ b/startup/Makefile
-@@ -28,6 +28,9 @@ HURDLIBS = shouldbeinlibc
- # startup does not use libports. Disable the default payload to port
- # conversion.
- MIGSFLAGS="-DHURD_DEFAULT_PAYLOAD_TO_PORT=1"
-+notify-MIGSFLAGS="-DNOTIFY_IMPORTS=import <hurd.h>;"
-+notifyServer-CFLAGS="-DMIG_EOPNOTSUPP=EOPNOTSUPP"
-+fsysServer-CFLAGS="-DMIG_EOPNOTSUPP=EOPNOTSUPP"
- fsServer-CFLAGS="-DMIG_EOPNOTSUPP=EOPNOTSUPP"
- ioServer-CFLAGS="-DMIG_EOPNOTSUPP=EOPNOTSUPP"
-
-diff --git a/startup/startup.c b/startup/startup.c
-index b64f6de..2491e92 100644
---- a/startup/startup.c
-+++ b/startup/startup.c
-@@ -1448,41 +1448,6 @@ S_startup_reboot (mach_port_t server,
- for (;;);
- }
-
--/* Stubs for unused notification RPCs. */
--
--kern_return_t
--do_mach_notify_port_destroyed (mach_port_t notify,
-- mach_port_t rights)
--{
-- return EOPNOTSUPP;
--}
--
--kern_return_t
--do_mach_notify_send_once (mach_port_t notify)
--{
-- return EOPNOTSUPP;
--}
--
--kern_return_t
--do_mach_notify_no_senders (mach_port_t port, mach_port_mscount_t mscount)
--{
-- return EOPNOTSUPP;
--}
--
--kern_return_t
--do_mach_notify_port_deleted (mach_port_t notify,
-- mach_port_t name)
--{
-- return EOPNOTSUPP;
--}
--
--kern_return_t
--do_mach_notify_msg_accepted (mach_port_t notify,
-- mach_port_t name)
--{
-- return EOPNOTSUPP;
--}
--
- /* msg server */
-
- kern_return_t
-@@ -1731,75 +1696,10 @@ S_fsys_getroot (mach_port_t fsys_t,
- }
-
- error_t
--S_fsys_goaway (mach_port_t control, int flags)
--{
-- return EOPNOTSUPP;
--}
--
--error_t
--S_fsys_startup (mach_port_t bootstrap, int flags, mach_port_t control,
-- mach_port_t *real, mach_msg_type_name_t *realtype)
--{
-- return EOPNOTSUPP;
--}
--
--error_t
--S_fsys_syncfs (mach_port_t control,
-- int wait,
-- int recurse)
--{
-- return EOPNOTSUPP;
--}
--
--error_t
--S_fsys_set_options (mach_port_t control,
-- char *data, mach_msg_type_number_t len,
-- int do_children)
--{
-- return EOPNOTSUPP;
--}
--
--error_t
- S_fsys_get_options (mach_port_t control,
- char **data, mach_msg_type_number_t *len)
- {
-- return EOPNOTSUPP;
--}
--
--error_t
--S_fsys_getfile (mach_port_t control,
-- uid_t *uids, size_t nuids,
-- uid_t *gids, size_t ngids,
-- char *handle, size_t handllen,
-- mach_port_t *pt,
-- mach_msg_type_name_t *pttype)
--{
-- return EOPNOTSUPP;
--}
--
--error_t
--S_fsys_getpriv (mach_port_t control,
-- mach_port_t *host_priv, mach_msg_type_name_t *host_priv_type,
-- mach_port_t *dev_master, mach_msg_type_name_t *dev_master_type,
-- task_t *fs_task, mach_msg_type_name_t *fs_task_type)
--{
-- return EOPNOTSUPP;
--}
--
--error_t
--S_fsys_init (mach_port_t control,
-- mach_port_t reply,
-- mach_msg_type_name_t replytype,
-- mach_port_t proc,
-- auth_t auth)
--{
-- return EOPNOTSUPP;
--}
--
--error_t
--S_fsys_forward (mach_port_t server, mach_port_t requestor,
-- char *argz, size_t argz_len)
--{
-+ /* XXX Implement me. */
- return EOPNOTSUPP;
- }
-
---
-2.1.4
-