summaryrefslogtreecommitdiff
path: root/debian/patches/external.patch
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2012-11-27 23:24:42 +0000
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2012-11-27 23:24:42 +0000
commit3c423ce17e1511f7b71c05e0f53c5ebc93bd266d (patch)
treeb099a7e6b33ef43c4d836e9eb7a46a1ac1ee7cea /debian/patches/external.patch
parentd6339873a35867819e4a906d923e8731ce377e8e (diff)
refresh patches
Diffstat (limited to 'debian/patches/external.patch')
-rw-r--r--debian/patches/external.patch22
1 files changed, 12 insertions, 10 deletions
diff --git a/debian/patches/external.patch b/debian/patches/external.patch
index 19c9b97a..76005f36 100644
--- a/debian/patches/external.patch
+++ b/debian/patches/external.patch
@@ -53,13 +53,13 @@ index 05b959b..68ec159 100644
Index: hurd-debian/procfs/Makefile
===================================================================
---- hurd-debian.orig/procfs/Makefile 2010-09-27 19:50:41.000000000 +0000
-+++ hurd-debian/procfs/Makefile 2010-09-27 19:50:46.000000000 +0000
+--- hurd-debian.orig/procfs/Makefile 2012-11-26 00:23:22.000000000 +0000
++++ hurd-debian/procfs/Makefile 2012-11-26 00:25:35.000000000 +0000
@@ -1,26 +1,31 @@
-TARGET = procfs
-OBJS = procfs.o netfs.o procfs_dir.o \
- process.o proclist.o rootdir.o dircat.o main.o
--LIBS = -lnetfs -lps
+-LIBS = -lnetfs -lps -lfshelp
+# Makefile - for procfs
+#
+# Copyright (C) 2008 Free Software Foundation, Inc.
@@ -82,24 +82,26 @@ Index: hurd-debian/procfs/Makefile
+makemode := server
+
+target = procfs
++
++SRCS = procfs.c netfs.c procfs_dir.c process.c proclist.c rootdir.c dircat.c main.c
++LCLHDRS = dircat.h main.h process.h procfs.h procfs_dir.h proclist.h rootdir.h
++
++OBJS = $(SRCS:.c=.o)
++HURDLIBS = netfs fshelp iohelp ps ports ihash shouldbeinlibc
++OTHERLIBS = -lpthread
-CC = gcc
-CFLAGS = -Wall -g
-CPPFLAGS =
-LDFLAGS =
-+SRCS = procfs.c netfs.c procfs_dir.c process.c proclist.c rootdir.c dircat.c main.c
-+LCLHDRS = dircat.h main.h process.h procfs.h procfs_dir.h proclist.h rootdir.h
-
+-
-ifdef PROFILE
-CFLAGS= -g -pg
-CPPFLAGS= -DPROFILE
-LDFLAGS= -static
-LIBS= -lnetfs -lfshelp -liohelp -lps -lports -lthreads -lihash -lshouldbeinlibc
-endif
-+OBJS = $(SRCS:.c=.o)
-+HURDLIBS = netfs fshelp iohelp ps ports ihash shouldbeinlibc
-+OTHERLIBS = -lpthread
-
+-
-CPPFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
-
-all: $(TARGET)