summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@debian.org>2010-04-27 16:15:18 +0000
committerSamuel Thibault <sthibault@debian.org>2010-04-27 16:15:18 +0000
commitf58a176d7ed09276406feb36a10a853417a441cf (patch)
treea72f58e8e1016a3894007a676d2f5caacc6caaba /debian
parent7d5583376440383431c714bd2862926415bcf848 (diff)
* debian/patches/40_iopl_mmap.patch: Add a "mem" alias for the iopl device,
since that is what upstream provides.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/40_iopl_mmap.patch13
2 files changed, 12 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index df9e837..bc759cc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ gnumach (2:1.3.99.dfsg.git20091128-2) UNRELEASED; urgency=low
- Add ${misc:Depends}.
* debian/patches/40_iopl_mem.patch: Add patch, not enabled yet, to be used
instead of 40_iopl_mmap.patch when a new snapshot is taken.
+ * debian/patches/40_iopl_mmap.patch: Add a "mem" alias for the iopl device,
+ since that is what upstream provides.
[ Guillem Jover ]
* Now using Standards-Version 3.8.4 (no changes needed).
diff --git a/debian/patches/40_iopl_mmap.patch b/debian/patches/40_iopl_mmap.patch
index a011149..cb49f96 100644
--- a/debian/patches/40_iopl_mmap.patch
+++ b/debian/patches/40_iopl_mmap.patch
@@ -1,4 +1,6 @@
Device for direct memory access (needed e.g. for Xorg).
+Upstream now has a mem device, so this patch should go away and be replaced by
+40_iopl_mem.patch when we upgrade the Debian snapshot.
Index: b/i386/Makefrag.am
===================================================================
@@ -13,20 +15,20 @@ Index: b/i386/Makefrag.am
i386/i386at/kd.h \
i386/i386at/kd_event.c \
Index: b/i386/i386at/conf.c
-===================================================================
--- a/i386/i386at/conf.c
+++ b/i386/i386at/conf.c
-@@ -58,6 +58,9 @@ extern int kbdgetstat(), kbdsetstat();
+@@ -58,6 +58,10 @@ extern int kbdgetstat(), kbdsetstat();
extern int mouseopen(), mouseclose(), mouseread(), mousegetstat();
#define mousename "mouse"
+extern vm_offset_t ioplmmap();
+#define ioplname "iopl"
++#define memname "mem"
+
extern int kmsgopen(), kmsgclose(), kmsgread(), kmsggetstat();
#define kmsgname "kmsg"
-@@ -113,6 +116,11 @@ struct dev_ops dev_name_list[] =
+@@ -113,6 +117,16 @@ struct dev_ops dev_name_list[] =
nodev, nulldev, nulldev, 0,
nodev },
@@ -35,6 +37,11 @@ Index: b/i386/i386at/conf.c
+ nodev, nulldev, nulldev, 0,
+ nodev },
+
++ { memname, nulldev, nulldev, nodev,
++ nodev, nodev, nodev, ioplmmap,
++ nodev, nulldev, nulldev, 0,
++ nodev },
++
#ifdef MACH_KMSG
{ kmsgname, kmsgopen, kmsgclose, kmsgread,
nodev, kmsggetstat, nodev, nomap,