summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2009-02-20 01:18:48 +0000
committerGuillem Jover <guillem@debian.org>2009-02-20 01:18:48 +0000
commite2645532ad48566e6cc6751a4ccdd13c5c14d898 (patch)
tree5b0e446ffa15dbddb7390aecbb29784deaf234a8 /debian
parentb9ac4f3f17839f4e8bb88564b20e2e70921f4ca2 (diff)
Sync with upstream gnumach snapshot 1.3.99.dfsg.cvs20090220
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/patches/00_clean_gfdl.patch2
-rw-r--r--debian/patches/05_halt_on_panic_flag.patch10
-rw-r--r--debian/patches/14_alloc_params.patch19
-rw-r--r--debian/patches/15_mem_obj_proxy.patch8
-rw-r--r--debian/patches/20_mmx_support.patch4
6 files changed, 22 insertions, 34 deletions
diff --git a/debian/changelog b/debian/changelog
index 6aa0077..7170191 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,21 @@
-gnumach (2:1.3.99.dfsg.cvs20080708-2) UNRELEASED; urgency=low
+gnumach (2:1.3.99.dfsg.cvs20090220-1) UNRELEASED; urgency=low
+
+ * New upstream CVS snapshot.
[ Samuel Thibault ]
* Remove kern/mach_param.h patch from debian/patches/14_alloc_params.patch,
- increase zone_map_size, kernel virtual space and maximum number of cached
- objects.
+ increase zone_map_size and maximum number of cached objects.
[ Guillem Jover ]
* Switch to debhelper compatibility level 7.
* Use dh_prep instead of “dh_clean -k”.
* Remove XC- prefix from Package-Type field.
+ * Sync with upstream:
+ - debian/patches/00_clean_gfdl.patch: Refresh.
+ - debian/patches/05_halt_on_panic_flag.patch: Likewise.
+ - debian/patches/14_alloc_params.patch: Likewise.
+ - debian/patches/15_mem_obj_proxy.patch: Likewise.
+ - debian/patches/20_mmx_support.patch: Likewise.
-- Guillem Jover <guillem@debian.org> Tue, 08 Jul 2008 16:54:06 +0300
diff --git a/debian/patches/00_clean_gfdl.patch b/debian/patches/00_clean_gfdl.patch
index d3d327c..b60af0e 100644
--- a/debian/patches/00_clean_gfdl.patch
+++ b/debian/patches/00_clean_gfdl.patch
@@ -2,7 +2,7 @@ Index: b/Makefile.am
===================================================================
--- a/Makefile.am
+++ b/Makefile.am
-@@ -108,7 +108,7 @@ include Makefrag.am
+@@ -117,7 +117,7 @@ include Makefrag.am
include tests/Makefrag.am
# Documentation.
diff --git a/debian/patches/05_halt_on_panic_flag.patch b/debian/patches/05_halt_on_panic_flag.patch
index 1509810..b14101f 100644
--- a/debian/patches/05_halt_on_panic_flag.patch
+++ b/debian/patches/05_halt_on_panic_flag.patch
@@ -11,7 +11,7 @@ Index: b/i386/i386at/model_dep.c
===================================================================
--- a/i386/i386at/model_dep.c
+++ b/i386/i386at/model_dep.c
-@@ -96,6 +96,10 @@ void inittodr(); /* forward */
+@@ -110,6 +110,10 @@ void inittodr(); /* forward */
int rebootflag = 0; /* exported to kdintr */
@@ -22,9 +22,9 @@ Index: b/i386/i386at/model_dep.c
/* XX interrupt stack pointer and highwater mark, for locore.S. */
vm_offset_t int_stack_top, int_stack_high;
-@@ -368,6 +372,11 @@ void c_boot_entry(vm_offset_t bi)
+@@ -394,6 +398,11 @@ void c_boot_entry(vm_offset_t bi)
cninit(); /* need console for debugger */
- Debugger();
+ Debugger("init");
}
+#else
+ if (strstr (kernel_cmdline, "-H "))
@@ -38,7 +38,7 @@ Index: b/kern/debug.c
===================================================================
--- a/kern/debug.c
+++ b/kern/debug.c
-@@ -124,6 +124,10 @@ panic_init(void)
+@@ -126,6 +126,10 @@ panic_init(void)
}
}
@@ -49,7 +49,7 @@ Index: b/kern/debug.c
/*VARARGS1*/
void
panic(const char *s, ...)
-@@ -165,7 +169,7 @@ panic(const char *s, ...)
+@@ -167,7 +171,7 @@ panic(const char *s, ...)
delay (1000000); /* microseconds */
}
diff --git a/debian/patches/14_alloc_params.patch b/debian/patches/14_alloc_params.patch
index befe470..d71c245 100644
--- a/debian/patches/14_alloc_params.patch
+++ b/debian/patches/14_alloc_params.patch
@@ -1,7 +1,5 @@
2008-12-29 Samuel Thibault <samuel.thibault@ens-lyon.org>
- * i386/intel/pmap.c (pmap_bootstrap): Extend kernel virtual memory to
- at least the size of the physical memory.
* kern/zalloc.c (zone_map_size): Increase from 12 to 64 MiB.
2007-12-30 Samuel Thibault <samuel.thibault@ens-lyon.org>
@@ -51,20 +49,3 @@ Index: b/vm/vm_map.h
typedef struct vm_map_copy {
int type;
-Index: i386/intel/pmap.c
-===================================================================
-RCS file: /cvsroot/hurd/gnumach/i386/intel/pmap.c,v
-retrieving revision 1.4.2.23
-retrieving revision 1.4.2.24
-diff -u -p -r1.4.2.23 -r1.4.2.24
---- i386/intel/pmap.c 27 Nov 2008 01:37:52 -0000 1.4.2.23
-+++ i386/intel/pmap.c 29 Dec 2008 11:11:03 -0000 1.4.2.24
-@@ -576,7 +576,7 @@ void pmap_bootstrap()
- */
- kernel_virtual_start = phys_last_addr;
- kernel_virtual_end = phys_last_addr + morevm
-- + (phys_last_addr - phys_first_addr) / 15;
-+ + (phys_last_addr - phys_first_addr);
-
- if (kernel_virtual_end < phys_last_addr
- || kernel_virtual_end > VM_MAX_KERNEL_ADDRESS)
diff --git a/debian/patches/15_mem_obj_proxy.patch b/debian/patches/15_mem_obj_proxy.patch
index 303c7ce..e73bb4d 100644
--- a/debian/patches/15_mem_obj_proxy.patch
+++ b/debian/patches/15_mem_obj_proxy.patch
@@ -84,7 +84,7 @@ Index: b/kern/ipc_kobject.c
===================================================================
--- a/kern/ipc_kobject.c
+++ b/kern/ipc_kobject.c
-@@ -353,6 +353,9 @@ ipc_kobject_notify(request_header, reply
+@@ -355,6 +355,9 @@ ipc_kobject_notify(request_header, reply
case IKOT_DEVICE:
return ds_notify(request_header);
@@ -320,7 +320,7 @@ Index: b/vm/vm_init.c
===================================================================
--- a/vm/vm_init.c
+++ b/vm/vm_init.c
-@@ -81,4 +81,5 @@ void vm_mem_bootstrap()
+@@ -82,4 +82,5 @@ void vm_mem_bootstrap()
void vm_mem_init()
{
vm_object_init();
@@ -330,7 +330,7 @@ Index: b/vm/vm_user.c
===================================================================
--- a/vm/vm_user.c
+++ b/vm/vm_user.c
-@@ -275,6 +275,12 @@ kern_return_t vm_copy(map, source_addres
+@@ -276,6 +276,12 @@ kern_return_t vm_copy(map, source_addres
return KERN_SUCCESS;
}
@@ -343,7 +343,7 @@ Index: b/vm/vm_user.c
/*
* Routine: vm_map
*/
-@@ -324,7 +330,22 @@ kern_return_t vm_map(
+@@ -325,7 +331,22 @@ kern_return_t vm_map(
copy = FALSE;
} else if ((object = vm_object_enter(memory_object, size, FALSE))
== VM_OBJECT_NULL)
diff --git a/debian/patches/20_mmx_support.patch b/debian/patches/20_mmx_support.patch
index 4931f60..692a57f 100644
--- a/debian/patches/20_mmx_support.patch
+++ b/debian/patches/20_mmx_support.patch
@@ -310,7 +310,7 @@ Index: b/i386/i386/fpu.h
===================================================================
--- a/i386/i386/fpu.h
+++ b/i386/i386/fpu.h
-@@ -66,6 +66,12 @@
+@@ -67,6 +67,12 @@
#define frstor(state) \
asm volatile("frstor %0" : : "m" (state))
@@ -323,7 +323,7 @@ Index: b/i386/i386/fpu.h
#define fwait() \
asm("fwait");
-@@ -85,7 +91,10 @@
+@@ -86,7 +92,10 @@
if (ifps != 0 && !ifps->fp_valid) { \
/* registers are in FPU - save to memory */ \
ifps->fp_valid = TRUE; \