summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2010-07-31 16:21:39 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2010-07-31 16:21:39 +0200
commitd78dd33668e026982b1ca86e8f3115aabf077cdc (patch)
tree58086909a9f0b2d570ae07adf8df372ea90f85b6 /debian
parent2089ebf06325c8068aef1870a8e3f2cd376186c9 (diff)
New upstream snapshot
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/10_cdromlock.patch2
-rw-r--r--debian/patches/40_iopl_mem.patch5
-rw-r--r--debian/patches/40_iopl_mmap.patch108
-rw-r--r--debian/patches/series2
5 files changed, 7 insertions, 113 deletions
diff --git a/debian/changelog b/debian/changelog
index 9b7aced..39a6573 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
-gnumach (2:1.3.99.dfsg.git20091128-2) UNRELEASED; urgency=low
+gnumach (2:1.3.99.dfsg.git20100731-1) UNRELEASED; urgency=low
[ Samuel Thibault ]
+ * New upstream snapshot.
* debian/control
- (gnumach-udeb): Add XC- prefix to Package-Type. Add Provides:
kernel-image, *-modules.
diff --git a/debian/patches/10_cdromlock.patch b/debian/patches/10_cdromlock.patch
index ac03488..436f97c 100644
--- a/debian/patches/10_cdromlock.patch
+++ b/debian/patches/10_cdromlock.patch
@@ -65,7 +65,7 @@ Index: b/linux/dev/glue/block.c
/* Check block BN and size COUNT for I/O validity
@@ -1704,6 +1711,17 @@ device_get_status (void *d, dev_flavor_t
- return D_SUCCESS;
+ return D_INVALID_OPERATION;
}
+
diff --git a/debian/patches/40_iopl_mem.patch b/debian/patches/40_iopl_mem.patch
index 5719a57..9c54e1b 100644
--- a/debian/patches/40_iopl_mem.patch
+++ b/debian/patches/40_iopl_mem.patch
@@ -1,5 +1,6 @@
-The mem device provides direct memory access (needed e.g. for Xorg), but some
-packages (Xorg, notably) are still using the iopl device.
+The mem device provides direct memory access (needed e.g. for Xorg), but
+some packages (Xorg, notably) are still using the iopl device. TODO: fix
+them and drop this patch.
diff --git a/i386/i386at/conf.c b/i386/i386at/conf.c
index d51b5ee..88e753c 100644
diff --git a/debian/patches/40_iopl_mmap.patch b/debian/patches/40_iopl_mmap.patch
deleted file mode 100644
index cb49f96..0000000
--- a/debian/patches/40_iopl_mmap.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-Device for direct memory access (needed e.g. for Xorg).
-Upstream now has a mem device, so this patch should go away and be replaced by
-40_iopl_mem.patch when we upgrade the Debian snapshot.
-
-Index: b/i386/Makefrag.am
-===================================================================
---- a/i386/Makefrag.am
-+++ b/i386/Makefrag.am
-@@ -31,6 +31,7 @@ libkernel_a_SOURCES += \
- i386/i386at/immc.c \
- i386/i386at/int_init.c \
- i386/i386at/interrupt.S \
-+ i386/i386at/iopl.c \
- i386/i386at/kd.c \
- i386/i386at/kd.h \
- i386/i386at/kd_event.c \
-Index: b/i386/i386at/conf.c
---- a/i386/i386at/conf.c
-+++ b/i386/i386at/conf.c
-@@ -58,6 +58,10 @@ extern int kbdgetstat(), kbdsetstat();
- extern int mouseopen(), mouseclose(), mouseread(), mousegetstat();
- #define mousename "mouse"
-
-+extern vm_offset_t ioplmmap();
-+#define ioplname "iopl"
-+#define memname "mem"
-+
- extern int kmsgopen(), kmsgclose(), kmsgread(), kmsggetstat();
- #define kmsgname "kmsg"
-
-@@ -113,6 +117,16 @@ struct dev_ops dev_name_list[] =
- nodev, nulldev, nulldev, 0,
- nodev },
-
-+ { ioplname, nulldev, nulldev, nodev,
-+ nodev, nodev, nodev, ioplmmap,
-+ nodev, nulldev, nulldev, 0,
-+ nodev },
-+
-+ { memname, nulldev, nulldev, nodev,
-+ nodev, nodev, nodev, ioplmmap,
-+ nodev, nulldev, nulldev, 0,
-+ nodev },
-+
- #ifdef MACH_KMSG
- { kmsgname, kmsgopen, kmsgclose, kmsgread,
- nodev, kmsggetstat, nodev, nomap,
-Index: b/i386/i386at/iopl.c
-===================================================================
---- /dev/null
-+++ b/i386/i386at/iopl.c
-@@ -0,0 +1,56 @@
-+/*
-+ * Mach Operating System
-+ * Copyright (c) 1991,1990,1989 Carnegie Mellon University
-+ * All Rights Reserved.
-+ *
-+ * Permission to use, copy, modify and distribute this software and its
-+ * documentation is hereby granted, provided that both the copyright
-+ * notice and this permission notice appear in all copies of the
-+ * software, derivative works or modified versions, and any portions
-+ * thereof, and that both notices appear in supporting documentation.
-+ *
-+ * CARNEGIE MELLON ALLOWS FREE USE OF THIS SOFTWARE IN ITS "AS IS"
-+ * CONDITION. CARNEGIE MELLON DISCLAIMS ANY LIABILITY OF ANY KIND FOR
-+ * ANY DAMAGES WHATSOEVER RESULTING FROM THE USE OF THIS SOFTWARE.
-+ *
-+ * Carnegie Mellon requests users of this software to return to
-+ *
-+ * Software Distribution Coordinator or Software.Distribution@CS.CMU.EDU
-+ * School of Computer Science
-+ * Carnegie Mellon University
-+ * Pittsburgh PA 15213-3890
-+ *
-+ * any improvements or extensions that they make and grant Carnegie Mellon
-+ * the rights to redistribute these changes.
-+ */
-+
-+#include <device/io_req.h>
-+
-+/*ARGSUSED*/
-+int iopl_all = 1;
-+int
-+ioplmmap(dev, off, prot)
-+int dev;
-+vm_offset_t off;
-+vm_prot_t prot;
-+{
-+ extern vm_offset_t phys_last_addr;
-+
-+ if (iopl_all) {
-+ if (off == 0)
-+ return 0;
-+ else if (off < 0xa0000)
-+ return -1;
-+ else if (off >= 0x100000 && off <= phys_last_addr)
-+ return -1;
-+ else
-+ return i386_btop(off);
-+
-+ }
-+ if (off > 0x60000)
-+ return(-1);
-+
-+ /* Get page frame number for the page to be mapped. */
-+
-+ return(i386_btop(0xa0000 + off));
-+}
diff --git a/debian/patches/series b/debian/patches/series
index 92091ef..baf3363 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,4 +2,4 @@
10_cdromlock.patch
13_ide_dma.patch
24_pci_irq_fix.patch
-40_iopl_mmap.patch
+40_iopl_mem.patch