summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2004-09-19 04:32:53 +0000
committerGuillem Jover <guillem@debian.org>2004-09-19 04:32:53 +0000
commitc132498b1719595e377c3b651124bd10e4fc29d3 (patch)
treecefd46bc9620698ce2ef91e0f118dca3c205cd25 /debian
parent6b213a7a1f82fd1d0ff189eb8c1b8c224bccf400 (diff)
Support DESTDIR on upstream makefiles.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/01_makefiles_DESTDIR.patch43
2 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2bf38f5..be33014 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ gnumach (1:20040915-1) unstable; urgency=low
* Added myself to Uploaders.
* Cleaned and updated debian/copyright file.
* Honour DEB_BUILD_OPTIONS.
+ * Support DESTDIR on upstream makefiles.
* Split patches into debian/patches/.
* Allow to build natively on non GNU/Hurd systems.
* Enable i386, kfreebsd-i386 and knetbsd-i386 on all packages.
diff --git a/debian/patches/01_makefiles_DESTDIR.patch b/debian/patches/01_makefiles_DESTDIR.patch
new file mode 100644
index 0000000..e2a1a14
--- /dev/null
+++ b/debian/patches/01_makefiles_DESTDIR.patch
@@ -0,0 +1,43 @@
+#DPATCHLEVEL=1
+
+2004-09-19 Guillem Jover <guillem@hadrons.org>
+
+ * Makefile.in: Honour DESTDIR on installation targets.
+
+
+diff -Naur gnumach-20040915.orig/Makefile.in gnumach-20040915/Makefile.in
+--- gnumach-20040915.orig/Makefile.in 2004-09-19 05:35:01.000000000 +0200
++++ gnumach-20040915/Makefile.in 2004-09-19 05:31:17.000000000 +0200
+@@ -334,23 +334,25 @@
+ install: install-headers install-kernel
+
+ $(installed-headers-names): $(includedir)/%: $(srcdir)/include/%
+- $(INSTALL_DATA) $< $@
++ $(INSTALL_DATA) $< $(DESTDIR)$@
+
+ $(installed-sysdep-headers-names): $(includedir)/%: $(sysdep)/include/%
+- $(INSTALL_DATA) $< $@
++ $(INSTALL_DATA) $< $(DESTDIR)$@
+
+ install-headers: mkheaderdirs $(installed-headers-names) $(installed-sysdep-headers-names)
+- ln -sf $(systype) $(includedir)/mach/machine
++ ln -sf $(systype) $(DESTDIR)$(includedir)/mach/machine
+
+ install-kernel: kernel mkkerneldirs
+- $(INSTALL_PROGRAM) kernel $(bootdir)/gnumach
++ $(INSTALL_PROGRAM) kernel $(DESTDIR)$(bootdir)/gnumach
+
+ mkheaderdirs:
+- mkdir -p $(includedir) $(includedir)/device $(includedir)/mach \
+- $(includedir)/mach/$(systype) $(includedir)/mach/exec
++ mkdir -p $(DESTDIR)$(includedir) $(DESTDIR)$(includedir)/device \
++ $(DESTDIR)$(includedir)/mach \
++ $(DESTDIR)$(includedir)/mach/$(systype) \
++ $(DESTDIR)$(includedir)/mach/exec
+
+ mkkerneldirs:
+- mkdir -p $(bootdir)
++ mkdir -p $(DESTDIR)$(bootdir)
+
+
+ #