summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2004-11-20 22:12:48 +0000
committerGuillem Jover <guillem@debian.org>2004-11-20 22:12:48 +0000
commitb4a3a633dd308029f5d64da0fd811fec01360588 (patch)
treea8e9992a5bcd1174de6ad68965e5a3a8d6947b75 /debian
parent626894d635c88c148205f6a72ef39b10f98f45d4 (diff)
Repackage upstream source to remove binary only data. (Closes: #252323)
- i386/i386/fpe.b: Remove binary without source. - i386/i386/fpe.b_elf: Likewise. - linux/src/drivers/scsi/qlogicisp_asm.c: Likewise. Disable floating point emulation usage. Disable qlogicisp firmware loading.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/patches/14_disable_fpe.patch61
-rw-r--r--debian/patches/15_disable_qlogic_firmware.patch44
3 files changed, 117 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 9f1eb10..2dcfaab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+gnumach (1:20040915.dfsg.1-1) unstable; urgency=low
+
+ * Repackage upstream source to remove binary only data.
+ (Closes: #252323)
+ - i386/i386/fpe.b: Remove binary without source.
+ - i386/i386/fpe.b_elf: Likewise.
+ - linux/src/drivers/scsi/qlogicisp_asm.c: Likewise.
+ * Disable floating point emulation usage.
+ * Disable qlogicisp firmware loading.
+
+ -- Guillem Jover <guillem@debian.org> Tue, 16 Nov 2004 07:58:02 +0100
+
gnumach (1:20040915-1) unstable; urgency=low
* New upstream CVS snapshot.
diff --git a/debian/patches/14_disable_fpe.patch b/debian/patches/14_disable_fpe.patch
new file mode 100644
index 0000000..f730686
--- /dev/null
+++ b/debian/patches/14_disable_fpe.patch
@@ -0,0 +1,61 @@
+#DPATCHLEVEL=1
+
+2004-10-26 Guillem Jover <guillem@hadrons.org>
+
+ * i386/i386/fpe.b: Remove binary without source.
+ * i386/i386/fpe.b_elf: Likewise.
+ * i386/i386/fpe_linkage.c: Disable the code if [! FPE].
+ * i386/bogus/fpe.h: Add comment about not having an fpe implementation.
+ * i386/Makefrag (objfiles): Do not add fpe.o.
+ Remove targets to generate fpe.o.
+
+
+diff -Naur gnumach-20040915.orig/i386/bogus/fpe.h gnumach-20040915/i386/bogus/fpe.h
+--- gnumach-20040915.orig/i386/bogus/fpe.h 2001-06-25 18:28:26.000000000 +0200
++++ gnumach-20040915/i386/bogus/fpe.h 2004-10-26 11:27:49.000000000 +0200
+@@ -1 +1,2 @@
++/* We do not have a floating point implementation. */
+ #define FPE 0
+diff -Naur gnumach-20040915.orig/i386/i386/fpe_linkage.c gnumach-20040915/i386/i386/fpe_linkage.c
+--- gnumach-20040915.orig/i386/i386/fpe_linkage.c 1997-02-25 22:27:09.000000000 +0100
++++ gnumach-20040915/i386/i386/fpe_linkage.c 2004-10-26 11:28:29.000000000 +0200
+@@ -30,6 +30,8 @@
+
+ #include <fpe.h>
+
++#if FPE
++
+ #include <cpus.h>
+
+ #include <mach/std_types.h>
+@@ -357,3 +359,5 @@
+ }
+ exception(exc, code, subcode);
+ }
++#endif /* FPE. */
++
+diff -Naur gnumach-20040915.orig/i386/Makefrag gnumach-20040915/i386/Makefrag
+--- gnumach-20040915.orig/i386/Makefrag 2000-11-26 15:33:20.000000000 +0100
++++ gnumach-20040915/i386/Makefrag 2004-10-26 11:27:49.000000000 +0200
+@@ -40,9 +40,6 @@
+ objfiles += busses.o cirbuf.o
+ vpath busses.c $(srcdir)/chips
+
+-# FPE emulation
+-objfiles += fpe.o
+-
+ # Mig-generated
+ objfiles += mach_i386_server.o
+
+@@ -132,11 +129,3 @@
+ rpc.h syscall_sw.h \
+ thread_status.h trap.h vm_param.h \
+ vm_types.h)
+-
+-
+-# Cheat, cheat, cheat.
+-fpe.o: fpe.b_elf
+- uudecode $<
+-vpath fpe.b_elf $(sysdep)/i386
+-
+-fpe.d:; touch $@
diff --git a/debian/patches/15_disable_qlogic_firmware.patch b/debian/patches/15_disable_qlogic_firmware.patch
new file mode 100644
index 0000000..ba2bc28
--- /dev/null
+++ b/debian/patches/15_disable_qlogic_firmware.patch
@@ -0,0 +1,44 @@
+#DPATCHLEVEL=1
+
+2004-10-27 Guillem Jover <guillem@hadrons.org>
+
+ * linux/src/drivers/scsi/qlogicisp_asm.c: Remove file with binary
+ only firmware.
+ * linux/src/drivers/scsi/qlogicisp.c: Do not include "qlogicisp_asm.c".
+ (RELOAD_FIRMWARE): Set to 0.
+ (risc_code_addr01): New variable from qlogicisp_asm.c.
+ * linux/Files: Remove linux/src/drivers/scsi/qlogicisp_asm.c.
+
+
+diff -Naur -x CVS gnumach.orig/linux/Files gnumach/linux/Files
+--- gnumach.orig/linux/Files 2002-05-23 02:06:26.000000000 +0200
++++ gnumach/linux/Files 2004-10-27 06:04:12.000000000 +0200
+@@ -198,7 +198,6 @@
+ linux/src/drivers/scsi/ppa.h
+ linux/src/drivers/scsi/qlogicfas.c
+ linux/src/drivers/scsi/qlogicfas.h
+-linux/src/drivers/scsi/qlogicisp_asm.c
+ linux/src/drivers/scsi/qlogicisp.c
+ linux/src/drivers/scsi/qlogicisp.h
+ linux/src/drivers/scsi/scripts.h
+diff -Naur -x CVS gnumach.orig/linux/src/drivers/scsi/qlogicisp.c gnumach/linux/src/drivers/scsi/qlogicisp.c
+--- gnumach.orig/linux/src/drivers/scsi/qlogicisp.c 2004-10-27 03:06:03.000000000 +0200
++++ gnumach/linux/src/drivers/scsi/qlogicisp.c 2004-10-27 06:04:45.000000000 +0200
+@@ -105,7 +105,7 @@
+ the latest firmware provided by QLogic. This may be an earlier/later
+ revision than supplied by your board. */
+
+-#define RELOAD_FIRMWARE 1
++#define RELOAD_FIRMWARE 0
+
+ /* Set the following macro to 1 to reload the ISP1020's defaults from nvram.
+ If you are not sure of your settings, leave this alone, the driver will
+@@ -433,7 +433,7 @@
+ #define MBOX_WRITE_FOUR_RAM_WORDS 0x0041
+ #define MBOX_EXEC_BIOS_IOCB 0x0042
+
+-#include "qlogicisp_asm.c"
++unsigned short risc_code_addr01 = 0x1000 ;
+
+ #define PACKB(a, b) (((a)<<4)|(b))
+