summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@debian.org>2008-02-06 11:39:52 +0000
committerSamuel Thibault <sthibault@debian.org>2008-02-06 11:39:52 +0000
commitb0b59d0f43994cce7374599d5ecfe89bdbe2bb8f (patch)
tree49dbdf257a5a993dc0f2b9fed7e157e02807eb68 /debian
parent6142ffe13d0e949bfd53eb6973e7b78ed05d99e5 (diff)
* New patch from CVS to enable Bus Mastering on triton chipsets.
- debian/patches/50_ide_bm.patch
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/50_ide_bm.patch28
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d0b3a0d..edcb36e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,8 @@ gnumach (2:1.3.99.dfsg.cvs20070809-2) unstable; urgency=low
- debian/patches/16_ide_multsect.patch
* New patch from CVS to enable multicast for IPv6.
- debian/patches/30_net_multicast.patch
+ * New patch from CVS to enable Bus Mastering on triton chipsets.
+ - debian/patches/50_ide_bm.patch
-- Guillem Jover <guillem@debian.org> Thu, 09 Aug 2007 01:45:22 +0300
diff --git a/debian/patches/50_ide_bm.patch b/debian/patches/50_ide_bm.patch
new file mode 100644
index 0000000..bb644aa
--- /dev/null
+++ b/debian/patches/50_ide_bm.patch
@@ -0,0 +1,28 @@
+Enable Bus Mastering if not enabled by BIOS (Bochs' BIOS doesn't).
+
+Index: linux/src/drivers/block/triton.c
+===================================================================
+RCS file: /cvsroot/hurd/gnumach/linux/src/drivers/block/Attic/triton.c,v
+retrieving revision 1.1
+diff -u -p -r1.1 triton.c
+--- linux/src/drivers/block/triton.c 26 Apr 1999 05:51:41 -0000 1.1
++++ linux/src/drivers/block/triton.c 6 Feb 2008 11:30:47 -0000
+@@ -632,7 +632,17 @@ void ide_init_triton (byte bus, byte fn)
+ goto quit;
+ }
+ if ((pcicmd & 4) == 0) {
+- printk("ide: BM-DMA feature is not enabled (BIOS)\n");
++ printk("ide: BM-DMA feature is not enabled (BIOS), enabling\n");
++ pcicmd |= 4;
++ pcibios_write_config_word(bus, fn, 0x04, pcicmd);
++ if ((rc = pcibios_read_config_word(bus, fn, 0x04, &pcicmd))) {
++ printk("ide: Couldn't read back PCI command\n");
++ goto quit;
++ }
++ }
++
++ if ((pcicmd & 4) == 0) {
++ printk("ide: BM-DMA feature couldn't be enabled\n");
+ } else {
+ /*
+ * Get the bmiba base address
diff --git a/debian/patches/series b/debian/patches/series
index ae20b44..0d2f695 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -11,4 +11,5 @@
24_pci_irq_fix.patch -p1
30_net_multicast.patch -p0
40_iopl_mmap.patch -p0
+50_ide_bm.patch -p0
90_autoconf_autogen.patch