summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2007-03-06 05:52:11 +0000
committerGuillem Jover <guillem@debian.org>2007-03-06 05:52:11 +0000
commitc6b0bbce253482d3ff1e2b33969acf5534bc766c (patch)
tree6e52eb79e78bffe7b6e6421fdbc95f0e025b0499 /debian/rules
parenta4dc2f8278e1f9f003e12b938234928d2ef2dce3 (diff)
Run the test suite after build. (Closes: #390872)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 17 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index e4bfb5d..5d1b403 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,12 @@ else
CFLAGS += -O2
endif
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ CHECKS :=
+else
+ CHECKS := check-gnumach check-gnumach-dbg
+endif
+
drivers := \
--enable-sis900
@@ -65,6 +71,16 @@ build-gnumach-dbg: configure-dbg
$(MAKE) -C build-dbg
+check-gnumach: build-gnumach
+ dh_testdir
+
+ $(MAKE) -C build check
+
+check-gnumach-dbg: build-gnumach-dbg
+ dh_testdir
+
+ $(MAKE) -C build-dbg check
+
clean: unpatch
dh_testdir
@@ -73,7 +89,7 @@ clean: unpatch
dh_clean
-install: build-gnumach build-gnumach-dbg
+install: build-gnumach build-gnumach-dbg $(CHECKS)
dh_testdir
dh_testroot
dh_clean -a -k