summaryrefslogtreecommitdiff
path: root/debian/patches/15_mem_obj_proxy.patch
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2006-11-01 01:46:18 +0000
committerGuillem Jover <guillem@debian.org>2006-11-01 01:46:18 +0000
commitbe37238e3eb41075a981e33530cd26c666e53552 (patch)
tree4905467b905bd22ca843f721265d5437ced6db80 /debian/patches/15_mem_obj_proxy.patch
parent8ea6d90623ee13b5e1d72fda5925b1659e79d8ad (diff)
New upstream CVS snapshot.
- Remove debian/rules.options, now unneeded with the default configure options. - debian/patches/01_gcc-4.1.patch: Removed, merged upstream. - debian/patches/00_clean_gfdl.patch: Sync. - debian/patches/05_halt_on_panic_flag.patch: Likewise. - debian/patches/10_cdromlock.patch: Likewise. - debian/patches/12_sis900.patch: Likewise. - debian/patches/13_ide_dma.patch: Likewise. - debian/patches/14_alloc_params.patch: Likewise. - debian/patches/15_mem_obj_proxy.patch: Likewise. - debian/patches/44_more_ports.patch: Likewise. - debian/patches/45_io_per_task.patch: Likewise. - debian/patches/46_io_device.patch: Likewise. - debian/patches/90_autoconf_autogen.patch: Regenerated. - debian/patches/61_vm_resident-zoned.patch: Disable for now, it's causing problems with current applied patches in CVS.
Diffstat (limited to 'debian/patches/15_mem_obj_proxy.patch')
-rw-r--r--debian/patches/15_mem_obj_proxy.patch86
1 files changed, 45 insertions, 41 deletions
diff --git a/debian/patches/15_mem_obj_proxy.patch b/debian/patches/15_mem_obj_proxy.patch
index 0700688..334db0f 100644
--- a/debian/patches/15_mem_obj_proxy.patch
+++ b/debian/patches/15_mem_obj_proxy.patch
@@ -1,5 +1,3 @@
-#DPATCHLEVEL=1
-
2005-06-06 Marcus Brinkmann <marcus@gnu.org>
* include/mach/mach4.defs: Add memory_object_create_proxy
@@ -17,21 +15,10 @@
objects.
-diff -rupN gnumach-1/Makefile.in gnumach/Makefile.in
---- gnumach-1/Makefile.in 2005-06-06 21:37:42.000000000 +0200
-+++ gnumach/Makefile.in 2005-06-07 04:08:55.000000000 +0200
-@@ -137,7 +137,7 @@ util-cfiles = putchar.c puts.c
- util-files = $(util-cfiles)
-
- # Virtual memory implementation
--vm-cfiles = $(addprefix vm_,$(vm-names)) memory_object.c
-+vm-cfiles = $(addprefix vm_,$(vm-names)) memory_object.c memory_object_proxy.c
- vm-names = debug.c external.c fault.c init.c kern.c map.c \
- object.c pageout.c resident.c user.c
- vm-files = $(vm-cfiles) memory_object_default.cli memory_object_user.cli \
-diff -rupN gnumach-1/i386/include/mach/i386/vm_types.h gnumach/i386/include/mach/i386/vm_types.h
---- gnumach-1/i386/include/mach/i386/vm_types.h 2005-06-06 21:37:55.000000000 +0200
-+++ gnumach/i386/include/mach/i386/vm_types.h 2005-06-07 04:08:55.000000000 +0200
+Index: i386/include/mach/i386/vm_types.h
+===================================================================
+--- i386/include/mach/i386/vm_types.h.orig 2006-10-15 20:39:24.000000000 +0300
++++ i386/include/mach/i386/vm_types.h 2006-10-26 00:07:22.000000000 +0300
@@ -74,6 +74,7 @@ typedef unsigned int uint32;
* e.g. an offset into a virtual memory space.
*/
@@ -40,9 +27,10 @@ diff -rupN gnumach-1/i386/include/mach/i386/vm_types.h gnumach/i386/include/mach
/*
* A vm_size_t is the proper type for e.g.
-diff -rupN gnumach-1/include/mach/mach4.defs gnumach/include/mach/mach4.defs
---- gnumach-1/include/mach/mach4.defs 2005-06-06 21:38:01.000000000 +0200
-+++ gnumach/include/mach/mach4.defs 2005-06-07 04:10:27.000000000 +0200
+Index: include/mach/mach4.defs
+===================================================================
+--- include/mach/mach4.defs.orig 1997-02-25 23:26:51.000000000 +0200
++++ include/mach/mach4.defs 2006-10-26 00:07:22.000000000 +0300
@@ -79,4 +79,34 @@ skip /* pc_sampling reserved 1*/;
skip /* pc_sampling reserved 2*/;
skip /* pc_sampling reserved 3*/;
@@ -78,9 +66,10 @@ diff -rupN gnumach-1/include/mach/mach4.defs gnumach/include/mach/mach4.defs
+ start : vm_offset_array_t;
+ len : vm_offset_array_t;
+ out proxy : mach_port_t);
-diff -rupN gnumach-1/include/mach/memory_object.h gnumach/include/mach/memory_object.h
---- gnumach-1/include/mach/memory_object.h 2005-06-06 21:38:01.000000000 +0200
-+++ gnumach/include/mach/memory_object.h 2005-06-07 04:08:56.000000000 +0200
+Index: include/mach/memory_object.h
+===================================================================
+--- include/mach/memory_object.h.orig 1997-02-25 23:26:52.000000000 +0200
++++ include/mach/memory_object.h 2006-10-26 00:07:22.000000000 +0300
@@ -46,6 +46,9 @@ typedef mach_port_t memory_object_t;
/* the object to map; used by the */
/* kernel to retrieve or store data */
@@ -91,10 +80,11 @@ diff -rupN gnumach-1/include/mach/memory_object.h gnumach/include/mach/memory_ob
typedef mach_port_t memory_object_control_t;
/* Provided to a memory manager; ... */
/* used to control a memory object */
-diff -rupN gnumach-1/kern/ipc_kobject.c gnumach/kern/ipc_kobject.c
---- gnumach-1/kern/ipc_kobject.c 2005-06-06 21:38:07.000000000 +0200
-+++ gnumach/kern/ipc_kobject.c 2005-06-07 04:08:56.000000000 +0200
-@@ -355,6 +355,9 @@ ipc_kobject_notify(request_header, reply
+Index: kern/ipc_kobject.c
+===================================================================
+--- kern/ipc_kobject.c.orig 2006-10-15 20:39:24.000000000 +0300
++++ kern/ipc_kobject.c 2006-10-26 00:07:22.000000000 +0300
+@@ -351,6 +351,9 @@ ipc_kobject_notify(request_header, reply
case IKOT_DEVICE:
return ds_notify(request_header);
@@ -104,9 +94,10 @@ diff -rupN gnumach-1/kern/ipc_kobject.c gnumach/kern/ipc_kobject.c
default:
return FALSE;
}
-diff -rupN gnumach-1/kern/ipc_kobject.h gnumach/kern/ipc_kobject.h
---- gnumach-1/kern/ipc_kobject.h 2005-06-06 21:38:07.000000000 +0200
-+++ gnumach/kern/ipc_kobject.h 2005-06-07 04:08:56.000000000 +0200
+Index: kern/ipc_kobject.h
+===================================================================
+--- kern/ipc_kobject.h.orig 1997-02-25 23:28:22.000000000 +0200
++++ kern/ipc_kobject.h 2006-10-26 00:07:22.000000000 +0300
@@ -77,9 +77,10 @@ typedef unsigned int ipc_kobject_type_t;
#define IKOT_LOCK_SET 24
#define IKOT_CLOCK 25
@@ -120,9 +111,10 @@ diff -rupN gnumach-1/kern/ipc_kobject.h gnumach/kern/ipc_kobject.h
/* Please keep ipc/ipc_object.c:ikot_print_array up to date */
#define is_ipc_kobject(ikot) (ikot != IKOT_NONE)
-diff -rupN gnumach-1/vm/memory_object_proxy.c gnumach/vm/memory_object_proxy.c
---- gnumach-1/vm/memory_object_proxy.c 1970-01-01 01:00:00.000000000 +0100
-+++ gnumach/vm/memory_object_proxy.c 2005-06-07 04:13:37.000000000 +0200
+Index: vm/memory_object_proxy.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ vm/memory_object_proxy.c 2006-10-26 00:07:22.000000000 +0300
@@ -0,0 +1,200 @@
+/* memory_object_proxy.c - Proxy memory objects for Mach.
+ Copyright (C) 2005 Free Software Foundation, Inc.
@@ -324,18 +316,20 @@ diff -rupN gnumach-1/vm/memory_object_proxy.c gnumach/vm/memory_object_proxy.c
+
+ return KERN_SUCCESS;
+}
-diff -rupN gnumach-1/vm/vm_init.c gnumach/vm/vm_init.c
---- gnumach-1/vm/vm_init.c 2005-06-06 21:38:40.000000000 +0200
-+++ gnumach/vm/vm_init.c 2005-06-07 04:08:56.000000000 +0200
+Index: vm/vm_init.c
+===================================================================
+--- vm/vm_init.c.orig 1997-02-25 23:28:36.000000000 +0200
++++ vm/vm_init.c 2006-10-26 00:07:22.000000000 +0300
@@ -81,4 +81,5 @@ void vm_mem_bootstrap()
void vm_mem_init()
{
vm_object_init();
+ memory_object_proxy_init();
}
-diff -rupN gnumach-1/vm/vm_user.c gnumach/vm/vm_user.c
---- gnumach-1/vm/vm_user.c 2005-06-06 21:38:43.000000000 +0200
-+++ gnumach/vm/vm_user.c 2005-06-07 04:08:56.000000000 +0200
+Index: vm/vm_user.c
+===================================================================
+--- vm/vm_user.c.orig 1997-02-25 23:28:37.000000000 +0200
++++ vm/vm_user.c 2006-10-26 00:07:22.000000000 +0300
@@ -275,6 +275,12 @@ kern_return_t vm_copy(map, source_addres
return KERN_SUCCESS;
}
@@ -373,5 +367,15 @@ diff -rupN gnumach-1/vm/vm_user.c gnumach/vm/vm_user.c
/*
* Perform the copy if requested
-
-
+Index: Makefrag.am
+===================================================================
+--- Makefrag.am.orig 2006-10-26 00:08:15.000000000 +0300
++++ Makefrag.am 2006-10-26 00:08:47.000000000 +0300
+@@ -123,6 +123,7 @@ libkernel_a_SOURCES += \
+ vm/vm_pageout.c \
+ vm/vm_resident.c \
+ vm/vm_user.c \
++ vm/memory_object_proxy.c \
+ vm/memory_object.c
+
+ # These device support files are always needed; the others are needed only if