summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMiles Bader <miles@gnu.org>1996-09-25 01:49:10 +0000
committerMiles Bader <miles@gnu.org>1996-09-25 01:49:10 +0000
commitd26a4ac514a043047ec82fd380b1ac7909d586aa (patch)
treebad6567201de7f7a42a884c81d2270e2f2599aac /configure.in
parent2b1458f8b939fc030a9359138cd0e3870add4ec4 (diff)
Add check for crypt function.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e62038af..6afafb12 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.9 1996/09/23 19:55:19 miles Exp $])
+AC_REVISION([$Id: configure.in,v 1.10 1996/09/25 01:49:10 miles Exp $])
AC_PREREQ(2.4) dnl Minimum Autoconf version required.
AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
@@ -42,6 +42,11 @@ AC_SUBST(CFLAGS) AC_SUBST(CPPFLAGS) AC_SUBST(LDFLAGS)
# See if there's a separate libcrypt (many systems put crypt there)
AC_CHECK_LIB(crypt, crypt, LIBCRYPT=-lcrypt)
AC_SUBST(LIBCRYPT)
+# Look for the crypt function itself (in libcrypt if possible)
+_SAVE_LIBS="$LIBS"
+LIBS="$LIBCRYPT $LIBS"
+AC_CHECK_FUNCS(crypt)
+LIBS="$_SAVE_LIBS"
if test $srcdir = .; then
# Configuring in source directory; don't create any Makefiles.