summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMark Kettenis <kettenis@gnu.org>2000-05-25 20:23:28 +0000
committerMark Kettenis <kettenis@gnu.org>2000-05-25 20:23:28 +0000
commit8288e02fb9a63ca4f1d5dc1a1491f4f94d7f27dc (patch)
tree01c6e33dce276e236a7b223beeda9ec5874ef2dd /configure.in
parentd699bf4063041c0be2e874a639880b59078eefdc (diff)
* configure.in: Add check for libio. Only enable versioning if we
found libio.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ed80813a..c0c8de61 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.18 2000/03/27 18:20:47 roland Exp $])
+AC_REVISION([$Id: configure.in,v 1.19 2000/05/25 20:23:28 kettenis Exp $])
AC_PREREQ(2.12) dnl Minimum Autoconf version required.
AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
@@ -93,7 +93,27 @@ else
hurd_cv_ld_version_script_option=no
fi
rm -f conftest*])
-VERSIONING=$hurd_cv_ld_version_script_option
+
+# See if libc was built with --enable-libio.
+AC_CACHE_CHECK([for libio],
+ hurd_cv_libio,
+ AC_TRY_COMPILE([#include <stdio.h>
+#ifndef _STDIO_USES_IOSTREAM
+# error No libio found.
+#endif],,
+ hurd_cv_libio=yes,
+ hurd_cv_libio=no))
+
+# The versions of the symbols in libthreads have to match those in
+# libc.so. Since the symbols in a libc that includes libio will be
+# versioned differently from the ones in a libc that uses stdio, this
+# isn't easy to accomplish. Instead we leave things unversioned if
+# libio isn't found.
+if test $hurd_cv_libio = yes; then
+ VERSIONING=$hurd_cv_ld_version_script_option
+else
+ VERSIONING=no
+fi
AC_SUBST(VERSIONING)