summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2003-02-15 23:57:50 +0000
committerRoland McGrath <roland@gnu.org>2003-02-15 23:57:50 +0000
commit5de299981e58c422c014ebc0ea863e63fe76dcf2 (patch)
treed05fb65994f3a2b962dd14d743e9081e30ab4a72 /configure.in
parent2065a9b5c3108bbd00add04db2384b20f836f373 (diff)
2002-10-23 Jeff Bailey <jbailey@gnu.org>
Update for Autoconf 2.54. * configure.in: Replace AC_FD_CC with AS_MESSAGE_LOG_FD. (AC_PREREQ): Require Autoconf 2.54. (AC_INIT): Update to no arguments syntax. Call AC_CONFIG_SRCDIR. (AC_OUTPUT): Update to no arguments syntax. Call AC_CONFIG_FILES. (AC_CHECK_TOOL, hurd_PROG_CC): Replace with ... (AC_PROG_CC): ... this. * aclocal.m4: Replace AC_FD_CC with AS_MESSAGE_LOG_FD. (hurd_PROG_CC, hurd_PROG_CC_WORKS): Removed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 9 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 73f253ee..8d493da5 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,8 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.34 2002/08/30 00:27:32 roland Exp $])
-AC_PREREQ(2.12) dnl Minimum Autoconf version required.
-AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
+AC_REVISION([$Id: configure.in,v 1.35 2003/02/15 23:57:50 roland Exp $])
+AC_PREREQ(2.54) dnl Minimum Autoconf version required.
+AC_INIT
+AC_CONFIG_SRCDIR([hurd/hurd_types.h]) dnl File to look for in srcdir.
AC_PREFIX_DEFAULT() dnl Default to empty prefix, not /usr/local.
@@ -75,10 +76,7 @@ AC_SUBST(enable_static_progs)
AC_PROG_INSTALL
AC_PROG_AWK
-AC_CHECK_TOOL(CC, gcc)
-# That check handles cross-compilation well, but AC_PROG_CC tests for GCC
-# and sets default CFLAGS nicely for us, so do that too.
-hurd_PROG_CC
+AC_PROG_CC
# Require GCC.
if test x$GCC != xyes; then
AC_MSG_ERROR([this code uses GNU C extensions, you must compile with GCC])
@@ -114,11 +112,11 @@ VERS_2 {
} VERS_1;
EOF
-if AC_TRY_COMMAND([eval $ac_compile 1>&AC_FD_CC]) &&
+if AC_TRY_COMMAND([eval $ac_compile 1>&AS_MESSAGE_LOG_FD()]) &&
AC_TRY_COMMAND([${CC-cc} $CFLAGS -shared -o conftest.so conftest.o
-nostartfiles -nostdlib
-Wl,--version-script,conftest.map
- 1>&AC_FD_CC]); then
+ 1>&AS_MESSAGE_LOG_FD()]); then
hurd_cv_ld_version_script_option=yes
else
hurd_cv_ld_version_script_option=no
@@ -193,7 +191,8 @@ else
echo ${file}:build.mk.in; done`"
fi
-AC_OUTPUT(config.make ${makefiles})
+AC_CONFIG_FILES([config.make ${makefiles}])
+AC_OUTPUT
dnl Local Variables:
dnl comment-start: "dnl "