summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1995-09-21 23:07:35 +0000
committerRoland McGrath <roland@gnu.org>1995-09-21 23:07:35 +0000
commit505b5018a1b667b99b5f3dd0f126b98567026563 (patch)
tree8ba44b9265b3dac6cc33c346f9032217b564c098 /configure.in
parent53ef34f26d4089dee66b27a87b5467b2813d26f9 (diff)
If not in $srcdir, produce */Makefile from build.mk.in.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1d63b3ac..7603efca 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.1 1995/09/16 18:19:43 roland Exp $])
+AC_REVISION([$Id: configure.in,v 1.2 1995/09/21 23:07:35 roland Exp $])
AC_PREREQ(2.4) dnl Minimum Autoconf version required.
AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
@@ -22,7 +22,18 @@ AC_CHECK_TOOL(MIG, mig)
dnl Let these propagate from the environment.
AC_SUBST(CFLAGS) AC_SUBST(CPPFLAGS) AC_SUBST(LDFLAGS)
-AC_OUTPUT(config.make)
+if test $srcdir = .; then
+ # Configuring in source directory; don't create any Makefiles.
+ makefiles=
+else
+ # We are configuring in a separate build tree.
+ # Create a Makefile in the top-level build directory and
+ # one for each subdirectory Makefile in the source.
+ makefiles="`cd $srcdir; for file in Makefile */Makefile; do \
+ echo ${file}:build.mk.in; done`"
+fi
+
+AC_OUTPUT(config.make ${makefiles})
dnl Local Variables:
dnl comment-start: "dnl "