summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2001-12-31 23:39:18 +0000
committerRoland McGrath <roland@gnu.org>2001-12-31 23:39:18 +0000
commit24bed25cb9cac783159fe5ce6b7c16cfb8a722cd (patch)
tree828808bc88404bd25aa609b525e070b7de9461ff /configure.in
parent5a80293aa03abe1a6ffbcd4a8dc074b5223ccf5b (diff)
2001-12-31 Roland McGrath <roland@frob.com>
* configure.in: Check mig for `retcode' keyword support. If not there, add -DRetCode=NoLong.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 24 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 730e05e5..cf117be0 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.23 2001/12/22 20:45:48 roland Exp $])
+AC_REVISION([$Id: configure.in,v 1.24 2001/12/31 23:39:18 roland Exp $])
AC_PREREQ(2.12) dnl Minimum Autoconf version required.
AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
@@ -79,6 +79,29 @@ AC_SUBST(CFLAGS) AC_SUBST(CPPFLAGS) AC_SUBST(LDFLAGS)
AC_CHECK_LIB(crypt, crypt, LIBCRYPT=-lcrypt)
AC_SUBST(LIBCRYPT)
+# See if mig groks `retcode'.
+AC_CACHE_CHECK(whether $MIG supports the retcode keyword, hurd_cv_mig_retcode,
+[cat > conftest.defs <<\EOF
+#include <mach/std_types.defs>
+#include <mach/mach_types.defs>
+subsystem foobar 1000;
+type reply_port_t = polymorphic | MACH_MSG_TYPE_PORT_SEND_ONCE
+ ctype: mach_port_t;
+simpleroutine foobar_reply (
+ reply_port: reply_port_t;
+ err: kern_return_t, RetCode);
+EOF
+if AC_TRY_COMMAND([CC="${CC}" ${MIG-false} -n conftest.defs 1>&AC_FD_CC]); then
+ hurd_cv_mig_retcode=yes
+else
+ hurd_cv_mig_retcode=no
+fi
+rm -f conftest*])
+if test $hurd_cv_mig_retcode = no; then
+ dnl NoLong is a harmless syntactically equivalent flag.
+ AC_DEFINE(RetCode, NoLong)
+fi
+
# See if --version-script is available.
AC_CACHE_CHECK(for ld --version-script, hurd_cv_ld_version_script_option, [dnl
cat > conftest.c <<\EOF