summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in59
1 files changed, 28 insertions, 31 deletions
diff --git a/configure.in b/configure.in
index b845204..b6691f5 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Configure script for GNU Mach.
-dnl Copyright 1997, 1998, 1999 Free Software Foundation, Inc.
+dnl Copyright 1997, 1998, 1999, 2004 Free Software Foundation, Inc.
dnl Permission to use, copy, modify and distribute this software and its
dnl documentation is hereby granted, provided that both the copyright
@@ -12,11 +12,11 @@ dnl "AS IS" CONDITION. THE FREE SOFTWARE FOUNDATION DISCLAIMS ANY
dnl LIABILITY OF ANY KIND FOR ANY DAMAGES WHATSOEVER RESULTING FROM THE
dnl USE OF THIS SOFTWARE.
-AC_INIT(kern/ipc_kobject.c)
-AC_PREREQ(2.12)
+m4_include([version.m4])
-VERSION=1.3
-AC_SUBST(VERSION)
+AC_INIT([PACKAGE], [VERSION], [bug-hurd@gnu.org], [gnumach])
+AC_CONFIG_SRCDIR([kern/ipc_kobject.c])
+AC_PREREQ(2.57)
#
# Deduce output var `systype' from configuration parms.
@@ -28,27 +28,23 @@ i[[3456]]86) systype=i386 ;;
*) AC_MSG_ERROR([unsupported CPU type]) ;;
esac
-case "$host_os" in
-gnu*) ;;
-*) AC_MSG_ERROR([sorry, this is the gnu os, not $host_os]) ;;
-esac
-
-AC_SUBST(systype)
-AC_SUBST(cross_compiling)
+AC_SUBST([systype])
+AC_SUBST([cross_compiling])
# Default prefix is / for the kernel.
-AC_PREFIX_DEFAULT()
+AC_PREFIX_DEFAULT([])
#
# Options
#
-AC_ARG_ENABLE(kdb,
-[ --enable-kdb enable use of in-kernel debugger],
-[test "x$enableval" = xno || AC_DEFINE(MACH_KDB)])
+AC_ARG_ENABLE([kdb],
+AS_HELP_STRING([--enable-kdb], [enable use of in-kernel debugger]),
+[test "x$enableval" = xno || AC_DEFINE([MACH_KDB], [1], [enable use of in-kernel debugger])])
-AC_ARG_ENABLE(kmsg,
-[ --enable-kmsg enable use of kmsg device [default=yes]],
-[test "x$enableval" = xno || AC_DEFINE(MACH_KMSG)], [AC_DEFINE(MACH_KMSG)])
+AC_ARG_ENABLE([kmsg],
+AS_HELP_STRING([--enable-kmsg], [enable use of kmsg device [[default=yes]]]),
+[test "x$enableval" = xno || AC_DEFINE([MACH_KMSG], [], [enable use of kmsg device])],
+ [AC_DEFINE([MACH_KMSG], [], [enable use of kmsg device])])
#
# Programs
@@ -56,23 +52,24 @@ AC_ARG_ENABLE(kmsg,
AC_PROG_INSTALL
AC_PROG_AWK
+AC_PROG_CC
-AC_CHECK_TOOL(CC, gcc)
-# That check handles cross-compilation well, but AC_PROG_CC tests for GCC
-# and sets default CFLAGS nicely for us, so do that too.
-AC_PROG_CC_LOCAL
-
-AC_CHECK_TOOL(LD, ld)
-AC_CHECK_TOOL(NM, nm)
+AC_CHECK_TOOL([LD], [ld])
+AC_SUBST([LDFLAGS])
+AC_CHECK_TOOL([NM], [nm])
-AC_CHECK_TOOL(MIG, mig, mig)
+AC_CHECK_TOOL([MIG], [mig], [mig])
# Set up `machine' link in build directory for easier header file location.
-AC_LINK_FILES(${systype}/${systype},machine)
+AC_CONFIG_LINKS([machine:${systype}/${systype}])
+
+AC_CONFIG_SUBDIRS([linux])
# Do machine-specific configuration last so that it can override anything
# set above if necessary.
+if test "$systype" = i386; then
+ AC_CONFIG_SUBDIRS([i386])
+fi
-AC_CONFIG_SUBDIRS(linux ${systype})
-
-AC_OUTPUT(Makefile version.c doc/Makefile)
+AC_CONFIG_FILES([Makefile version.c doc/Makefile])
+AC_OUTPUT