summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Bushnell <thomas@gnu.org>1997-04-23 18:07:36 +0000
committerThomas Bushnell <thomas@gnu.org>1997-04-23 18:07:36 +0000
commit8224c19990c4e8098ceac4cbd391603a76252014 (patch)
tree0255fc1cad1f15b62e8b81ad8a7410df005dbeb5 /configure.in
parent5989dac3caaa1e76896f8ec70128dba93a5ecccc (diff)
Wed Apr 23 13:21:23 1997 Thomas Bushnell, n/BSG <thomas@gnu.ai.mit.edu>
* configure.in (BUILD_CC): Use AC_CHECK_PROGS, not AC_CHECK_PROG, since we are checking multiple names. * configure.in (kdb): New --enable option. * Makefile.in (DEFINES): Add @DEFS@. * Makefile.in (clean, distclean, mostlyclean, maintainter-clean): New targets. (all-archs-configures): New variable. (MIG): Change to ./local-mig. (./local-mig): Change to build this instead of ./mig (check-clib-routines): Use nm -g in case there are local symbols. Suggested by Matthew Wilcox (willy@odie.barnet.ac.uk). Fri Apr 18 15:25:10 1997 Thomas Bushnell, n/BSG <thomas@gnu.ai.mit.edu> * configure.in: Add AC_PREREQ for version 2.12. * i386/Drivers.in: Likewise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1683d3f..36c8edc 100644
--- a/configure.in
+++ b/configure.in
@@ -14,6 +14,7 @@ dnl USE OF THIS SOFTWARE.
AC_INIT(kern/ipc_kobject.c)
+AC_PREREQ(2.12)
#
# Deduce output var `systype' from configuration parms.
@@ -37,6 +38,11 @@ AC_SUBST(cross_compiling)
AC_PREFIX_DEFAULT()
#
+# Options
+#
+AC_ARG_ENABLE(kdb, Enable use of in-kernel debugger, AC_DEFINE(MACH_KDB))
+
+#
# Programs
#
AC_PROG_CC_LOCAL
@@ -45,7 +51,7 @@ AC_PROG_INSTALL
AC_CHECK_TOOL(MIG, mig, mig)
if test $cross_compiling = yes; then
- AC_CHECK_PROG(BUILD_CC, gcc cc)
+ AC_CHECK_PROGS(BUILD_CC, gcc cc)
CC=$BUILD_CC
fi