summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Schwinge <tschwinge@gnu.org>2006-01-31 09:21:05 +0000
committerThomas Schwinge <tschwinge@gnu.org>2009-06-18 00:26:31 +0200
commit70b84c83f21a5943a291e86520e02f676517e644 (patch)
tree3532ba64b621bd7cc568a4d7853d57abe7c397ee /configure.in
parent3a52c9edfa90e81f19b208e0c289072dcb2f24c8 (diff)
2006-01-31 Thomas Schwinge <tschwinge@gnu.org>
Cleanup of GNU Mach's build system. The system dependend parts are now handeled by the respective Makefile and no longer by the top-level one. * configure, i386/configure, i386/linux/configure, linux/configure: Regenerated. * Makefile.in: Various cleanups. (mach/machine, mach_machine): Targets removed. (AWK, CC, CFLAGS, CPPFLAGS, DEFINES, INCLUDES, INSTALL, INSTALL_DATA) (INSTALL_PROGRAM, LD, MIG, MIGFLAGS, NM): Variables moved into Makerules.in. Do not include $(sysdep)/Makefrag anymore. (all, check, clean, distclean, mostlyclean, maintainer-clean, install) (install-headers, install-kernel): Recurse into the system dependend subdirectory. (check): Add a basic test using mbchk. (clean, distclean): Be more explicit in what to delete. ($(systype)/%): New target. (kernel.o): Incorporate the system dependend archive. (installed-sysdep-headers-names, $(installed-sysdep-headers-names)): Variable and target moved into the system dependend Makefile.in. (install-headers, mkheaderdirs): Don't care for the system dependend header files. (%.symc, %.symc.o, %.h, %_user.c, %_interface.h, %_server.c): Targets moved into Makerules.in. Inclusion of dependency files: Likewise. (%.migs_d, %.migu_d, %.migsh_d, %.miguh_d, make-deps, %.d): Likewise. Include Makerules. * Makerules.in: New file, mainly based on Makefile.in. * configure.in: Do not substitute cross_compiling and not explicitly substitute LDFLAGS. Check for cpp, ranlib, ar and mbchk. Care for the mach/machine symbolic link. Add Makerules as a config file. * i386/Makefile.in: Various cleanups. Merge i386/Makefrag and the system dependent stuff from Makefile.in into this file. (all, check, install, install-headers, install-kernel): Recurse into the system dependend subdirectory. (sysdep.o): transformed to the new target sysdep.a. (linux/linux.o): Target removed. (clean, distclean): Be more explicit in what to delete. (linux/%): New target. (install-headers): Install the system dependend header files. (mkheaderdirs): New target. Include the top-level Makerules. * i386/Makefrag: File removed. * i386/Makerules.in: New file. * i386/configure.in: Synchronize AC_INIT to the top-level definition. Do not check for ld and make. Add Makerules as a config file. * i386/linux/Makefile.in: Various cleanups. Replace linux-objs with objfiles. (check, install, install-headers, install-kernel): New empty targets. Don't care about linux-flags if no_deps is true. Inclusion of dependency files removed and instead... Include the top-level Makerules. * i386/linux/Makerules.in: New file. * i386/linux/configure.ac: Synchronize AC_INIT to the top-level definition. Do not check for gcc and ld. Do not explicitly substitute LDFLAGS. Add Makerules as a config file. * linux/configure.in: Synchronize AC_INIT to the top-level definition. Do not create directories using a dummy file. * linux/dummy.in: File removed. * ddb/db_access.h: Include <machine/vm_param.h> instead of "vm_param.h". * kern/bootstrap.c: Likewise. * kern/thread.c: Likewise. * vm/vm_kern.c: Likewise. * vm/vm_object.c: Likewise. * vm/vm_resident.c: Likewise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index b6691f5..2f631e2 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Configure script for GNU Mach.
-dnl Copyright 1997, 1998, 1999, 2004 Free Software Foundation, Inc.
+dnl Copyright 1997, 1998, 1999, 2004, 2006 Free Software Foundation, Inc.
dnl Permission to use, copy, modify and distribute this software and its
dnl documentation is hereby granted, provided that both the copyright
@@ -29,7 +29,6 @@ i[[3456]]86) systype=i386 ;;
esac
AC_SUBST([systype])
-AC_SUBST([cross_compiling])
# Default prefix is / for the kernel.
AC_PREFIX_DEFAULT([])
@@ -53,15 +52,22 @@ AS_HELP_STRING([--enable-kmsg], [enable use of kmsg device [[default=yes]]]),
AC_PROG_INSTALL
AC_PROG_AWK
AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_RANLIB
+AC_CHECK_TOOL([AR], [ar])
AC_CHECK_TOOL([LD], [ld])
-AC_SUBST([LDFLAGS])
AC_CHECK_TOOL([NM], [nm])
AC_CHECK_TOOL([MIG], [mig], [mig])
-# Set up `machine' link in build directory for easier header file location.
-AC_CONFIG_LINKS([machine:${systype}/${systype}])
+AC_CHECK_PROG([MBCHK], [mbchk], [mbchk], :)
+
+# Set up `machine' and `mach/machine' links in the build directory for easier
+# header file location.
+AC_CONFIG_LINKS([machine:${systype}/${systype}
+ mach/machine:${systype}/include/mach/${systype}])
+
AC_CONFIG_SUBDIRS([linux])
@@ -71,5 +77,5 @@ if test "$systype" = i386; then
AC_CONFIG_SUBDIRS([i386])
fi
-AC_CONFIG_FILES([Makefile version.c doc/Makefile])
+AC_CONFIG_FILES([Makefile Makerules version.c doc/Makefile])
AC_OUTPUT