summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Schwinge <tschwinge@gnu.org>2006-09-19 23:12:49 +0000
committerThomas Schwinge <tschwinge@gnu.org>2009-06-18 00:26:41 +0200
commit65be2f5e021eb7a193be0b1314a1482e50743ba2 (patch)
tree719f18259080affd71636c0ad74b9fc1f2b67462 /configure.in
parent9d9f61b8b9ad2c01182f11b470c20edf30702a4f (diff)
2006-09-20 Thomas Schwinge <tschwinge@gnu.org>
* Drivers.macros (AC_DRIVER_ALIAS): Remove definition. (AC_DRIVER): Extend to take a `description' parameter and consider `$enable_default_device_drivers'. (AC_DRIVER_nodef): New definition. * configure.in (options kdb, kmsg): Remove redundancy. * i386/configure.in (option default-device-drivers): New option. (option lpr): Consider `$enable_default_device_drivers'. * i386/linux/configure.ac: Rework substantially. Remove all aliases. Rename some of the device driver options. (option default-device-drivers): New option. (linux_DRIVER): Take care about a `description' parameter and don't invoke AC_DRIVER_ALIAS. (linux_DRIVER_nodef): New definition. Adopt all usages of AC_DRIVER and linux_DRIVER to provide a `description' parameter. (g_NCR5380, NCR53c406a, eata_dma, wavelan, atp): Change from AC_DRIVER to AC_DRIVER_nodef to have these device drivers disabled by default. * doc/mach.texi: Add a note about the outdatedness to the configuration option table. * i386/README-Drivers: Update.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 0a0baeb..539c54d 100644
--- a/configure.in
+++ b/configure.in
@@ -37,13 +37,16 @@ AC_PREFIX_DEFAULT([])
# Options
#
AC_ARG_ENABLE([kdb],
-AS_HELP_STRING([--enable-kdb], [enable use of in-kernel debugger]),
-[test "x$enableval" = xno || AC_DEFINE([MACH_KDB], [1], [enable use of in-kernel debugger])])
+AS_HELP_STRING([--enable-kdb], [enable use of in-kernel debugger]))
+[if test x"$enable_kdb" = xyes; then]
+ AC_DEFINE([MACH_KDB], [1], [enable use of in-kernel debugger])
+[fi]
AC_ARG_ENABLE([kmsg],
-AS_HELP_STRING([--enable-kmsg], [enable use of kmsg device [[default=yes]]]),
-[test "x$enableval" = xno || AC_DEFINE([MACH_KMSG], [], [enable use of kmsg device])],
- [AC_DEFINE([MACH_KMSG], [], [enable use of kmsg device])])
+AS_HELP_STRING([--disable-kmsg], [disable use of kmsg device]))
+[if test x"$enable_kmsg" != xno; then]
+ AC_DEFINE([MACH_KMSG], [], [enable use of kmsg device])
+[fi]
#
# Programs