summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Bushnell <thomas@gnu.org>1997-03-24 21:53:03 +0000
committerThomas Bushnell <thomas@gnu.org>1997-03-24 21:53:03 +0000
commit30b32d2ccbf95436b642e6208d6829dcf68981fa (patch)
tree481af37a46b22473db7cadf280a6b5466136d726 /configure.in
parent455c9e455d124e3359d8f9e16ffe111178589e6f (diff)
prerelease work
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in45
1 files changed, 45 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..aef8c73
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,45 @@
+dnl Configure script for GNU Mach.
+dnl Copyright 1997 Free Software Foundation, Inc.
+dnl This file is part of GNU Mach. Redistribution terms are not yet decided.
+
+AC_INIT(kern/ipc_kobject.c)
+
+#
+# Deduce output var `systype' from configuration parms.
+#
+AC_CANONICAL_HOST
+
+case "$host_cpu" in
+i[[345]]86) systype=i386 ;;
+*) AC_MSG_ERROR([unsupported CPU type]) ;;
+esac
+
+AC_SUBST(systype)
+AC_SUBST(cross_compiling)
+
+# Default prefix is / for the kernel.
+AC_PREFIX_DEFAULT()
+
+#
+# Programs
+#
+AC_PROG_CC
+AC_PROG_AWK
+AC_PROG_INSTALL
+AC_PROG_LEX
+AC_PROG_YACC
+AC_CHECK_TOOL(MIG, mig, mig)
+
+if test $host != $build; then
+ AC_CHECK_PROG(BUILD_CC, gcc cc)
+fi
+
+# Set up `machine' link in build directory for easier header file location.
+AC_LINK_FILES(${systype}/${systype},machine)
+
+# Do machine-specific configuration last so that it can override anything
+# set above if necessary.
+
+AC_CONFIG_SUBDIRS($systype)
+
+AC_OUTPUT(Makefile)