summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/libpthread_weak_inline.patch47
2 files changed, 49 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 36fd9f59..57ccafd4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ hurd (20050513-4+SVN) unreleased; urgency=low
McGrath, taken from CVS.
* debian/rules (CC): Removed.
* debian/control (Build-Depends): Removed gcc-3.3.
+ * debian/patches/libpthread_weak_inline.patch: New patch by Neal
+ Walfield.
-- Michael Banck <mbanck@debian.org> Sat, 24 Sep 2005 13:34:26 +0200
diff --git a/debian/patches/libpthread_weak_inline.patch b/debian/patches/libpthread_weak_inline.patch
new file mode 100644
index 00000000..13e1cc90
--- /dev/null
+++ b/debian/patches/libpthread_weak_inline.patch
@@ -0,0 +1,47 @@
+Index: libpthread/sysdeps/generic/bits/mutex.h
+===================================================================
+RCS file: /cvsroot/hurd/hurd/libpthread/sysdeps/generic/bits/mutex.h,v
+retrieving revision 1.3
+diff -u -p -r1.3 mutex.h
+--- libpthread/sysdeps/generic/bits/mutex.h 12 May 2005 20:55:38 -0000 1.3
++++ libpthread/sysdeps/generic/bits/mutex.h 10 Dec 2005 19:45:49 -0000
+@@ -75,7 +75,8 @@ pthread_mutex_init (struct __pthread_mut
+ struct __pthread_mutex initialized_mutex = __PTHREAD_MUTEX_INITIALIZER;
+
+ extern int _pthread_mutex_init (struct __pthread_mutex *,
+- const pthread_mutexattr_t *);
++ const pthread_mutexattr_t *)
++ __attribute__ ((weak));
+
+ if (attr)
+ return _pthread_mutex_init (__mutex, attr);
+@@ -87,7 +88,8 @@ pthread_mutex_init (struct __pthread_mut
+ _EXTERN_INLINE int
+ pthread_mutex_destroy (struct __pthread_mutex *__mutex)
+ {
+- extern int _pthread_mutex_destroy (struct __pthread_mutex *);
++ extern int _pthread_mutex_destroy (struct __pthread_mutex *)
++ __attribute__ ((weak));
+
+ if (__mutex->attr || __mutex->data)
+ return _pthread_mutex_destroy (__mutex);
+@@ -98,7 +100,8 @@ pthread_mutex_destroy (struct __pthread_
+ _EXTERN_INLINE int
+ __pthread_mutex_lock (struct __pthread_mutex *__mutex)
+ {
+- extern int _pthread_mutex_lock (struct __pthread_mutex *);
++ extern int _pthread_mutex_lock (struct __pthread_mutex *)
++ __attribute__ ((weak));
+
+ if (__mutex->attr == NULL
+ && __mutex->data == NULL
+@@ -111,7 +114,8 @@ __pthread_mutex_lock (struct __pthread_m
+ extern __inline int
+ __pthread_mutex_trylock (struct __pthread_mutex *__mutex)
+ {
+- extern int _pthread_mutex_trylock (struct __pthread_mutex *);
++ extern int _pthread_mutex_trylock (struct __pthread_mutex *)
++ __attribute__ ((weak));
+
+ if (__mutex->attr == NULL
+ && __mutex->data == NULL)