summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/pflocal-port-leak.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index df10c613..39b21a4c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,7 @@
hurd (20080607-4) UNRELEASED; urgency=low
[Samuel Thibault]
- * debian/patches/pflocal-port-leak.patch: New patch to fix a port leak in
+ * debian/patches/pflocal-port-leak.patch: New patch to fix port leaks in
pflocal which was making tcl-related builds hang.
-- Michael Banck <mbanck@debian.org> Sat, 12 Jul 2008 16:45:36 +0200
diff --git a/debian/patches/pflocal-port-leak.patch b/debian/patches/pflocal-port-leak.patch
index c967e8e5..7b9f8c86 100644
--- a/debian/patches/pflocal-port-leak.patch
+++ b/debian/patches/pflocal-port-leak.patch
@@ -34,3 +34,15 @@ diff -u -p -r1.24 socket.c
return 0;
}
+@@ -323,7 +324,10 @@ S_socket_send (struct sock_user *user, s
+ source_addr, data, data_len,
+ control, control_len, ports, num_ports,
+ amount);
+- pipe_release_writer (pipe);
++ if (dest_sock)
++ pipe_release_reader (pipe);
++ else
++ pipe_release_writer (pipe);
+ }
+
+ if (err)